最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > DMI指标 > 通达信DMI组合指标公式

通达信DMI组合指标公式

来源:网络 点击: 时间:2018-08-16

VAR1:=(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100;
牛:SMA(VAR1,7,1);
VAR2:=SMA(牛,5,1);
熊:IF(CROSS(牛,VAR2) AND CROSS(MA(C,5),MA(C,13) AND 牛>50),VAR2*2,VAR2);
DRAWBAND(牛,RGB(205,92,92),熊,RGB(28,134,238));
N:=14;M:=6;
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:DMP*100/TR COLORMAGENTA;
MDI:=DMM*100/TR COLORGREEN;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
STICKLINE(ADX>=ADXR,ADX,ADXR,3,0),COLOR800040;
STICKLINE(ADX关注:STICKLINE(BARSLAST(CROSS(MDI,PDI))<5 AND MDI>PDI AND ADXADXR*0.97,ADX,ADXR,2,0) COLORRED;
10;90;
FVAR1:=REF(CLOSE,2);
会员专用: SMA(MAX(CLOSE-FVAR1,0),7,1)/SMA(ABS(CLOSE-FVAR1),7,1)*100,COLORYELLOW;
{一、PDI>MDI且趋势向上;二、ADX;ADXR在PDI及MDI中间金叉 }
走强:DRAWTEXT(CROSS(ADX,ADXR) AND PDI>MDI AND PDI>REF(PDI,1) AND ADX>REF(ADX,1) AND BETWEEN(ADX,MDI,PDI) AND ADXR>REF(ADXR,1),ADXR*0.98,'走强'),COLORYELLOW;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top