最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > KDJ指标 > 通达信看灯行指标公式

通达信看灯行指标公式

来源:网络 点击: 时间:2019-05-14

{1-MACD30分线}
DIF30:=(EMA(CLOSE,12/4)-EMA(CLOSE,26/4));
DEA30:=(EMA(DIF30,9/4));
彩灯指路:DIF30,NODRAW,COLORYELLOW;
STICKLINE(IF(DIF30>=DEA30,10.5,DRAWNULL),10.5,13,5,0),COLORMAGENTA;
STICKLINE(IF(DIF30DRAWTEXT(CURRBARSCOUNT=1,13.2,'★M30F'),COLORMAGENTA;
{2-MACD60分线}
DIF60:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
DEA60:=EMA(DIF60,9/2);
STICKLINE(IF(DIF60>=DEA60,7.6,DRAWNULL),7.6,10.1,5,0),COLORYELLOW;
STICKLINE(IF(DIF60DRAWTEXT(CURRBARSCOUNT=1,10.3,'★M60F'),COLORYELLOW;
{3-MACD日线}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
STICKLINE(IF(DIF>=DEA,4.7.2,DRAWNULL),4.7,7.2,5,0),COLORRED;
STICKLINE(IF(DIFDRAWTEXT(CURRBARSCOUNT=1,7.2,'★M日线'),COLORRED;
{4-KDJ日线}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(IF(J>=K,1.6,DRAWNULL),1.6,4.3,5,0),COLORBLUE;
STICKLINE(IF(JDRAWTEXT(CURRBARSCOUNT=1,4.3,'★K日线'),COLORLIBLUE;
{5-MACD周线}
周MD:=MACD.DIF#WEEK;
周MA:=MACD.DEA#WEEK;
STICKLINE(IF(周MD>=周MA,-1.3,DRAWNULL),-1.3,1.2,5,0),COLORBROWN;
STICKLINE(IF(周MD<周MA,-1.3,DRAWNULL),-1.3,1.2,5,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,1.2,'★M周线'),COLORBROWN;
{6-KDJ周线}
周K:="KDJ.K#WEEK" ;
周D:="KDJ.D#WEEK" ;
STICKLINE(IF(周K>=周D,-4.2,DRAWNULL),-4.2,-1.7,5,0),COLORLIMAGENTA;
STICKLINE(IF(周K<周D,-4.2,DRAWNULL),-4.2,-1.7,5,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,-1.7,'★K周线'),COLORLIMAGENTA;

通达信看灯行指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top