最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > KDJ指标 > 大智慧改进的KDJ指标公式

大智慧改进的KDJ指标公式

来源:网络 点击: 时间:2019-03-26

N:=5;
M1:=3;
M2:=3;
ZC:=IF(BARPOS=1,1,DAYS1970-DAYS1970[1]<>WEEKDAY-WEEKDAY[1]);
{上市第一日ZC取1,每周初交易日取1,其他交易日取0 }
M:=BARSLAST(ZC)+1; { 最后一周交易日 }
周初标记:=DAYS1970-DAYS1970[1]<>WEEKDAY-WEEKDAY[1];
A:=IF(BARPOS=1,1,周初标记);
WO:=if(m=1,o,ref(o,m-1));
WC:=c;
WH:=if(m=1,h,hhv(h,m));
WL:=if(m=1,l,llv(l,m));
VAR1:=WEEKDAY>REF(WEEKDAY,1);
VAR2:=WEEKDAYZRSV:=(CLOSE-MIN(LLV(WL,SUMBARS(VAR2,1)),LLV(WL,SUMBARS(VAR2,n))))
/(MAX(HHV(WH,SUMBARS(VAR2,1)),HHV(WH,SUMBARS(VAR2,n)))-
MIN(LLV(WL,SUMBARS(VAR2,1)),LLV(WL,SUMBARS(VAR2,n))))*100;
ZK:SMA(ZRSV,SUMBARS(VAR2,m1)-SUMBARS(VAR2,1),1),COLORWHITE;
ZD:SMA(ZK,SUMBARS(VAR2,m2)-SUMBARS(VAR2,1),1),COLORYELLOW;
ZJ:3*ZK-2*ZD,COLORMAGENTA,LINETHICK1;

大智慧改进的KDJ指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top