最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > MACD指标 > 同花顺经典MACD指标公式

同花顺经典MACD指标公式

来源:网络 点击: 时间:2019-02-25

DRAWGBKLAST(C>0,STRIP(RGB(140,140,130),RGB(120,120,110),1));
DIF:=(EMA(CLOSE,6/2)-0.7*EMA(CLOSE,6)-0.3*EMA(CLOSE,12))*100;
PARTLINE(DIF,DIF>REF(DIF,1),RGB(250,10,250),DIF<=REF(DIF,1),RGB(10,250,250)),LINETHICK2;
DEA:EMA(DIF,5),Color1E67FF,LINETHICK2;
MACD:=(DIF-DEA)*2,COLORSTICK;
A:=MACD;
KDIF:=3*(DIF-DEA);
KDEA:=SMA(KDIF,5,2);
买卖力:=2*(KDIF-KDEA),Color15FFFF;
均衡力:SMA(买卖力,4,2),ColorFFFFFF,LINETHICK1;
STICKLINE(A>REF(A,1) AND a>=0,0,A,8,0),Color0000B5;
STICKLINE(A>REF(A,1) AND a>=0,0,A,6,0),Color0000D2;
STICKLINE(A>REF(A,1) AND a>=0,0,A,4,0),Color0000F0;//红
STICKLINE(A>REF(A,1) AND a<0,0,A,8,0),Color00B5B5;
STICKLINE(A>REF(A,1) AND a<0,0,A,6,0),Color00D2D2;
STICKLINE(A>REF(A,1) AND a<0,0,A,4,0),Color00F0F0;//黄
STICKLINE(A<=REF(A,1) AND a>=0,0,a,8,0),ColorB4B4B4;
STICKLINE(A<=REF(A,1) AND a>=0,0,a,6,0),ColorD2D2D2;
STICKLINE(A<=REF(A,1) AND a>=0,0,a,4,0),ColorF0F0F0;//灰
STICKLINE(A<=REF(A,1) AND a<0,0,A,8,0),Color00B500;
STICKLINE(A<=REF(A,1) AND a<0,0,A,6,0),Color00D200;
STICKLINE(A<=REF(A,1) AND a<0,0,A,4,0),Color00F000;//绿
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
DEA高点延长线:IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),ColorFF2626,LINETHICK1;
DEA低点延长线:IF(DIFA1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.13,8,0),Color8B17FF;
DRAWLINE(A1=0,DEA,底背离,DEA,0),Color8B17FF,linethick1;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),ColorD50000,linethick1;

同花顺经典MACD指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top