最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > MACD指标 > 大智慧九全MACD指标公式

大智慧九全MACD指标公式

来源:网络 点击: 时间:2018-08-22

INPUT:N(9,1,9);
{基本设定}
{CCI-14}
TYP:= (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
{RSI-12}
LC:= REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
{RSV-9}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
{BBI}
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
{BIAS-12}
BIAS:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
{OBV}
OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE{参数设定}
VARC:=IF(N=1,CCI,IF(N=2,RSI,IF(N=3,RSV,IF(N=4,BBI,IF(N=5,BIAS,IF(N=6,OBV,IF(N=7,VOL,IF(N=8,AMOUNT,C))))))));
{九全MACD}
DIFF:EMA(VARC,12)-EMA(VARC,26);
DEA: EMA(DIFF,9);
MACD: 2*(DIFF-DEA),COLORSTICK;
{提示}
IF N=1 THEN BEGIN
DRAWTEXTREL(15,40,'CCI-MACD'),color00FF00;
END;
IF N=2 THEN BEGIN
DRAWTEXTREL(15,40,'RSI-MACD'),color00FF00;
END;
IF N=3 THEN BEGIN
DRAWTEXTREL(15,40,'RSV-MACD'),color00FF00;
END;
IF N=4 THEN BEGIN
DRAWTEXTREL(15,40,'BBI-MACD'),color00FF00;
END;
{www.gUPang.com 老K股票学习网_最新股票指标公式}
IF N=5 THEN BEGIN
DRAWTEXTREL(15,40,'BIAS-MACD'),color00FF00;
END;
IF N=6 THEN BEGIN
DRAWTEXTREL(15,40,'能量潮-MACD'),color00FF00;
END;
IF N=7 THEN BEGIN
DRAWTEXTREL(15,40,'成交量-MACD'),color00FF00;
END;
IF N=8 THEN BEGIN
DRAWTEXTREL(15,40,'成交额-MACD'),color00FF00;
END;
IF N=9 THEN BEGIN
DRAWTEXTREL(15,40,'标准-MACD'),color00FF00;
END;

大智慧九全MACD指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top