最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > MACD指标 > 通达信深化MACD指标公式

通达信深化MACD指标公式

来源:网络 点击: 时间:2019-02-13

SHORT:=12;
LONG:=26;
M:=9;
DIFF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIFF,M),COLORGREEN,LINETHICK2;
MACD:2*(DIFF-DEA),LINETHICK0;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,2,1),COLORRED;
STICKLINE(MACD>=0 AND MACDSTICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,1),COLORYELLOW;
STICKLINE(MACD<0 AND MACDOBV:=DEA;
P:=10;
A1:=REF(OBV,P)=HHV(OBV,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(OBV,P)=LLV(OBV,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
上:=REF(OBV,BARSLAST(D1)),COLORFF00FF,NODRAW;
下:=REF(OBV,BARSLAST(D2)),COLOR00FF00,NODRAW;
向上:=CROSS(OBV,上*1.01),NODRAW;
{www.gUPaNg.com 老K股票学习网_最新股票指标公式}
相对能量:(OBV-下)/(上-下)*100,COLORYELLOW,NODRAW;
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
DRAWLINE(D1,OBV,S11,OBV,1),COLORYELLOW;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,OBV,U11,OBV,1),COLOR00FF00;
STICKLINE(C>0,下,下,1,0),COLOR00FF00;
STICKLINE(C>0,上,上,1,0),COLORFF00FF;
DRAWTEXT(CROSS(OBV,上*1.01),上,上),COLORYELLOW;
DRAWTEXT(CROSS(下*0.99,OBV),下,下),COLORYELLOW;
DRAWICON(D1,OBV,1);
DRAWICON(D2,OBV,2);

通达信深化MACD指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top