最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > MACD指标 > 大智慧MACD金叉背离指标公式

大智慧MACD金叉背离指标公式

来源:网络 点击: 时间:2018-08-24

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:2*(DIF-DEA),COLORSTICK;
STICKLINE(MACD>0,MACD, 0, 0, 1),color0055cc;
STICKLINE(MACD<0,MACD, 0, 0, 1),Colordddd00;
STICKLINE(MACD0,0,MACD,0.1,0),COLORYELLOW;
DRAWICON(BARSTATUS=2 AND MACD>REF(MACD,1),HHV(MACD,35), 7),VALIGN2;
DRAWICON(BARSTATUS=2 AND MACDPARTLINE(DIF,DIF>ref(DIF,1),RGB(255,50,0),DIFPARTLINE(MACD,MACD>0,RGB(205,100,100),MACD<0,RGB(0,200,0)),COLORSTICK;
VAR1:=HHV(DEA,60);
VAR2:=LLV(DEA,100);
VAR3:=DEA-(DIF-DEA);
上轨:IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1);
下轨:IF(DIF主升:= DIF>0 AND DIF>DEA;
FILLRGN(DIF,DEA,DIF>DEA,RGB(130,0,0),DIFFILLRGN(DIF,DEA,主升,RGB(100,0,0));
低金:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低金,0,-0.10,6,0),COLORYELLOW;
DRAWTEXT(低金,-0.05,' 低金'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二金:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二金,0,-0.10,6,0),ColorFF00FF;
DRAWICON(二金,dea*1.04,13) ;
DRAWTEXT(二金,-0.08,' 二金'),ColorFF00FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.13,6,0),Colorred;
DRAWTEXT(底背离,dea,' 底背离'),Colorred;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
{www.gUPaNg.com 老K股票学习网_最新股票指标公式}
顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);
DRAWTEXT(顶背离,dea,' 顶背离'),Colorgreen;
a1:=DIF<0 and DEA<0;
a2:=a1>REF(a1,1);
a3:=BARSLAST(a2);
a4:=COUNT(DEA>0 and DIF>0,a3)=0;
a5:=CROSS(DIF,DEA);{金叉}
a6:=BARSLAST(a5);
a7:=REF(a6,a6+1)+a6;
a8:=(DiF+DEA)/2;
a9:=(HIGH+LOW)/2;
a10:=a5 and a7REF(a8,a7) and a90;
DRAWTEXT(a10,dif*0.95,'★'),COLORyellow;

大智慧MACD金叉背离指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top