最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > MACD指标 > 飞狐MACD红绿柱面积指标公式

飞狐MACD红绿柱面积指标公式

来源:网络 点击: 时间:2018-08-24

P:=26;S:=12;M:=9;
DIFF1:=(EMA(CLOSE,s) - EMA(CLOSE,p)){/EMA(CLOSE,s)*100};
DEA1:=EMA(DIFF1,m);
MACD:2*(DIFF1-DEA1){,COLORSTICK},LINETHICK0;
MACDhs:=IF(MACD>0 AND MACD>=REF(MACD,1),MACD,0);
MACDhx:=IF(MACD>0 AND MACD<=REF(MACD,1),MACD,0);
MACDlx:=IF(MACD<0 AND MACDMACDls:=IF(MACD<0 AND MACD>REF(MACD,1),MACD,0);
STICKLINE(MACDhs>0,0,MACD,9,0),Color0000BB;
STICKLINE(MACDhs>0,0,MACD,8,0),Color0000CC;
STICKLINE(MACDhs>0,0,MACD,7,0),Color0011CC;
STICKLINE(MACDhs>0,0,MACD,6,0),Color1122DD;
STICKLINE(MACDhs>0,0,MACD,5,0),Color2233DD;
STICKLINE(MACDhs>0,0,MACD,4,0),Color3344EE;
STICKLINE(MACDhs>0,0,MACD,3,0),Color4455EE;
STICKLINE(MACDhs>0,0,MACD,2,0),Color5566FF;
STICKLINE(MACDhs>0,0,MACD,1,0),Color6677FF;
STICKLINE(MACDhx>0,0,MACD,9,0),Color0077BB;
STICKLINE(MACDhx>0,0,MACD,8,0),Color0088CC;
STICKLINE(MACDhx>0,0,MACD,7,0),Color0099CC;
STICKLINE(MACDhx>0,0,MACD,6,0),Color00AADD;
STICKLINE(MACDhx>0,0,MACD,5,0),Color00BBDD;
STICKLINE(MACDhx>0,0,MACD,4,0),Color00CCEE;
STICKLINE(MACDhx>0,0,MACD,3,0),Color00DDEE;
STICKLINE(MACDhx>0,0,MACD,2,0),Color00EEFF;
STICKLINE(MACDhx>0,0,MACD,1,0),Color00FFFF;
STICKLINE(MACDlx<0,MACD,0,9,0),Color770000;
STICKLINE(MACDlx<0,MACD,0,8,0),Color881100;
STICKLINE(MACDlx<0,MACD,0,7,0),Color992200;
STICKLINE(MACDlx<0,MACD,0,6,0),ColorAA3300;
STICKLINE(MACDlx<0,MACD,0,5,0),ColorBB4400;
STICKLINE(MACDlx<0,MACD,0,4,0),ColorCC5500;
STICKLINE(MACDlx<0,MACD,0,3,0),ColorDD6600;
STICKLINE(MACDlx<0,MACD,0,2,0),ColorEE7700;
STICKLINE(MACDlx<0,MACD,0,1,0),ColorFF8800;
{www.igojr.com 老K股票学习网_飞狐股票指标公式}
STICKLINE(MACDls<0,MACD,0,9,0),Color005500;
STICKLINE(MACDls<0,MACD,0,8,0),Color007700;
STICKLINE(MACDls<0,MACD,0,7,0),Color009900;
STICKLINE(MACDls<0,MACD,0,6,0),Color00AA00;
STICKLINE(MACDls<0,MACD,0,5,0),Color00BB00;
STICKLINE(MACDls<0,MACD,0,4,0),Color00CC00;
STICKLINE(MACDls<0,MACD,0,3,0),Color00DD00;
STICKLINE(MACDls<0,MACD,0,2,0),Color00EE00;
STICKLINE(MACDls<0,MACD,0,1,0),Color00FF00;
DIFF:DIFF1,Color0000FF;
DEA:DEA1,ColorFF0000;
红柱面积:10*IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),LINETHICK0,Color0000FF;
绿柱面积:10*IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0),LINETHICK0,Color006000;
{平均面积: IF(MACD>0,10*红柱面积/BARSLAST(MACD<0),10*绿柱面积/BARSLAST(MACD>0)),LINETHICK0,ColorFF00FF;}
DRAWNUMBER(ref(MACD,1)>0 and MACD<=0 ,HHV(MACD,4),ref(红柱面积,1),2),ALIGN1,pxup10,colorred;
{DRAWNUMBER(ref(MACD,1)>0 and MACD<=0 ,HHV(MACD,4),ref(平均面积,1),2),ALIGN1,pxup35,ColorFF00FF;}
DRAWNUMBER(ref(MACD,1)<0 and MACD>=0 ,LLV(MACD,4),ref(abs(绿柱面积),1),2),ALIGN1,pxdn5,Color006000;
{DRAWNUMBER(ref(MACD,1)<0 and MACD>=0 ,LLV(MACD,4),ref(abs(平均面积),1),2),ALIGN1,pxdn30,ColorFF00FF;}
DRAWNUMBER(BARSTATUS=2 AND MACD<0,LLV(MACD,4),abs(绿柱面积),2),align2,pxdn5,Color006000;
{DRAWNUMBER(BARSTATUS=2 AND MACD<0,LLV(MACD,4),abs(平均面积),2),align2,pxdn30,ColorFF00FF;}
DRAWNUMBER(BARSTATUS=2 AND MACD>0,HHV(MACD,4),abs(红柱面积),2),align2,pxup10,colorred;
{DRAWNUMBER(BARSTATUS=2 AND MACD>0,HHV(MACD,4),abs(平均面积),2),align2,pxup35,ColorFF00FF;}
DRAWNUMBER(MACD>0 AND MACD=HHV(MACD,BARSLAST(MACD<0)) AND MACD>=REFX(MACD,1) AND MACD>=REFX(MACD,2),MACD,MACD,2),align0,pxup20,ColorFF0000;
DRAWNUMBER(MACD<0 AND MACD=LLV(MACD,BARSLAST(MACD>0)) AND MACD<=REFX(MACD,1) AND MACD<=REFX(MACD,2),MACD,MACD,2),align0,pxup10,ColorFF00FF;
0,Color000000;

飞狐MACD红绿柱面积指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top