最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > MACD指标 > 通达信MACD加辅助指标公式

通达信MACD加辅助指标公式

来源:网络 点击: 时间:2018-08-30

DIFF : (EMA(CLOSE,12) - EMA(CLOSE,26))/EMA(C,512)*2000,NODRAW;
DEA : EMA(DIFF,9),NODRAW;
DRAWBAND(DIFF,RGB(120,00,00),DEA,RGB(00,80,00));
MACD : 2*(DIFF-DEA), COLORSTICK;
DRAWBAND(0,RGB(100,100,100),0,0);
X00:=C;
X01:=0.7522406533*X00+0.3609454219*REF(X00,1)-0.03309329629*REF(X00,2)-0.04241822779*REF(X00,3)-0.026737249*REF(X00,4)-0.007010041271*REF(X00,5)-0.002652859952*REF(X00,6)-0.0008415042966*REF(X00,7)-0.0002891931964*REF(X00,8)-0.0000956265934*REF(X00,9)-0.0000321286052*REF(X00,10)-0.0000106773454*REF(X00,11)-0.0000035457562*REF(X00,12)-0.0000011670713*REF(X00,13);
X02:=0.7522406533*X01+0.3609454219*REF(X01,1)-0.03309329629*REF(X01,2)-0.04241822779*REF(X01,3)-0.026737249*REF(X01,4)-0.007010041271*REF(X01,5)-0.002652859952*REF(X01,6)-0.0008415042966*REF(X01,7)-0.0002891931964*REF(X01,8)-0.0000956265934*REF(X01,9)-0.0000321286052*REF(X01,10)-0.0000106773454*REF(X01,11)-0.0000035457562*REF(X01,12)-0.0000011670713*REF(X01,13);
X03:=0.7522406533*X02+0.3609454219*REF(X02,1)-0.03309329629*REF(X02,2)-0.04241822779*REF(X02,3)-0.026737249*REF(X02,4)-0.007010041271*REF(X02,5)-0.002652859952*REF(X02,6)-0.0008415042966*REF(X02,7)-0.0002891931964*REF(X02,8)-0.0000956265934*REF(X02,9)-0.0000321286052*REF(X02,10)-0.0000106773454*REF(X02,11)-0.0000035457562*REF(X02,12)-0.0000011670713*REF(X02,13);
WA4:=EMA(EMA(EMA((EMA(X01,1)+EMA(X01,2)+EMA(X01,3)+EMA(X01,4))/4,2),2),2);
WA5:=EMA(WA4,2);
WA6:=EMA(WA5,2);
WA7:=EMA(WA6,2);
BB1:=(X00+X01+X02+X03)/4;
BB2:=(WA5+WA6+WA7)/3;
{ Gupang.com 股-旁-网_通达信股票指标公式}
WA13:=EMA((((EMA(X01,32)+EMA(X01,33))+EMA(X01,34))/3),2);
WA8:=EMA((((EMA(X01,22)+EMA(X01,23))+EMA(X01,24))/3),2);
WA9:=EMA((((EMA(X01,24)+EMA(X01,25))+EMA(X01,26))/3),2);
WA10:=EMA((((EMA(X01,26)+EMA(X01,27))+EMA(X01,28))/3),2);
WA11:=EMA((((EMA(X01,28)+EMA(X01,29))+EMA(X01,30))/3),2);
WA12:=EMA((((EMA(X01,30)+EMA(X01,31))+EMA(X01,32))/3),2);
BB:=(WA13+WA8+WA9+WA10+WA11+WA12)/6;
~DIF:(BB1-BB)/BB*1000,COLORWHITE;
~DEAL:(BB2-BB)/BB*1000,COLORYELLOW,LINETHICK1;

通达信MACD加辅助指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top