最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票指标 > MACD指标 > 通达信好用MACD指标公式

通达信好用MACD指标公式

来源:网络 点击: 时间:2019-02-12

DIFF9:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA9:=EMA(DIFF9,9),COLORRED,LINETHICK1;
MACD:2*(DIFF9-DEA9), COLORSTICK,LINETHICK1;
A1:=BARSLAST(REF(CROSS(DIFF9,DEA9),1));
STICKLINE(MACD0,0,MACD,0.5,0),COLORFF99AA;
STICKLINE(MACDSTICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0.5,0),COLORGRAY;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORMAGENTA;
DIFF :(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA : EMA(DIFF9,9),COLORRED,LINETHICK1;
IF(DIFF9IF(DEA9低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,2,0),COLORYELLOW;
DRAWTEXT(低位金叉,-0.2,' 低金'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,2,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.15,' 二金叉'),COLORYELLOW;
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.03,2,0),COLOR00FF00;
DRAWTEXT(底背离,-0.19,' 底背'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);
STICKLINE(顶背离,0,0.03,2,0),COLORWHITE;
DRAWTEXT(顶背离,0.12,' 顶背'),COLORFF00FF;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.19,'三全项'),COLOR0000FF,LINETHICK2;

通达信好用MACD指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top