最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 超赢BS主图大智慧

超赢BS主图大智慧

来源:网络 点击: 时间:2019-03-20

  DRAWGBK(v》=0,STRIP(RGB(18,19,51),RGB(1,155,155),0));N:=2;

  B1:=MA(CLOSE,1);

  B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1) ;

  SMA2:=MA(B2,3) ;

  FILLRGN(b2,sma2,b2》sma2),colorred;

  FILLRGN(b2,sma2,b2

  a:=“LTFunc4@FORLT2”;

  s1:=“LTFunc4@LT_S1”;

  hs:=“LTFunc4@LT_HS”;

  ls:=“LTFunc4@LT_LS”;

  p1:=“LTFunc4@LT_P1”;

  upp:=“LTFunc4@LT_UPP”;

  udd:=“LTFunc4@LT_UDD”;

  {hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};

  d1:=ema(abs(“ddx.ddx”),60);

  d2:=max(“ddx.ddx”/d1+7.5,7.5);

  d3:=min(“ddx.ddx”/d1,10);

  fb:=if(s1=0,hs,ls);

  tr0:=ifs(p1=1,‘明日收盘价《’+numtostrn(udd,2)+‘,出现S点n’,‘若明日收盘价》 ’+numtostrn(upp,2)+‘,出现B点n’);

  tr1:=ifs(s1=1,‘明日收盘价《’+numtostrn(ls,2)+‘,短线卖出机会’,‘若明日收盘价》 ’+numtostrn(hs,2)+‘短线买入机会’);

  tr2:=ifs(p1=1,ifs(cross(p1,0),‘B点’,‘持股’),ifs(cross(1,p1),‘S点’,‘持币’));

  tr3:=ifs(s1=0,‘向下,’,‘向上,’);

  tr4:=‘3.能量级别:’+numtostrn(d3,1)+‘级’;

  bs:=‘’+datestr(date)+‘买卖点决策系统提示n’+‘1.BS点:’+tr2+‘,’+tr0+‘2.短线:’+tr3+tr1+‘n’+tr4;

  drawflagtext(1,fb,bs);

  STICKLINE(CLOSE》OPEN or CLOSE=OPEN and CLOSE》REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;

  STICKLINE(CLOSE》OPEN or CLOSE=OPEN and CLOSE》REF(CLOSE,1),OPEN,CLOSE,7,0),colorred;

  STICKLINE(CLOSE

  STICKLINE(CLOSE

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;

  STICKLINE(p1=1 and c》=o and o《》0,c,o,d2,0),color5454ff;

  STICKLINE(p1=1 and c》=o and o《》0,c,o,7.5,0),colorblack;

  STICKLINE(p1=1 and c》=o and o《》0,c,c,7.5,0),color5454ff;

  STICKLINE(p1=1 and c》=o and o《》0,o,o,7.5,0),color5454ff;

  STICKLINE(p1=1 and c》=o and o《》0,o,c,7.5,1),color5454ff;

  STICKLINE(p1=1 and c《=o,o,c,7.5,1),color5454ff;

  STICKLINE(p1=1 and c《=o,l,c,0.5,1),color5454ff;

  STICKLINE(p1=1 and c《=o,h,o,0.5,1),color5454ff;

  STICKLINE((p1《》1 or barscount(c)《3) and c》=o,c,o,7.5,1),colorffff54;

  STICKLINE((p1《》1 or barscount(c)《3) and c》=o,c,h,0.5,1),colorffff54;

  STICKLINE((p1《》1 or barscount(c)《3) and c》=o,l,o,0.5,1),colorffff54;

  drawbmp(p1=1 and ref(p1,1)=0,l,‘buy1.bmp’),align1,valign0;

  drawbmp(p1=0 and ref(p1,1)=1,h,‘sell1.bmp’),align1,valign2;

  drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))《》1,l,‘bs.bmp’),align1,valign0;

  drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))《》1,h,‘ss.bmp’),align1,valign2;

  早晨之星:=REF(CLOSE,2)/REF(OPEN,2)《0.95 AND REF(OPEN,1)

  REF(CLOSE,1))/REF(CLOSE,1)《0.03 AND CLOSE/OPEN》1.05 AND CLOSE》REF(CLOSE,2);

  黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)》1.03 AND REF(OPEN,1)》REF(CLOSE,2) AND ABS(REF(OPEN,1)-

  REF(CLOSE,1))/REF(CLOSE,1)《0.02 AND CLOSE/OPEN《0.97 AND CLOSE

  长十字:=CLOSE=OPEN AND HIGH/LOW 》1.03;

  垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE《》HIGH;

  早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)《0.95 AND REF(OPEN,1)

  =REF(CLOSE,1) AND

  CLOSE/OPEN》1.05 AND CLOSE》REF(CLOSE,2);

  黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)》1.05 AND REF(OPEN,1)》REF(CLOSE,2) AND REF(OPEN,1)

  =REF(CLOSE,1) AND

  CLOSE/OPEN《0.95 AND CLOSE

  射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW》3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE》MA(CLOSE,5);

  倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW》3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE

  锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW》3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE

  吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW》3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE》MA(CLOSE,5);

  穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)》1.03 AND CLOSE/OPEN《0.96 AND CLOSE

  OPEN》REF(CLOSE,1))

  OR (REF(CLOSE,1)/REF(OPEN,1)《0.97 AND CLOSE/OPEN》1.04 AND CLOSE》REF(OPEN,1) AND OPEN

  (CLOSE,1));

  乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)》1.03 AND CLOSE/OPEN《0.97 AND OPEN》REF(CLOSE,1) AND

  CLOSE

  曙光初现:=REF(CLOSE,1)/REF(OPEN,1)《0.97 AND CLOSE/OPEN》1.03 AND OPEN

  CLOSE》REF(CLOSE,1);

  身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)》0.04 AND ABS(CLOSE-OPEN)/CLOSE《0.005AND MAX(CLOSE,OPEN)MIN(REF(CLOSE,1),REF

  (OPEN,1));

  十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)》0.04 AND CLOSE=OPEN AND

  CLOSE 《 MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE 》 MIN(REF(CLOSE,1),REF(OPEN,1));

  平顶:=ABS(HIGH-REF(HIGH,1))/HIGH《0.001;

  平底:=(ABS(LOW-REF(LOW,1))/LOW《0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)《=0.001);

  大阳烛:=CLOSE/OPEN》1.05 AND HIGH/LOW

  三个白武士:=REF(CLOSE,2)》REF(OPEN,2) AND REF(CLOSE,1)》REF(OPEN,1) AND CLOSE》OPEN

  AND REF(CLOSE,1)》REF(CLOSE,2) AND CLOSE》REF(CLOSE,1);

  双飞乌鸦:=REF(CLOSE,1)

  孕育线:=REF(CLOSE,2)》REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)》=2/100 AND

  REF(OPEN,1)》=REF(CLOSE,1) AND

  (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)《=2/100 AND REF(OPEN,1)《=REF(CLOSE,2) AND REF

  (CLOSE,1)》=REF(OPEN,2) AND C》=OPEN AND

  (CLOSE-OPEN)/OPEN》=2/100 AND CLOSE》=REF(OPEN,1) AND OPEN《=REF(CLOSE,1) AND (MAX(CLOSE,REF

  (C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))《=1/100;

  多方炮:=REF(CLOSE,2)》REF(OPEN,2) AND REF(CLOSE,1)OPEN;

  出水芙蓉:=(OPENMAX(EMA(C,20),MAX

  (EMA(C,40),EMA(C,60))))

  AND (V/MA(V,30)》1.2 AND C/REF(C,1)》1.049);

  上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)》1.03 AND REF(CLOSE,3)

  REF(LOW,4)

  》REF(HIGH,3) AND REF(HIGH,4)》REF(HIGH,2) AND

  REF(HIGH,4)》REF(HIGH,1) AND CLOSE/OPEN》1.03 AND CLOSE》REF(CLOSE,4);

  下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)《0.97 AND REF(CLOSE,3)》REF(OPEN,3) AND REF(CLOSE,2)

  》REF(OPEN,2) AND REF(CLOSE,1)》REF(OPEN,1) AND REF(LOW,4)

  REF(LOW,4)REF(HIGH,3) AND REF

  (HIGH,4)》REF(HIGH,2) AND REF(HIGH,4)》REF(HIGH,1) AND CLOSE/OPEN《0.97 AND

  CLOSE

  跳空缺口:=HIGHREF(HIGH,1);

  三只乌鸦:=REF(CLOSE,2)

  光脚阴线:=LOW=CLOSE AND HIGH《》LOW;

  光头阳线:=HIGH=CLOSE AND HIGH《》LOW;

  分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))《0;

  长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)》0.667;

  长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)》0.667;

  十字星:=CLOSE=OPEN AND HIGH《》LOW;

  大阴烛:=OPEN/CLOSE 》 1.05 AND HIGH/LOW 《 OPEN/CLOSE+0.018;

  好友反攻:=(REF(CLOSE,1)OPEN AND ABS(CLOSE-REF

  (CLOSE,1))/CLOSE《0.002)

  OR (REF(CLOSE,1)》REF(OPEN,1) AND CLOSE

  倾盆大雨:=REF(C,1)/REF(O,1)》=1.03 AND OREF(O,1) AND C

  解盘:=‘【K线形态解盘】’+

  IFs(倾盆大雨,‘★倾盆大雨 见顶信号;’,‘’)+

  IFs(大阴烛,‘★大阴烛 后市向淡,发生逆转;’,‘’)+

  IFs(好友反攻,‘★好友反攻 底部反转;’,‘’)+

  IFs(跳空缺口,‘★跳空缺口 注意向上还是向下跳空;’,‘’)+

  IFs(光脚阴线,‘★光脚阴线 下跌信号;’,‘’)+

  IFs(光头阳线,‘★光头阳线 光头阳线,后市看涨;’,‘’)+

  IFs(三只乌鸦,‘★三只乌鸦 三只乌鸦,可能见顶回落;’,‘’)+

  IFs(分离,‘★分离 注意看涨分离和看跌分离;’,‘’)+

  IFs(长下影,‘★长下影 持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;’,‘’)+

  IFs(长上影,‘★长上影 表明行情上档压力沉重,升势受阻;’,‘’)+

  IFs(下跌三部曲,‘★下跌三部曲 下跌三部曲,下跌信号;’,‘’)+

  IFs(上升三部曲,‘★上升三部曲 上涨信号;’,‘’)+

  IFs(早晨之星,‘★早晨之星 见底回升;’,‘’)+

  IFs(黄昏之星,‘★黄昏之星 见顶回落;’,‘’)+

  IFs(十字星,‘★十字星 有转向意味,注意股价位置在顶部还是底部;’,‘’)+

  IFs(长十字,‘★长十字 注意在顶部还是底部;’,‘’)+

  IFs(垂死十字,‘★垂死十字 下跌信号;’,‘’)+

  IFs(早晨十字星,‘★早晨十字星 上涨信号,见底回升;’,‘’)+

  IFs(黄昏十字星,‘★黄昏十字星 下跌信号,见顶回落;’,‘’)+

  IFs(射击之星,‘★射击之星 可能见顶回落,可靠性低;’,‘’)+

  IFs(倒转锤头,‘★倒转锤头 可能见底回升;’,‘’)+

  IFs(锤头,‘★锤头 可能见底回升,如有量配合,信号强烈;’,‘’)+

  IFs(吊颈,‘★吊颈 上升行情中见顶回落,顶部出现,见顶信号;’,‘’)+

  IFs(平顶,‘★平顶 温和的反转;’,‘’)+

  IFs(穿头破脚,‘★穿头破脚 顶部出现,见顶回落信号;’,‘’)+

  IFs(乌云盖顶,‘★乌云盖顶 见顶回落信号;’,‘’)+

  IFs(曙光初现,‘★曙光初现 后市见底回升;’,‘’)+

  IFs(身怀六甲,‘★身怀六甲 ,出现在底部,是见底回升信号;出现在顶部,是见顶回落信意;’,‘’)+

  IFs(十字胎,‘★十字胎 注意股价位置;’,‘’)+

  IFs(平底,‘★平底 温和的反转;’,‘’)+

  IFs(大阳烛,‘★大阳烛 看涨;’,‘’)+

  IFs(三个白武士,‘★三个白武士 每日收盘价上移,表示可能见底回升;’,‘’)+

  IFs(双飞乌鸦,‘★双飞乌鸦 ,行情将见顶回落;’,‘’)+

  IFs(孕育线,‘★孕育线 注意股价位置;’,‘’)+

  IFs(多方炮,‘★多方炮 在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复 合见顶信号;’,‘’)+

  IFs(出水芙蓉,‘★出水芙蓉;’,‘’);

  DRAWTEXTREL(10,10,BKNAME),Color00FFFD,LINETHICK3;

  DRAWTEXTABS(10,30,解盘),LINETHICK2,COLORff00FF;

  DRAWFLAGTEXT(倾盆大雨,c,‘★倾盆大雨,见顶信号’),COLORFF00FF;

  DRAWFLAGTEXT(大阴烛,c,‘★大阴烛,后市向淡,发生逆转’),COLORFF00FF;

  DRAWFLAGTEXT(好友反攻,c,‘★好友反攻,底部反转’),COLORFF00FF;

  DRAWFLAGTEXT(跳空缺口,c,‘★跳空缺口,注意向上还是向下跳空’),COLORFF00FF;

  DRAWFLAGTEXT(光脚阴线,c,‘★光脚阴线,下跌信号’),COLORFF00FF;

  DRAWFLAGTEXT(光头阳线,c,‘★光头阳线,后市看涨’),COLORFF00FF;

  DRAWFLAGTEXT(三只乌鸦,c,‘★三只乌鸦,可能见顶回落’),COLORFF00FF;

  DRAWFLAGTEXT(分离,c,‘★分离,注意看涨分离和看跌分离’),COLORFF00FF;

  DRAWFLAGTEXT(长下影,c,‘★长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意’),COLORFF00FF;

  DRAWFLAGTEXT(长上影,c,‘★长上影,表明行情上档压力沉重,升势受阻’),COLORFF00FF;

  DRAWFLAGTEXT(下跌三部曲,c,‘★下跌三部曲,下跌信号’),COLORFF00FF;

  DRAWFLAGTEXT(上升三部曲,c,‘★上升三部曲,上涨信号’),COLORFF00FF;

  DRAWFLAGTEXT(早晨之星,c,‘★早晨之星,见底回升’),COLORFF00FF;

  DRAWFLAGTEXT(黄昏之星,c,‘★黄昏之星,见顶回落’),COLORFF00FF;

  DRAWFLAGTEXT(十字星,c,‘★十字星,有转向意味,注意股价位置在顶部还是底部’),COLORFF00FF;

  DRAWFLAGTEXT(长十字,c,‘★长十字,注意在顶部还是底部’),COLORFF00FF;

  DRAWFLAGTEXT(垂死十字,c,‘★垂死十字,下跌信号’),COLORFF00FF;

  DRAWFLAGTEXT(早晨十字星,c,‘★早晨十字星,上涨信号,见底回升’),COLORFF00FF;

  DRAWFLAGTEXT(黄昏十字星,c,‘★黄昏十字星,下跌信号,见顶回落’),COLORFF00FF;

  DRAWFLAGTEXT(射击之星,c,‘★射击之星,可能见顶回落,可靠性低’),COLORFF00FF;

  DRAWFLAGTEXT(倒转锤头,c,‘★倒转锤头,可能见底回升’),COLORFF00FF;

  DRAWFLAGTEXT(锤头,c,‘★锤头,可能见底回升,如有量配合,信号强烈’),COLORFF00FF;

  DRAWFLAGTEXT(吊颈,c,‘★吊颈,上升行情中见顶回落,顶部出现,见顶信号’),COLORFF00FF;

  DRAWFLAGTEXT(平顶,c,‘★平顶,温和的反转’),COLORFF00FF;

  DRAWFLAGTEXT(穿头破脚,c,‘★穿头破脚,顶部出现,见顶回落信号’),COLORFF00FF;

  DRAWFLAGTEXT(乌云盖顶,c,‘★乌云盖顶,见顶回落信号’),COLORFF00FF;

  DRAWFLAGTEXT(曙光初现,c,‘★曙光初现,后市见底回升’),COLORFF00FF;

  DRAWFLAGTEXT(身怀六甲,c,‘★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信意’),COLORFF00FF;

  DRAWFLAGTEXT(十字胎,c,‘★十字胎’),COLORFF00FF;

  DRAWFLAGTEXT(平底,c,‘★平底,温和的反转’),COLORFF00FF;

  DRAWFLAGTEXT(大阳烛,c,‘★大阳烛,看涨’),COLORFF00FF;

  DRAWFLAGTEXT(三个白武士,c,‘★三个白武士,每日收盘价上移,表示可能见底回升’),COLORFF00FF;

  DRAWFLAGTEXT(双飞乌鸦,c,‘★双飞乌鸦,行情将见顶回落’),COLORFF00FF;

  DRAWFLAGTEXT(孕育线,c,‘★孕育线,注意股价位置’),COLORFF00FF;

  DRAWFLAGTEXT(多方炮,c,‘★多方炮,在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复 合见顶信号’),COLORFF00FF;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top