最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧MA均线+F10资料主图提示买卖点的源码免费指标

大智慧MA均线+F10资料主图提示买卖点的源码免费指标

来源:网络 点击: 时间:2018-08-28

  大智慧MA均线+F10资料主图提示买卖点的源码免费指标

  MA5:MA(c,5);

  ma10:ma(c,10);

  ma30:ma(c,30),linethick2;

  MA60:MA(c,60);

  {F10提取显示部分}

  cwts:=f10find(‘财务透视’,1);

  xsml:=f10find(‘销售毛利率(%)’,cwts+1);

  销售毛利率:=strtonum(f10text(xsml+20,10));

  通流市值:=DYNAINFO(57)/100000000;

  cpbd:=f10find(‘最新指标’,1);

  fpya:=f10find(‘分配预案: ’,cpbd+1);

  分配预案:=f10text(fpya+10,0);

  zygc:=f10find(‘主营构成’,1);

  zycp:=f10find(‘─────────────────────────────────────’,zygc+1);

  主营1:=f10text(zycp+78,70);

  主营2:=f10text(zycp+148,68);

  DRAWTEXTREL(5,10,‘所属板块:’+BKNAME),Color60FF14;

  DRAWTEXTREL(5,55,‘股票代码:’+STKLABEL+‘, 流通盘:’+CAPITAL/1000000+‘亿, 流通总市值:’+通流市值+‘亿,’),Color08ddff;

  DRAWTEXTREL(5,95,‘主营收入同比: ’+FINANCE2(11)+‘% ,利润率同比: ’+FINANCE2(10)+‘% ’+ ‘ 销售毛利率:’+销售毛利率+‘% 市盈率:’+DYNAINFO(39)+‘, 每股收益’+FINANCE2(3)),Colorred;

  DRAWTEXTREL(5,135,‘每股净资产:’+FINANCE2(4)+‘元, 每股未分配:’+FINANCE2(8)+‘元, 每股公积金’+FINANCE2(7)+‘元, 每股经营现金:’+FINANCE2(6)),Coloraa3399;

  DRAWTEXTREL(5,189,‘分配预案: ’+分配预案),ColorafFF00;

  DRAWTEXTREL(5,260,‘产品行业地区 主营收入 同比增长 主营收入占比 主营利润’),Color11FF00;

  DRAWTEXTREL(5,285,‘─────────────────────────────────────’),Color11FF00;

  DRAWTEXTREL(5,305,主营1),Color11FF00;

  DRAWTEXTREL(5,345,主营2),Color11FF00;

  ZF:=100*(C-REF(C,1))/REF(C,1);

  STICKLINE(ZF》5,c,o,2,500),coloryellow;

  活泼指数:COUNT(ZF》5,120),colorred,linethick0;

  DRAWTEXTABS(5,5,‘1’),linethick1,COLOR00EEff;

  VAR3:=LLV(HIGH,240);

  VAR4:=100*(CLOSE-VAR3)/VAR3;

  VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

  VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

  VAR7:=0;

  VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

  VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

  VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH》LOW+0.04,4,0);

  VAR11:=ZIG(3,6)》REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)《=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)《=REF(ZIG(3,6),3);

  VAR12:=ZIG(3,6)《REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)》=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)》=REF(ZIG(3,6),3);

  VAR13:=ZIG(3,22)》REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)《=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)《=REF(ZIG(3,22),3);

  VAR14:=ZIG(3,22)《REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)》=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)》=REF(ZIG(3,22),3);

  VAR15:=ZIG(3,51)》REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)《=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)《=REF(ZIG(3,51),3);

  VAR16:=ZIG(3,51)《REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)》=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)》=REF(ZIG(3,51),3);

  VAR17:=ZIG(3,72)》REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)《=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)《=REF(ZIG(3,72),3);

  VAR18:=ZIG(3,72)《REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)》=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)》=REF(ZIG(3,72),3);

  VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

  买1:=VAR10;

  买2:=(VAR11+VAR13+VAR15+VAR17);

  卖1:=(VAR12+VAR14+VAR16+VAR18);

  买:=买1》0 OR 买2》0;

  卖:=卖1》0;

  DRAWTEXT(买1》0 OR 买2》0,0.99*LOW,‘买’),COLORRED;

  DRAWTEXT(卖1》0,1.01*HIGH,‘卖’),COLORGREEN;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top