最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧分时背离指标公式

大智慧分时背离指标公式

来源:网络 点击: 时间:2019-02-18

  Input:N(10),M1(3),M2(3);

  RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

  K:=SMA(RSV,M1,1);

  D:=SMA(K,M2,1);

  J:=3*K-2*D;

  POLYLINE(1,D),colorFFFF00;

  短高:IF(BETWEEN(“KDJ.K”,100,80),88,100),PRECIS0;

  短低:IF(BETWEEN(“KDJ.K”,20,0),12,0),PRECIS0;

  波低:IF(BETWEEN(“KDJ.K#week”,10,0),30,0),PRECIS0;

  波高:IF(BETWEEN(“KDJ.K#week”,100,90),70,100),PRECIS0;

  中低:IF(BETWEEN(“KDJ.K#MONTH”,20,0),30,0),PRECIS0,color0000FF;

  中高:IF(BETWEEN(“KDJ.K#MONTH”,100,75),70,100),PRECIS0;

  POLYLINE(1,0),color00FFFF;

  A1:=BARSLAST(REF(CROSS(“MACD.DIFF”,“MACD.DEA”),1));

  B1:=REF(CLOSE,A1+1)》CLOSE AND REF(“MACD.DIFF”,A1+1)《“MACD.DIFF” AND CROSS(“MACD.DIFF”,“MACD.DEA”);

  MACD底背离:FILTER(B1》0,5),LineThick0,PRECIS0;

  STICKLINE(FILTER(B1》0,5),0,10,3,0),color00FF00;

  DRAWTEXT(FILTER(B1》0,5),10,‘MACD底背’),color00FF00;

  A2:=BARSLAST(REF(CROSS(“KDJ.K”,“KDJ.D”),1));

  B2:=REF(CLOSE,A2+1)》CLOSE AND REF(“KDJ.K”,A2+1)《“KDJ.K” AND CROSS(“KDJ.K”,“KDJ.D”);

  KDJ底背离:FILTER(B2》0,5),LineThick0,PRECIS0;

  STICKLINE(FILTER(B2》0,5),0,20,3,0),color00FFFF;

  DRAWTEXT(FILTER(B2》0,5),20,‘KDJ底背’),color00FFFF;

  A3:=BARSLAST(REF(CROSS(“RSI.RSI1”,“RSI.RSI2”),1));

  B3:=REF(CLOSE,A3+1)》CLOSE AND REF(“RSI.RSI1”,A3+1)《“RSI.RSI1” AND CROSS(“RSI.RSI1”,“RSI.RSI2”);

  RSI底背离:FILTER(B3》0,5),LineThick0,PRECIS0;

  STICKLINE(FILTER(B3》0,5),0,30,3,0),colorFFFF00;

  DRAWTEXT(FILTER(B3》0,5),30,‘RSI底背’),colorFFFF00;

  POLYLINE(1,100),color0000FF;

  C1:=BARSLAST(REF(CROSS(“MACD.DEA”,“MACD.DIFF”),1));

  D1:=REF(CLOSE,C1+1)《CLOSE AND REF(“MACD.DIFF”,C1+1)》“MACD.DIFF” AND CROSS(“MACD.DEA”,“MACD.DIFF”);

  MACD顶背离:FILTER(D1》0,5),Linethick0,PRECIS0;

  STICKLINE(FILTER(D1》0,5),100,80,3,0),color0066FF;

  DRAWTEXT(FILTER(D1》0,5),80,‘MACD顶背’),color0066FF;

  C2:=BARSLAST(REF(CROSS(“KDJ.D”,“KDJ.K”),1));

  D2:=REF(CLOSE,C2+1)《CLOSE AND REF(“KDJ.K”,C2+1)》“KDJ.K” AND CROSS(“KDJ.D”,“KDJ.K”);

  KDJ顶背离:FILTER(D2》0,5),Linethick0,PRECIS0;

  STICKLINE(FILTER(D2》0,5),100,70,3,0),color0000FF;

  DRAWTEXT(FILTER(D2》0,5),70,‘KDJ顶背’),color0000FF;

  C3:=BARSLAST(REF(CROSS(“RSI.RSI2”,“RSI.RSI1”),1));

  D3:=REF(CLOSE,C3+1)《CLOSE AND REF(“RSI.RSI1”,C3+1)》“RSI.RSI1” AND CROSS(“RSI.RSI2”,“RSI.RSI1”);

  RSI顶背离:FILTER(D3》0,5),Linethick0,PRECIS0;

  STICKLINE(FILTER(D3》0,5),100,60,3,0),colorFF00FF;

  DRAWTEXT(FILTER(D3》0,5),60,‘RSI顶背’),colorFF00FF;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top