最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧追击黑马主图指标公式

大智慧追击黑马主图指标公式

来源:网络 点击: 时间:2018-08-31

  DRAWGBKLAST(v》0,STRIP(RGB(0,150,130),RGB(0,0,0),1));

  上:=(SMA(HIGH,21,2) * 1.05);

  DRAWTEXT(FILTER(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND (HIGH 》 上)) AND (CLOSE 《 上)),5),(HIGH + 0.05),‘减仓’),COLORFFFFFF;

  下轨道:(SMA(LOW,21,2) * 0.969),POINTDOT,COLOR00FFFF;

  BMA:=MA(CLOSE,118);

  阻挡:=(SMA(HIGH,21,2) * 1.05);

  RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=((3 * K) - (2 * D));

  RSV12:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);

  K12:=SMA(RSV12,3,1);

  D12:=SMA(K12,3,1);

  J12:=((3 * K12) - (2 * D12));

  RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

  K24:=SMA(RSV24,3,1);

  D24:=SMA(K24,3,1);

  J24:=((3 * K24) - (2 * D24));

  支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));

  压力位:IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),COLOR00FF00;

  U2L:=IF((CLOSE 》= MA(CLOSE,20)),80,50);

  L2L:=IF((CLOSE 》= MA(CLOSE,20)),50,20);

  RH1:=IF(((J 《 U2L) AND (REF(J,1) 》= U2L)),HHV(REF(HIGH,1),(BARSLAST(((J 》= U2L) AND (REF(J,1) 《 U2L))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((J 》= U2L) AND (REF(J,1) 《 U2L))) - 1)),BARSLAST(((J 《 U2L) AND REF(J,1)))));

  RH4:=IF((HIGH 》 RH1),LOW,REF(LOW,BARSLAST((HIGH 》 RH1))));

  RH42:=IF((HIGH 》 RH1),J,REF(J,BARSLAST((HIGH 》 RH1))));

  RH5:=IF((((HIGH 》 RH4) AND (J 《 RH42)) AND (J 《 J24)),HIGH,REF(HIGH,BARSLAST((((HIGH 》 RH4) AND (J 《 RH42)) AND (J 《 J24)))));

  RL1:=IF(((J 》 L2L) AND (REF(J,1) 《= L2L)),LLV(REF(LOW,1),(BARSLAST(((J 《= L2L) AND (REF(J,1) 》 L2L))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((J 《= L2L) AND (REF(J,1) 》 L2L))) - 1)),BARSLAST(((J 》 L2L) AND REF(J,1)))));

  RL4:=IF((LOW 《 RL1),HIGH,REF(HIGH,BARSLAST((LOW 《 RL1))));

  RL42:=IF((LOW 《 RL1),J,REF(J,BARSLAST((LOW 《 RL1))));

  RL5:=IF((((LOW 《 RL4) AND (J 》 RL42)) AND (J 》 J24)),LOW,REF(LOW,BARSLAST((((LOW 《 RL4) AND (J 》 RL42)) AND (J 》 J24)))));

  CB:=((AMOUNT / VOL) / 100);

  CD:=((CB 》 HIGH) OR (CB 《 LOW));

  黑马趋势:=MA(CLOSE,3);

  MAP:=MA(CLOSE,8);

  AA5:=MA(CLOSE,21);

  AA10:MA(CLOSE,8),COLOR0000FF;

  AA12:MA(CLOSE,12),COLOR0000FF;

  BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);

  BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);

  MA13:=MA(CLOSE,13);

  DRAWTEXT(FILTER(((((((CLOSE / OPEN) 》 1.04) AND ((CLOSE - REF(CLOSE,1)) 》 0)) AND (CLOSE 》 下轨道)) AND ((AA10 - REF(AA10,1)) 》 0)) AND (CLOSE 《 上)),3),(LOW - 0.07),‘追击’),COLORD1E768;

  STICKLINE((((AA12 《= AA10) AND (BB12 》= 1)) AND (BB10 》= 1)),AA10,AA12,4,0),COLOR0000FF;

  STICKLINE((((AA12 》= AA10) AND (BB10 《= 1)) AND (BB10 《= 1)),AA10,AA12,4,0),COLOR00FF00;

  VARD:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);

  支撑:=EMA(VARD,5);

  短期底部:=LLV(OPEN,30);

  DRAWTEXT(((((((CROSS(黑马趋势,短期底部) AND ((RL5 - REF(RL5,1)) 》 0)) AND ((黑马趋势 - REF(黑马趋势,1)) 》 0)) AND (黑马趋势 》 1)) AND (LOW 《= 支撑位)) AND (CLOSE 》 支撑位)) AND (HIGH 《 压力位)),(LOW - 0.15),‘黑马发现’),COLOR00FFFF;

  DRAWTEXT((((((((CROSS(黑马趋势,RL5) AND ((黑马趋势 - REF(黑马趋势,1)) 》 0)) AND (HIGH 《 压力位)) AND (LOW 《= 短期底部)) AND (CLOSE 》 支撑位)) AND (CD 《 1)) AND (CLOSE 》 OPEN)) AND (CLOSE 》 RL5)),LOW,‘短买’),COLOR00FF00;

  DRAWTEXT(FILTER((((((((LOW 《= 短期底部) AND ((CLOSE - REF(CLOSE,1)) 》 CLOSE)) AND ((MA(CLOSE,10) - REF(MA(CLOSE,10),1)) 》 0)) AND (WINNER(CLOSE) 《 0.05)) AND (短期底部 = RL5)) AND (LOW 《= RL5)) AND (HIGH 《 压力位)),3),LOW,‘机会难得’),COLORFFFFFF;

  历史大底:DRAWTEXT(FILTER((((((LLV(LOW,0) AND (WINNER(CLOSE) 《 0.08)) AND (LOW 《= 短期底部)) AND (CLOSE 》 短期底部)) AND (J 《 80)) AND ((CLOSE / OPEN) 》 1.08)),20),(LOW - 0.45),‘历史大底’);

  DRAWTEXT(FILTER(((((((((LOW 《= 短期底部) AND (CLOSE 》 压力位)) AND ((AA5 - REF(AA5,1)) 》 0)) AND (J 《 80)) AND (CLOSE 》 支撑位)) AND ((黑马趋势 - REF(黑马趋势,1)) 》 0)) AND (WINNER(CLOSE) 《 0.1)) AND (CLOSE 》 OPEN)),5),(LOW - 0.15),‘黑马登天’),COLORCDEEC5;

  X1:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);

  X2:=EMA(X1,10);

  X3:=REF(X2,1);

  X4:=((REF(HIGH,1) + REF(LOW,1)) / 2);

  X5:=(MA(CLOSE,21) + (2 * STD(CLOSE,21)));

  X6:=REF(CLOSE,1);

  X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);

  X8:=CROSS(79,X7);

  X9:=FILTER(X8,4);

  MAP1:=MA(CLOSE,60);

  均线30:=MA(CLOSE,30);

  均线89:=MA(CLOSE,89);

  均线:=MA(CLOSE,16);

  均线34:=MA(CLOSE,34);

  均线55:=MA(CLOSE,55);

  VAR1:=EMA(CLOSE,8);

  VAR2:=EMA(VAR1,20);

  VAR3:=CROSS(VAR1,VAR2);

  VAR4:=(VAR1 《 MA(CLOSE,60));

  VAR5:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);

  VAR6:=SMA(VAR5,5,1);

  VAR7:=SMA(VAR6,8,1);

  VAR8:=(CROSS(VAR6,VAR7) AND (VAR7 《 16));

  VAR9:=((CLOSE 》 (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND VAR8);

  VARA:=IF((CLOSE 》 1000),VAR8,VAR9);

  黑马起步:=(VAR3 AND VAR4);

  逃遁:=VARA;

  均线20:=MA(CLOSE,20);

  均线120:=MA(CLOSE,120);

  牛熊线:=MA(CLOSE,250);

  VA:=CROSS(MA(CLOSE,19),MA(CLOSE,120));

  VB:=(MA(CLOSE,20) 》 MA(CLOSE,120));

  {老K股票学习网-股票公式网站 www.igojr.com}

  VC:=CROSS(MA(CLOSE,120),MA(CLOSE,89));

  VD:=(MA(CLOSE,20) 《 MA(CLOSE,120));

  VE:=CROSS(MA(CLOSE,20),MA(CLOSE,250));

  VF:=(MA(CLOSE,20) 》 MA(CLOSE,250));

  VG:=CROSS(MA(CLOSE,250),MA(CLOSE,20));

  {DRAWTEXT(FILTER(((((((((OPEN 》 均线120) AND (均线20 《 均线120)) AND (LOW 《= 均线120)) AND ((均线20 - REF(均线20,1)) 》 0)) AND (CLOSE 》 OPEN)) AND ((均线120 - REF(均线120,1)) 》 0)) AND (HIGH 《 RH5)) AND (CLOSE 》= 均线120)),15),LOW,‘120跳马’),COLOR0089E0;

  DRAWTEXT((((VA AND ((均线120 - REF(均线120,1)) 》 0)) AND (HIGH 《 RH5)) AND (CLOSE 》 OPEN)),LOW,‘宝马望月’),COLORFFFFFF;}

  DRAWTEXT((((((均线 - REF(均线,1)) 》 0) AND CROSS(均线20,均线120)) AND (LOW 《= 均线120)) AND (CLOSE 》= 均线120)),LOW,‘三线开花’),COLORFFFFFF;

  短期底部2:LLV(HIGH,30),LINETHICK2,COLOR0000FF;

  上轨:(SMA(HIGH,21,2) * 1.092),POINTDOT,COLORFFFFFF;

  中轨道:(SMA(HIGH,21,2) * 1.017),POINTDOT,COLORFFFFFF;

  DRAWTEXT(FILTER(((((LOW 《 下轨道) AND (CLOSE 》 MA(CLOSE,15))) AND (CLOSE 》 短期底部2)) AND (HIGH 《 压力位)),10),LOW,‘短线5%’),COLOR9DC522;

  DRAWTEXT(((((((HIGH 》= 均线120) AND (CLOSE 《 REF(CLOSE,1))) AND (CLOSE 《 REF(CLOSE,1))) AND (HIGH 》 上)) AND (CLOSE 《 上)) AND (CLOSE 《 均线120)),(HIGH + 0.05),‘减仓’),COLOR00FF00;

  DRAWTEXT(FILTER(((HIGH 》 阻挡) AND (CLOSE 《 阻挡)),5),(HIGH + 0.15),‘逃命’);

  DRAWTEXT(((VE 》 VG) AND (HIGH 《 阻挡)),(LOW - 0.65),‘黑马短线’),COLOR00FFFF;

  DRAWTEXT(FILTER(((((((((((OPEN 《 X2) AND (CLOSE 》 X2)) AND ((支撑 - REF(支撑,1)) 》 0)) AND ((支撑 - REF(支撑,1)) 》 0)) AND (CLOSE 《 阻挡)) AND ((均线 - REF(均线,1)) 》 0)) AND (CLOSE 》= 均线)) AND (HIGH 《 阻挡)) AND ((AA10 - REF(AA10,1)) 》 0)) AND ((阻挡 - REF(阻挡,2)) 》 0)),11),(LOW - 0.11),‘快马加鞭’),COLOR0000FF;

  DRAWTEXT(FILTER(((((((OPEN 《 X2) AND (WINNER(CLOSE) 《 0.2)) AND (CLOSE 》 X2)) AND ((X2 - REF(X2,1)) 》 0)) AND (HIGH 《 阻挡)) AND ((CLOSE - REF(CLOSE,1)) 》 0.35)),4),(LOW - 0.05),‘黑马狂奔’),COLORD18073;

  DRAWTEXT((((((((CROSS(支撑,均线) AND (HIGH 《 中轨道)) AND (WINNER(CLOSE) 《 0.2)) AND (CLOSE 《 阻挡)) AND (CLOSE 》 OPEN)) AND (LOW 《= X2)) AND (CLOSE 》= X2)) AND CROSS(支撑,X2)),LOW,‘黑马起步’),COLOR00FFFF;

  DRAWTEXT(CROSS(X4,X5),HIGH,‘减仓’),COLOR00B4FF;

  DRAWTEXT(X9,(HIGH * 1.03),‘出货’),COLOR9000F5;

  DRAWTEXT((((黑马起步 》 0) AND (LOW 《= X2)) AND ((均线 - REF(均线,1)) 》 0)),(LOW - 0.11),‘黑马起步’),COLOR00FF00;

  DRAWTEXT((逃遁 》 0),(HIGH * 1.14),‘逃命’),COLOR0000FF;

  RDV:=SMA(LOW,8,1);

  DRAWTEXT(((((CROSS(K,D) AND (CLOSE 》= OPEN)) AND ((X2 - REF(X2,1)) 》 0)) AND ((RDV - REF(RDV,1)) 》 0)) AND (K 《= 33)),(LOW - 0.08),‘黑马初现’),COLOR8500DE;

  DRAWTEXT(FILTER((((((((LOW 《= 短期底部) AND (WINNER(CLOSE) 《 0.2)) AND (CLOSE 《 牛熊线)) AND (HIGH 《 阻挡)) AND ((X2 - REF(X2,1)) 》 0)) AND (CLOSE 》 OPEN)) AND (HIGH 》= X3)),5),(LOW - 0.03),‘黑马筑底’),COLOR85B256;

  RCK:=(SMA(LOW,21,2) * 0.95);

  趋势线:=SMA(LOW,5,1);

  大胆买入:DRAWTEXT(((CROSS(趋势线,RCK) AND (LOW 《= X2)) AND ((X2 - REF(X2,1)) 》 0)),LOW,‘大胆买入’),COLORE50000;

  B1:=(((HIGH + LOW) + CLOSE) / 3);

  B6:=HHV(B1,(4 * 15));

  B7:=LLV(B1,(4 * 15));

  B8:=(B6 - B7);

  飞龙顶底线:=(MA(((B1 - B7) / B8),2) * 80);

  DRAWTEXT(FILTER(((((((飞龙顶底线 《= 1) AND (WINNER(CLOSE) 《 0.02)) AND (HIGH 《 趋势线)) AND (CLOSE 》 OPEN)) AND (LOW 《= 短期底部)) AND (CLOSE 》 短期底部)),8),(LOW - 0.02),‘黑马寻底’),COLORE7DD1F;

  DRAWTEXT(FILTER((((((((LOW 《= 短期底部) AND (WINNER(CLOSE) 《 0.015)) AND ((OPEN / CLOSE) 》 0.99)) AND ((J - REF(J,1)) 》 0)) AND (CLOSE 》 OPEN)) AND (HIGH 《 支撑位)) AND (CLOSE 》 短期底部)),25),(LOW - 0.09),‘开始建仓’),COLOR00FFFF;

  DRAWTEXT(FILTER((((((((LOW 《= 均线30) AND ((AA10 - REF(AA10,1)) 》 0)) AND ((均线 - REF(均线20,1)) 》 0)) AND ((趋势线 - REF(趋势线,1)) 》 0)) AND (CLOSE 》= 均线30)) AND (WINNER(CLOSE) 《 0.15)) AND ((CLOSE / OPEN) 》 1.01)),3),LOW,‘天马奔月’),COLOR76B0FC;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top