最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧金尺兔主图指标公式

大智慧金尺兔主图指标公式

来源:网络 点击: 时间:2019-02-27

  MA5:MA(C,5);

  MA10:MA(C,10);

  MA30:MA(C,30);

  COST(50),COLOR334422,LAYER7,LINETHICK4;

  A:=BARSLAST(DISPSTATUS=1)+1;

  HH:=HHV(HIGH,A);

  LL:=LLV(LOW,A);

  上涨:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(L=LL)+1)),COLOR0000FF,linethick0;

  ↑空间%:(C/REF(L,上涨)-1)*100,COLOR00FFFF,linethick0;

  最高%:(HHVALL(HH)/REF(L,上涨)-1)*100,COLORFF00FF,linethick0;

  下跌:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(H=HH)+1)),COLOR00FF00,linethick0;

  ↓空间%:(C/REF(H,下跌)-1)*100,COLOR998888,linethick0;

  最低%:(LLVALL(LL)/REF(H,下跌)-1)*100,COLORFF0000,linethick0;

  高:REF(H,下跌),COLOR0000FF,DOTLINE;

  低:REF(L,上涨),COLOR00FF00,DOTLINE;

  VERTLINE(上涨=0,4),COLOR0000FF;

  VERTLINE(下跌=0,3),COLOR00FF00;

  DRAWTEXT(上涨=0,HHVALL(HH)*0.99,‘-最高%’),COLOR0000FF;

  DRAWTEXT(下跌=0,LLVALL(LL)*1.01,‘-最低%’),COLOR00FF00;

  DRAWTEXT(上涨=0 AND 最高%》10,LL*1.1,‘-10%’),COLORYELLOW;

  DRAWTEXT(上涨=0 AND 最高%》10,LL*1.15,‘-15%’),COLORFFFFFF;

  DRAWTEXT(上涨=0 AND 最高%》20,LL*1.2,‘-20%’),COLOR00FF00;

  DRAWTEXT(上涨=0 AND 最高%》25,LL*1.25,‘-25%’),COLORFF00FF;

  DRAWTEXT(上涨=0 AND 最高%》30,LL*1.3,‘-30%’),COLOR0000FF;

  DRAWTEXT(上涨=0 AND 最高%》40,LL*1.4,‘-40%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》50,LL*1.5,‘-50%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》60,LL*1.6,‘-60%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》70,LL*1.7,‘-70%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》80,LL*1.8,‘-80%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》90,LL*1.9,‘-90%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》100,LL*2,‘-100%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》125,LL*2.25,‘-125%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》150,LL*2.5,‘-150%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》180,LL*2.8,‘-180%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》200,LL*3,‘-200%’),COLOR00FFFF;

  DRAWTEXT(上涨=0 AND 最高%》250,LL*3.5,‘-250%’),COLOR00FFFF;

  DRAWTEXT(下跌=0 AND 最低%《-10,HH*0.9,‘-10%’),COLORYELLOW;

  DRAWTEXT(下跌=0 AND 最低%《-15,HH*0.85,‘-15%’),COLORFFFFFF;

  DRAWTEXT(下跌=0 AND 最低%《-20,HH*0.8,‘-20%’),COLOR00FF00;

  DRAWTEXT(下跌=0 AND 最低%《-25,HH*0.75,‘-25%’),COLORFF00FF;

  DRAWTEXT(下跌=0 AND 最低%《-30,HH*0.7,‘-30%’),COLORFF0000;

  DRAWTEXT(下跌=0 AND 最低%《-40,HH*0.6,‘-40%’),COLORFFFFFF;

  DRAWTEXT(下跌=0 AND 最低%《-50,HH*0.5,‘-50%’),COLORFFFFFF;

  DRAWTEXT(下跌=0 AND 最低%《-60,HH*0.4,‘-60%’),COLORFFFFFF;

  DRAWTEXT(下跌=0 AND 最低%《-70,HH*0.3,‘-70%’),COLORFFFFFF;

  DRAWTEXT(下跌=0 AND 最低%《-80,HH*0.2,‘-80%’),COLORFFFFFF;

  DRAWTEXT(下跌=0 AND 最低%《-90,HH*0.1,‘-90%’),COLORFFFFFF;

  DRAWTEXT(上涨=5,L,‘5天’),COLOR00FFFF;

  DRAWTEXT(上涨=8,L,‘8天’),COLOR00FFFF;

  DRAWTEXT(上涨=13,L,‘13天’),COLOR00FFFF;

  DRAWTEXT(上涨=21,L,‘21天’),COLOR00FFFF;

  DRAWTEXT(上涨=34,L,‘34天’),COLOR00FFFF;

  DRAWTEXT(上涨=55,L,‘55天’),COLOR00FFFF;

  DRAWTEXT(上涨=89,L,‘89天’),COLOR00FFFF;

  DRAWTEXT(上涨=144,L,‘144天’),COLOR00FFFF;

  DRAWTEXT(上涨=180,L,‘180天’),COLOR00FFFF;

  DRAWTEXT(上涨=250,L,‘250天’),COLOR00FFFF;

  DRAWTEXT(下跌=5,L,‘-5天’),COLOR00FF00;

  DRAWTEXT(下跌=8,L,‘-8天’),COLOR00FF00;

  DRAWTEXT(下跌=13,L,‘-13天’),COLOR00FF00;

  DRAWTEXT(下跌=21,L,‘-21天’),COLOR00FF00;

  DRAWTEXT(下跌=34,L,‘-34天’),COLOR00FF00;

  DRAWTEXT(下跌=55,L,‘-55天’),COLOR00FF00;

  DRAWTEXT(下跌=89,L,‘-89天’),COLOR00FF00;

  DRAWTEXT(下跌=144,L,‘-144天’),COLOR00FF00;

  DRAWTEXT(下跌=180,L,‘-180天’),COLOR00FF00;

  DRAWTEXT(下跌=250,L,‘-250天’),COLOR00FF00;

  LC:=REF(CLOSE,1);

  RSI:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;

  DRAWICON(CROSS(84,RSI) ,h*1.03,5);

  DRAWICON(CROSS(RSI,11) ,l*0.99,4);

  Var27:=REF(CLOSE,1);

  Var28:=SMA(MAX(CLOSE-Var27,0),5,1)/SMA(ABS(CLOSE-Var27),6,1)*100;

  DRAWICON(IF(CROSS(76,Var28),1,0),h*1.03,5);

  DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)》0 AND EMA(CLOSE,12)/LOW》1.15,5),

  LOW,‘☆’),linethick7 , COLORff00ff;

  VARA:=((AMOUNT)/(VOL))/(100);

  VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);

  VARC:=((SUM(AMOUNT,7))/(VARA))/(100);

  VARD:=DMA(VARB,(VOL)/(VARC));

  VARE:=((CLOSE-VARD)/(VARD))*(100);

  VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);

  VARJ:=MA(VARE,20)+STD(VARE,20);

  BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);

  aa:=SMA(VARF,3,1);

  ss:=(REF(BIAS18,1)》=5) AND CROSS(VARJ,VARE) AND (aa》79);

  DRAWTEXT((REF(BIAS18,1)》=5) AND CROSS(VARJ,VARE) AND

  (aa》ss),h*1.02,‘☆’),LINETHICK7,colorgreen;

  Var1:=ZIG(3,10)《REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)》REF(ZIG(3,10),2);{ZIG 有未来}

  Var2:=ZIG(3,10)》REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)《REF(ZIG(3,10),2);

  STICKLINE(Var1,C,O,8,0),COLORYELLOW,LINETHICK2;{高位黄色}

  STICKLINE(Var1,C,O,3,0),COLORYELLOW,LINETHICK2;{高位黄色}

  STICKLINE(Var1,H,L,1,0),COLORYELLOW,LINETHICK2;{高位黄色}

  STICKLINE(Var2,C,O,8,0),COLORFF00FF,LINETHICK2;{底位红色}

  STICKLINE(Var2,C,O,3,0),COLORFF00FF,LINETHICK2;{底位红色}

  STICKLINE(Var2,H,L,1,0),COLORFF00FF,LINETHICK2;{底位红色};

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top