最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧盘口数据综合分析指标公式

大智慧盘口数据综合分析指标公式

来源:网络 点击: 时间:2019-03-28

  INPUT:N(20,1,100);

  SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));

  饱和度:IF(SAT》1,1,SAT)*100,Color9368FF,PRECIS0,LINETHICK0;

  STICKLINE(C》0 AND BARSTATUS=2,5,100,10,1),COLORWHITE;

  起点量能≤5:STICKLINE(饱和度《=5 AND BARSTATUS=2,5,饱和度+20,6,0),COLORRED;

  温和量5~80:STICKLINE((饱和度》5 AND 饱和度《 80) AND BARSTATUS=2,5,饱和度+8,6,0),COLOR5290FF;

  警量80~97:STICKLINE((饱和度》80 AND 饱和度《 97) AND BARSTATUS=2,5,饱和度,6,0),COLORFFCC00;

  放量≥97:STICKLINE(饱和度》=97 AND BARSTATUS=2,5,饱和度,8,0),COLORGREEN;

  IF BARSTATUS=2 AND(饱和度) THEN BEGIN DRAWTEXTABS(610,130,‘■量能饱和度:’+NUMTOSTRN(饱和度,0)+‘%’),Color9368FF;END;

  K:=(DATE 《 1341230);

  XD1:=INDEXO;

  XD2:=INDEXH;

  XD3:=INDEXL;

  XD4:=INDEXC;

  对应指数开盘:=INDEXO;

  盘中最高点位:=INDEXH;

  盘中最低点位:=INDEXL;

  收盘点位:=INDEXC;

  大盘资金增减:=(100 * ((INDEXV / REF(INDEXV,1)) - 1));

  大盘上涨家数:=INDEXADV;

  平盘家数:=DYNAINFO(68);

  大盘下跌家数:=INDEXDEC;

  昨收盘:=DYNAINFO(3);

  今开盘:=DYNAINFO(4);

  涨幅:=DYNAINFO(14)*100;

  JJ:=(((XD4 + XD2) + XD3) / 3);

  A:=EMA(JJ,10);

  B:=REF(A,1);

  买卖决策:=B;

  DRAWTEXTABS(20,10,‘【大盘盘口动态观察】’),Color00FFFF;

  DRAWTEXTABS(20,25,‘对应个股开盘:’+对应指数开盘+‘点’),Color00FFFF;

  DRAWTEXTABS(20,40,‘盘中最高点位:’+盘中最高点位+‘点’),Color00FFFF;

  DRAWTEXTABS(20,55,‘盘中最低点位:’+盘中最低点位+‘点’),Color00FFFF;

  DRAWTEXTABS(20,70,‘■大盘资金增减:’+NUMTOSTRN(大盘资金增减,0)+‘%’),Color00FF00;

  DRAWTEXTABS(20,85,‘大盘今日上涨:’+大盘上涨家数+‘家’),Color00FFFF;

  DRAWTEXTABS(20,100,‘大盘今日平盘:’+平盘家数+‘家’),Color00FFFF;

  DRAWTEXTABS(20,115,‘大盘今日下跌:’+NUMTOSTRN(大盘下跌家数,0)+‘家’),Color00FFFF;

  买入委托成交:=ORDER(1);

  卖出委托成交:=ORDER(2);

  当日成交总量:=DYNAINFO(8);

  成交总金额:=DYNAINFO(10)/10000;

  主动卖盘:=DYNAINFO(22);

  主动买盘:=DYNAINFO(23);

  成交笔数:=TICKCOUNT;

  每笔手数:=DYNAINFO(53);

  DRAWTEXTABS(160,10,‘【个股盘口成交量观察】’),ColorD3A9FF;

  DRAWTEXTABS(160,25,‘日成交总量:’+NUMTOSTRN(当日成交总量,0)+‘手’),ColorD3A9FF;

  DRAWTEXTABS(160,40,‘日主动买入量:’+NUMTOSTRN(主动买盘,0)+‘手’),ColorD3A9FF;

  DRAWTEXTABS(160,55,‘日主动卖出量:’+NUMTOSTRN(主动卖盘,0)+‘手’),ColorD3A9FF;

  DRAWTEXTABS(160,70,‘■当前成交概况:’+NUMTOSTRN(成交笔数,0)+‘笔’),Color00FF00;

  DRAWTEXTABS(160,85,‘每笔成交:’+NUMTOSTRN(每笔手数,1)+‘手’),ColorD3A9FF;

  DRAWTEXTABS(160,100,‘买入下单委托成交:’+NUMTOSTRN(买入委托成交,0)+‘单’),ColorD3A9FF;

  DRAWTEXTABS(160,115,‘卖出下单委托成交:’+NUMTOSTRN(卖出委托成交,0)+‘单’),ColorD3A9FF;{换手率--成交量--委卖委买量:综合分析}

  n1:=barslast(cross(c,MA(c,60)));

  n2:=barslast(cross(MA(c,60),c));

  强势股排序:if(n1《n2,n1+1,0),PRECIS0,Color00FFFF,LINETHICK0;

  日换手率:=DYNAINFO(37)*100;

  5日换手率:sum(100*v/capital,5),ColorFFFFFF,PRECIS0,LINETHICK0;

  5日均量:DYNAINFO(38),ColorFFFFFF,PRECIS0,LINETHICK0;

  大单20万买入:DYNAINFO(94)*100,ColorFFFFFF,PRECIS0,LINETHICK0;

  大单20万卖出:=DYNAINFO(97)*100;

  50万大单买入:BIGORDER(1,3)*100,ColorFFFFFF,PRECIS0,LINETHICK0;

  卖出50万委托单:=BIGORDER(2,3)*100;

  建仓成本:=MAXCYC;

  压力位:=DMA(AMOUNT/(100*VOL),VOL/(100*FINANCE2(37)))*1.12;

  avgbpx:=DYNAINFO(87);

  avgopx:=DYNAINFO(88);

  tbqty:=DYNAINFO(89);

  toqty:=DYNAINFO(90);

  bq:=DYNAINFO(89)/capital;

  oq:=DYNAINFO(90)/capital;

  bm:=tbqty/((DYNAINFO(7)-avgbpx)*2/DYNAINFO(7)*100);

  om:=toqty/((avgopx-DYNAINFO(7))*2/DYNAINFO(7)*100);

  bd:=(DYNAINFO(7)-avgbpx)/(avgopx-avgbpx)*120;

  od:=(avgopx-DYNAINFO(7))/(avgopx-avgbpx)*120;

  gy:=max(bm,om);

  DRAWTEXTABS(300,10,‘【换手率--成交量--委卖委买量:综合分析】’),ColorFFFF00;

  DRAWTEXTABS(300,25,‘委卖→总量:’+str(toqty)+‘ 占流通盘比例:’+str(oq*100)+‘%’+‘ 密度:’+str(INTPART(om))+‘手 价宽:’+str(max(0,avgopx*2-DYNAINFO(7)*2))+‘元 ’+str(max(0,avgopx/DYNAINFO(7)*200-200))+‘%’),Color00B4FF,layer0;

  DRAWTEXTABS(300,40,‘委买→总量:’+str(tbqty)+‘ 占流通盘比例:’+str(bq*100)+‘%’+‘ 密度:’+str(INTPART(bm))+‘手 价宽:’+str(if(avgbpx=0,0,DYNAINFO(7)*2-avgbpx*2))+‘元 ’+str(max(0,DYNAINFO(7)/avgbpx*200-200))+‘%’),Color00B4FF,layer0;

  DRAWTEXTABS(300,55,‘委卖委买比:’+str((tbqty-toqty)/(tbqty+toqty)*100)+‘%→’),layer0,Color0000FF;

  DRAWTEXTABS(300,70,‘■个股对应大盘买卖决策点位:’+NUMTOSTRN(买卖决策,2)+‘点’),Color00FF00;

  DRAWTEXTABS(300,115,‘日换手率:’+NUMTOSTRN(日换手率,1)+‘%’),ColorFFFF00;

  DRAWTEXTABS(300,85,‘日成交总金额:’+NUMTOSTRN(成交总金额,0)+‘万元’),ColorFFFF00;

  DRAWTEXTABS(495,85,‘20万大单买入:’+NUMTOSTRN(大单20万买入,0)+‘%’),ColorFFFF00;

  DRAWTEXTABS(610,85,‘20万大单卖出:’+NUMTOSTRN(大单20万卖出,0)+‘%’),ColorFFFF00;

  DRAWTEXTABS(495,100,‘50万大单买入:’+NUMTOSTRN(50万大单买入,0)+‘%’),ColorFFFF00;

  DRAWTEXTABS(610,100,‘50万大单卖出:’+NUMTOSTRN(卖出50万委托单,0)+‘%’),ColorFFFF00;

  DRAWTEXTABS(390,115,‘5日换手率:’+NUMTOSTRN(5日换手率,1)+‘%’),ColorFFFF00;

  DRAWTEXTABS(495,115,‘5日均量:’+NUMTOSTRN(5日均量,0)+‘手’),ColorFFFF00;

  DRAWTEXTABS(610,115,‘平均成本:’+NUMTOSTRN(建仓成本,2)+‘元’),ColorFFFF00;

  DRAWTEXTABS(560,10,STKLABEL+‘ ’+STKNAME),Color80FFFF,LINETHICK2;

  DRAWTEXTABS(160,130,‘■股价上穿60均线:’+NUMTOSTRN(强势股排序,0)+‘天’),Color00FF00,LINETHICK1;

  DRAWTEXTABS(300,130,‘■心理成本压力位:’+NUMTOSTRN(压力位,2)+‘元’),Color00FFFF,LINETHICK1;

  DRAWTEXTABS(430,55,‘昨收盘:’+NUMTOSTRN(昨收盘,2)+‘元’),ColorFFFF00;

  DRAWTEXTABS(530,55,‘今开盘:’+NUMTOSTRN(今开盘,2)+‘元’),ColorFFFF00;

  DRAWTEXTABS(630,55,‘涨跌幅度:’+NUMTOSTRN(涨幅,2)+‘%’),ColorFFFF00;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top