最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧股票公式:狄马克指标

大智慧股票公式:狄马克指标

来源:网络 点击: 时间:2018-08-25

  大智慧股票公式有哪些?大智慧股票公式是什么?下面股票知识网为您介绍大智慧股票公式。

  a:=“STSFunc@CALSTSL”;

  R1:=“STSFunc@STS_RISK1”;

  R2:=“STSFunc@STS_RISK2”;

  S1:=“STSFunc@STS_STS1”;

  S2:=“STSFunc@STS_STS2”;

  TBS:=“STSFunc@STS_STSBS”;

  DN:=“STSFunc@STS_STSDN”;

  UP:=“STSFunc@STS_STSUP”;

  压力位:UP,linethick0,color0000ff,PRECIS2;

  支撑位:DN,linethick0,color00ff00,PRECIS2;

  警示位:IF(R1《》0,ABS(R1),IF(R2《》0,ABS(R2),0)),linethick0,colorff00ff,PRECIS2;

  {MA5:MA(CLOSE,5),colorFFFFff,PRECIS2; MA10:MA(CLOSE,10),color00FFff,PRECIS2;

  MA20:MA(CLOSE,20),colorFF00ff,PRECIS2; MA30:MA(CLOSE,30),color00FF00,PRECIS2;

  MA60:MA(CLOSE,60),colorAAAAAA,PRECIS2; MA120:MA(CLOSE,120),colorFF0000,PRECIS2;}

  STICKLINE(IF(STRFIND(stkname,‘S’,1)=0,CLOSE》=REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE》=REF(CLOSE,1)*1.0490 AND CLOSE=HIGH),CLOSE,OPEN,8,0),COLOR00FFFF;

  STICKLINE(CLOSE》=REF(CLOSE,1)*1.07 AND (C《》H OR C《=REF(C,1)*1.098),CLOSE,OPEN,8,0),COLORFFFFFF;

  STICKLINE(STRFIND(stkname,‘S’,1)=0 AND CLOSE》REF(CLOSE,1)*1.05 AND CLOSE《REF(CLOSE,1)*1.07,CLOSE,OPEN,8,0),COLORFFD0FF;

  STICKLINE(IF(STRFIND(stkname,‘S’,1)=0,CLOSE《REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE《REF(CLOSE,1)*0.9515 AND CLOSE=LOW),CLOSE,OPEN,8,0),COLORFF0000;

  流通:=INTPART(FINANCE2(37)/1000*C)/10;

  市盈:=INTPART(DYNAINFO(39)*10)/10;

  动态市盈:=INTPART(C/FINANCE2(3)*10)/10;

  DRAWTEXTABS(1,13,‘流通市值:’+流通+‘亿’),LINETHICK1,Color00FF00;

  DRAWTEXTABS(120,13,‘市盈率:’+市盈+‘ / ’+动态市盈+‘ ’),LINETHICK1,Colorgreen;

  DRAWTEXTREL(1,3,BKNAME),LINETHICK1,COLORAAEEEE;

  DRAWLINE(UP》0,UP,UP《》REF(UP,1) OR C=DYNAINFO(7),REF(ABS(UP),1),0),dotline,color0000ff,LINETHICK1;

  DRAWLINE(DN》0,DN,DN《》REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),dotline,color00ff00,LINETHICK1;

  DRAWLINE(UP《0,-UP,UP《》REF(UP,1) OR

  C=DYNAINFO(7),REF(ABS(UP),1),0),color0000ff;

  DRAWLINE(DN《0,-DN,DN《》REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),color00ff00;

  DRAWLINE(R1》0,R1,R1《》REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),dotline,colorEE88ff;

  DRAWLINE(R2》0,R2,R2《》REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),dotline,colorEE88ff;

  DRAWLINE(R1《0,-R1,R1《》REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),colorEE88ff;

  DRAWLINE(R2《0,-R2,R2《》REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),colorEE88ff;

  drawbmp(TBS=1,l*0.96,‘STSbuy1.bmp’),align1,valign0;

  drawbmp(TBS=-1,h*1.07,‘STSsell1.bmp’),align1,valign0;

  drawbmp(S2=14,l*0.94,‘STSbuy.bmp’),align1,valign0;

  drawbmp(S2=-14,h*1.09,‘STSsell.bmp’),align1,valign0;

  drawtext(S1》0,L,STR(S1)),color00FF00,LINETHICK1,align1,valign0;

  drawtext(S1《0,H*1.03,STR(-S1)),color00FF00,LINETHICK1,align1,valign0;

  drawtext(S2》0 and S2《13,l*0.97,STR(S2)),color0000FF,LINETHICK1,align1,valign0;

  drawtext(S2《0 and S2》-13,H*1.06,STR(-S2)),color0000FF,LINETHICK1,align1,valign0;

  drawtext(S2=13,l*0.97,‘+’),color0000FF,LINETHICK1,align1,valign0;

  drawtext(S2=14,l*0.97,‘13’),color0000FF,LINETHICK1,align1,valign0;

  drawtext(S2=-13,h*1.06,‘+’),color0000FF,LINETHICK1,align1,valign0;

  drawtext(S2=-14,h*1.06,‘13’),color0000FF,LINETHICK1,align1,valign0;

  b:=“LTFunc5@FORLT2”; s1:=“LTFunc5@LT_S1”;

  p0:=“LTFunc5@LT_P0”; p1:=“LTFunc5@LT_P1”;

  hs:=“LTFunc5@LT_HS”; ls:=“LTFunc5@LT_LS”;

  upp:=“LTFunc5@LT_UPP”; udd:=“LTFunc5@LT_UDD”;

  d2:=“Lxddx.ddx”/ema(abs(“Lxddx.ddx”),60)+8;

  d3:=min(“Lxddx.ddx”/ema(abs(“Lxddx.ddx”),60),10);

  fb:=if(s1=0,hs,ls);

  tr0:=ifs(p1=1,‘明日《’+numtostrn(udd,2)+‘,出现S点’,‘明日》’+numtostrn(upp,2)+‘,出现B点’);

  tr1:=ifs(s1=1,‘明日《’+numtostrn(ls,2)+‘,短线卖出’,‘明日》’+numtostrn(hs,2)+‘,短线买入’);

  tr2:=ifs(p1=1,ifs(cross(p1,0),‘B点’,‘持股待涨’),ifs(cross(1,p1),‘S点’,‘持币观望’));

  tr3:=ifs(s1=0,‘向下 ’,‘向上 ’);

  tr4:=‘ 能量级别:’+numtostrn(d3,1)+‘级’;

  {hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd;}

  d1:=ema(abs(“ddx.ddx”),60);

  {ddx绝对值60日指数平滑移动平均} d2:=max(“ddx.ddx”/d1+7.5,7.5);

  d3:=min(“ddx.ddx”/d1,10);

  {能量级别:当日ddx与60日平均值的比值,最高10.0}

  fb:=if(s1=0,hs,ls);

  tr0:=ifs(p1=1,‘明日收盘价《’+numtostrn(udd,2)+‘,出现S点\n’,‘若明日收盘价》’+numtostrn(upp,2)+‘,出现B点\n’);

  tr1:=ifs(s1=1,‘明日收盘价《’+numtostrn(ls,2)+‘,短线卖出机会’,‘若明日收盘价》’+numtostrn(hs,2)+‘短线买入机会’);

  tr2:=ifs(p1=1,ifs(cross(p1,0),‘B点’,‘持股’),ifs(cross(1,p1),‘S点’,‘持币’)); tr3:=ifs(s1=0,‘向下,’,‘向上,’);

  tr4:=‘3.能量级别:’+numtostrn(d3,1)+‘级’;

  bs:=‘《*t=0092F7*》《*c=FFFFFF*》《*p=95*》’+datestr(date)+‘买卖点决策系统提示\n’+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+‘1.BS点:’+tr2+‘,’+tr0+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+‘2.短线:’+tr3+tr1+‘\n’+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+tr4; drawflagtext(1,fb,bs);

  {1120,0415新版用代码}

  drawbmp(p1=1 and ref(p1,1)=0,l,‘buy1.bmp’),align1,valign0; drawbmp(p1=0 and ref(p1,1)=1,h,‘sell1.bmp’),align1,valign2;

  drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))《》1,l,‘bs.bmp’),align1,valign0; drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))《》1,h,‘ss.bmp’),align1,valign2;

  更多大智慧股票公式知识请关注股票知识网

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top