最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧股票公式:变色龙

大智慧股票公式:变色龙

来源:网络 点击: 时间:2019-03-24

  大智慧股票公式有哪些?大智慧股票公式是什么?下面股票知识网为您介绍大智慧股票公式。

  INPUT:M(10,1,30,1);

  止盈线:(MA(CLOSE,M) * 1.15),Color0000FF;

  分水岭:(MA(CLOSE,M) * 1),COLORWHITE;

  止损线:(MA(CLOSE,M) * 0.85),Color00FF80;

  总股本:=FINANCE2(35) ;

  流通股:=FINANCE2(37);

  限售A股:=FINANCE2(41);

  每股收益:=FINANCE2(3);

  市盈率:=DYNAINFO(39);

  每股公积金:=FINANCE2(7);

  所属板块:=BKNAME;

  DRAWTEXTABS(12,14, ‘所属板块: ’+所属板块),COLORYELLOW;

  DRAWTEXTABS(12,27,‘每股收益: ’+NUMTOSTRN(每股收益,3)+‘元 利润增长:’+FINANCE2(10)+‘% 市盈率:’+NUMTOSTRN(市盈率,1)+‘倍 ’+‘ 每股公积金:’+NUMTOSTRN(每股公积金,2)+‘元’),COLORYELLOW;

  DRAWTEXTABS(12,40,‘总 股 本: ’+NUMTOSTRN(总股本,2)+‘万股’+‘ 流通A股:’+NUMTOSTRN(流通股,2)+‘万股’+‘ 限售A股:’+NUMTOSTRN(限售A股,2)+‘万股’),COLORYELLOW;

  {17}

  x9:FORCAST(c,9),Colorwhite,LINETHICK2;

  llx:=llv(FORCAST(c,9),2);

  DRAWGBKLAST(DYNAINFO(3)《DYNAINFO(7){OPEN},STRIP(RGB(0,150,0),RGB(150,0,0),1));

  DRAWGBKLAST({CLOSE}DYNAINFO(3)》DYNAINFO(7){OPEN},STRIP(RGB(150,0,0),RGB(0,150,0),1));

  DRAWTEXTREL(550,900,STKLABEL+‘ ’+STKNAME+‘ ’+DYNAINFO(7)+‘元’+‘ ’+DYNAINFO(14)*100+‘%’),LINETHICK4,COLORFFFF00;

  PARTLINE(x9,x9=llx,rgb(255,205,0),x9《》llx,rgb(255,0,0)),linethick4;

  {24}

  {柱图}

  STICKLINE(c》=o and o《》0,HIGH,LOW,0.5,0),color0000CD;

  STICKLINE(c》=o and o《》0,CLOSE,OPEN,8,0),color070084;

  STICKLINE(c》=o and o《》0,CLOSE,OPEN,7,0),color0000A3;

  STICKLINE(c》=o and o《》0,CLOSE,OPEN,6,0),color0000B7;

  STICKLINE(c》=o and o《》0,CLOSE,OPEN,5,0),color0000CD;

  STICKLINE(c》=o and o《》0,CLOSE,OPEN,4,0),color0000E9;

  STICKLINE(c》=o and o《》0,CLOSE,OPEN,2,0),color0754E9;

  STICKLINE(c》=o and o《》0,CLOSE,OPEN,0.5,0),Color68B8FF;

  STICKLINE(c《o and o《》0,HIGH,LOW,0.5,0),colorFFBE00;

  STICKLINE(CLOSE《OPEN and OPEN《》0,HIGH,LOW,0.5,0),colorFFBE00;

  STICKLINE(CLOSE《OPEN and OPEN《》0,CLOSE,OPEN,8,0),ColorCA6500;

  STICKLINE(CLOSE《OPEN and OPEN《》0,CLOSE,OPEN,7,0),ColorE17100;

  STICKLINE(CLOSE《OPEN and OPEN《》0,CLOSE,OPEN,6,0),ColorF27900;

  STICKLINE(CLOSE《OPEN and OPEN《》0,CLOSE,OPEN,5,0),ColorFF850B;

  STICKLINE(CLOSE《OPEN and OPEN《》0,CLOSE,OPEN,4,0),ColorFF9326;

  STICKLINE(CLOSE《OPEN and OPEN《》0,CLOSE,OPEN,2,0),ColorFFA851;

  STICKLINE(CLOSE《OPEN and OPEN《》0,CLOSE,OPEN,0.5,0),colorFFFF00;

  {43}

  DRAWGBK(c,‘7’ );

  Var3:=LLV(H,240);

  Var4:=100*(C-Var3)/Var3;

  Var5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;

  Var6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;

  {Var7:=0;}

  Var8:=MA(HHV(C-REF(C,1),0),34)/MA(ABS(C-REF(C,1)),7)*100;

  Var9:=MA(HHV(C-REF(C,1),0),13)/MA(ABS(C-REF(C,1)),13)*100;

  VarA:=BARSCOUNT(C);

  VarB:=Var8《20 AND Var9《23 AND VarA》35;

  VarC:=VarB AND COUNT(VarB,1)=1;

  VarD:=EMA(C,21)-EMA(C,8);

  VarE:=EMA(VarD,5);

  VarF:=TROUGH(3,6,1)《4 AND CROSS(VarD,VarE);

  Var10:=IF(TROUGH(3,16,1)=0 AND H》L+0.04,4,0);

  Var11:=ZIG(3,6)》REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)《=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)《=REF(ZIG(3,6),3);

  Var12:=ZIG(3,6)《REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)》=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)》=REF(ZIG(3,6),3);

  Var13:=ZIG(3,22)》REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)《=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)《=REF(ZIG(3,22),3);

  Var14:=ZIG(3,22)《REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)》=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)》=REF(ZIG(3,22),3);

  Var15:=ZIG(3,51)》REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)《=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)《=REF(ZIG(3,51),3);

  Var16:=ZIG(3,51)《REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)》=REF(ZIG(3,51),2)AND REF(ZIG(3,51),2)》=REF(ZIG(3,51),3);

  Var17:=ZIG(3,72)》REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)《=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)《=REF(ZIG(3,72),3);

  Var18:=ZIG(3,72)《REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)》=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)》=REF(ZIG(3,72),3);

  Var19:=EMA(C,2)-EMA(C,150);

  Var1A:=EMA(Var19,100);

  Var1B:=2*(Var19-Var1A);

  Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);

  Var1D:=SQRT(SQRT(L*H*O*C));

  Var1E:=EMA(Var1D*0.97,3);

  Var1F:=(H+L+C)/3;

  Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));

  Var21:=CROSS(Var1E,L);

  买点1:=Var10;

  买点2:=(Var11+Var13+Var15+Var17);

  卖点1:=(Var12+Var14+Var16+Var18);

  Var22:=买点1 AND VarF AND VarC AND Var21 AND Var4《0AND Var5=0 AND Var6=0 AND Var20《(-110);

  DRAWTEXT(买点1》0,L-0.15,‘B’),LINETHICK4,ALIGN1,colorred;{B}

  DRAWTEXT(买点2》0,L-0.25,{‘B’}‘买’),LINETHICK4,ALIGN1,COLOR00FFFF;{B}

  DRAWTEXT(卖点1》0,H+0.95,{‘S’}‘卖’),LINETHICK4,ALIGN1,COLOR33FF33;{S}

  {83}

  {十字光标提示}

  a:=“LTFunc4@FORLT2”;

  s1:=“LTFunc4@LT_S1”;

  hs:=“LTFunc4@LT_HS”;

  ls:=“LTFunc4@LT_LS”;

  p1:=“LTFunc4@LT_P1”;

  upp:=“LTFunc4@LT_UPP”;

  udd:=“LTFunc4@LT_UDD”;

  {hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};

  d1:=ema(abs(“ddx.ddx”),60);

  d2:=max(“ddx.ddx”/d1+7.5,7.5);

  d3:=min(“ddx.ddx”/d1,10);

  fb:=if(s1=0,hs,ls);

  tr0:=ifs(p1=1,‘明日收盘价《’+numtostrn(udd,2)+‘,出现“卖”点\n’,‘若明日收盘价》’+numtostrn(upp,2)+‘,出现“买”点\n’);{1.BS点:}

  tr1:=ifs(s1=1,‘明日收盘价《’+numtostrn(ls,2)+‘,短线卖出机会’,‘若明日收盘价》’+numtostrn(hs,2)+‘短线买入机会’);{2.短线:}

  tr2:=ifs(p1=1,ifs(cross(p1,0),‘“买”点’,‘持股’),ifs(cross(1,p1),‘“卖”点’,‘持币’));{1.BS点:}

  tr3:=ifs(s1=0,‘向下,’,‘向上,’);{2.短线:}

  tr4:=‘3.能量级别:’+numtostrn(d3,1)+‘级’;{3.能量级别:}

  {102}

  c1:=INTPART(cyc(5)*100*0.96)/100;

  p2:=intpart(ref(cyc(5),1)*100)/100;

  p3:=intpart(ref(cyc(5),1)*0.96*100)/100;

  vv:=intpart(min(capital*0.05,ref(ma(vol,34),1))/100);

  p40:=intpart(maxcyc*100)/100;

  p41:=intpart(ref(MAXCYC,1)*100)/100;

  p4:=p1=0 and c》p2 or (ref(vol/100,1)《vv and c》intpart(p2*0.98*100)/100 and vol》min(capital*0.05,ref(ma(vol,34),1)));

  p5:=p1=1 and c《min(p3,p41);

  p1:=if(p4=1,1,if(p5=1,0,ref(p1,1)));

  DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c》0.1,c,‘持币’);{4.}

  DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c《=0.1 and ref(vol/100,1)《vv,c,‘明日收盘价超过’+str(c1)+‘;或收盘价超过’+str(intpart(c1*0.98*100)/100)+‘且成交量大于’+str(vv)+‘买入’);

  DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c《=0.1 and ref(vol/100,1)》=vv,c,‘明日收盘价超过’+str(c1)+‘买入’);

  DRAWFLAGTEXT(p1=1 and (c-min(c1,p40))/min(c1,p40)》0.1 ,c,‘持股’);

  DRAWFLAGTEXT(p1=1 and (c-min(c1,p40))/min(c1,p40)《=0.1 ,c,‘明日收盘价跌破’+str(min(c1,p40))+‘卖出’);

  {117}

  bs:=‘《*t=0092F7*》《*c=FFFFFF*》《*p=95*》’+datestr(date)+‘买卖点决策系统提示\n’+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+‘1.BS点:’+tr2+‘,’+tr0+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+‘2.短线:’+tr3+tr1+‘\n’+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+tr4;

  drawflagtext(1,fb,bs);

  更多大智慧股票公式知识请关注股票知识网

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top