最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧股票公式:神獒均线

大智慧股票公式:神獒均线

来源:网络 点击: 时间:2019-05-22

  大智慧股票公式有哪些?大智慧股票公式是什么?下面股票知识网为您介绍:大智慧股票公式。

if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
ee:=hhv(h,ddd);
MSTATUS:=BARSTATUS=2;
MA5:MA(C,5),PRECIS2;
MA10:MA(C,10),PRECIS2;
MA30:MA(C,30),PRECIS2;
MA60:MA(C,60),PRECIS2,LINETHICK2;
MA125:MA(C,125),ColorFFFF00,PRECIS2,LINETHICK2;
MA250:MA(C,250),PRECIS2,LINETHICK2;
i:=1;
IF MSTATUS and (MA5 > MA10 and MA10 > MA30 and MA5 > MA30) THEN BEGIN DRAWTEXTABS(0,i*16,'短期均线多头排列。股价高位谨防筑顶。中低位当股价向上突破5、10、30日均线,均线呈多头排列是最佳买入时机。'+ma5+' > '+ma10+' > '+ma30+';'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 < MA10 and MA10 < MA30 and MA5 < MA30) THEN BEGIN DRAWTEXTABS(0,i*16,'短期均线空头排列。股价高位谨防弃庄,卖盘涌出破位下跌。中低位当股价向下突破5、10、30日均线,均线呈空头排列时,注意观察股价所处箱体位置。'+ma5+' < '+ma10+' < '+ma30+';'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 > MA60 and MA30 > MA125 and MA60 > MA125) THEN BEGIN DRAWTEXTABS(0,i*16,'中期均线多头排列。注意股价突然下跌,当股价回档至当前盘面30、60、125日任一均线获得支撑,关注均线助涨,次日股价放量向上突破,是中长期最佳买入时机。'+ma30+' > '+ma60+' > '+ma125+';'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 < MA60 and MA30 < MA125 and MA60 < MA125) THEN BEGIN DRAWTEXTABS(0,i*16,'中期均线空头列排。30、60、125日中长期均线下行呈空头排列,注意箱体上下撑压或无量空跌。 '+ma30+' < '+ma60+' < '+ma125+';'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA60 > MA125 and MA125 > MA250 and MA60 > MA250) THEN BEGIN DRAWTEXTABS(0,i*16,'长期均线多头排列。即60,125,250日均线向上多头排列。注意:当股价处于箱体顶部,所有均线多头排列,股价反复震荡不能突破,可能顶部即将形成。'+ma60+' > '+ma125+' > '+ma250+';'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1; END;
IF MSTATUS and (MA60 < MA125 and MA125 < MA250 and MA60 < MA250) THEN BEGIN DRAWTEXTABS(0,i*16,'长期均线空头排列。即60,125,250日均线向下空头排列。注意:当所有均线空头排列的时候,股价处于箱体的一个次高位,中位,或箱体下沿,可能是阶段底部的形成。 '+ma60+' < '+ma125+' < '+ma250+';'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA5,MA10)) THEN BEGIN DRAWTEXTABS(0,i*16,'短期5日10日均线金叉。注意观察股价在箱体的位置,30日和其他均线是否成为股价上涨的阻力,或股价在高位的运行方向,判断是反转上涨还是下跌中途的小反弹。'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA10,MA5)) THEN BEGIN DRAWTEXTABS(0,i*16,'短期5日10日均线死叉。当股价反弹遭遇30日和其他均线的阻力形成死叉,可能是股价下跌中途的小反弹。高位区死叉,必须逃顶或止损。'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(C,MA125)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价上穿半年线。在半年线上方运行的个股被称为强势股。适合中小资金根据短线技术指标套利操作。 '),COLORFF00FF,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA125,C)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价跌破半年线。在半年线下方运行的个股被称为弱势股。适合大资金进场吸筹操作。 '),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(C,MA250)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价上穿年线。股票筑底后,股价经过反复震荡洗盘上穿年线,予以锁定跟踪。 '),COLORFF00FF,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA250,C)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价跌破年线。跌破年线,证明深度调整格局可能形成。如果后市股价继续深跌,调整时间和空间难以预测。 '),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(C,MA60) and CROSS(C,MA125) and CROSS(C,MA250)) THEN BEGIN DRAWTEXTABS(0,i*16,'股价一阳穿三线。5、10、30日均线三线合一,股价一阳穿三线,向上反转,可能变盘反转在即。 '),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 > REF(MA30,1)) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均线趋势向上。注意:如果股价在低位中位30日均线之上,围绕另一条重要均线缩量横盘,随后5-10日均线金叉,所有均线向上呈多头排列,是中长期绩优牛股的摇篮。'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 > REF(MA30,1) AND MA30 < REF(MA30,1)*1.001) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均线趋势走平。需观察5日和10日均线方向,如30日均线发出趋势向下信号,5日10日均线形成死叉,注意减仓或出货。'),COLORFFCC66,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 < REF(MA30,1)) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均线趋势向下。关注股价所处箱体位置,如股价当前上涨或下跌时,则需观察箱体阻力支撑位置。如果股价处于远离30日均线位置,一般情况下股价反弹空间有限。'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 > REF(MA5,1)*1.015) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均线强劲向上。需观察股价所处其他均线和箱体位置,如果收盘时股价突然跌破5日均线,则需观察箱体下方支撑,提防空头陷阱,股价转向。'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 > REF(MA5,1) AND MA5 < REF(MA5,1)*1.005) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均线方向不明。当股价连续跌破5日均线和箱体下沿,导致股价方向开始向下,绩优股应适当做空;股价在箱体内则需观察股价下方的重要均线位置,可否获得支撑。'),COLORYELLOW,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 < REF(MA5,1)*0.985) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均线快速向下,短线风险可能降临。需结合其他均线运行方向分析,如果股价在一个大箱体中,则需观察下方均线支撑,偌收盘前股价获得支撑,5-10均线金叉并数日向上,则可顺势而为做多。'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
if DISPSTATUS=2 then begin;
var100:='■所属行业板块:';
if inblock('电力')=1 then var100:=var100+'电力。';
if inblock('电力设备')=1 then var100:=var100+'电力设备。';
if inblock('电器')=1 then var100:=var100+'电器。';
if inblock('电子信息')=1 then var100:=var100+'电子信息。';
if inblock('房地产')=1 then var100:=var100+'房地产。';
if inblock('纺织服装')=1 then var100:=var100+'纺织服装。';
if inblock('钢铁')=1 then var100:=var100+'钢铁。';
if inblock('工程建筑')=1 then var100:=var100+'工程建筑。';
if inblock('供水供气')=1 then var100:=var100+'供水供气。';
if inblock('化工')=1 then var100:=var100+'化工。';
if inblock('化纤')=1 then var100:=var100+'化纤。';
if inblock('机械')=1 then var100:=var100+'机械。';
if inblock('计算机')=1 then var100:=var100+'计算机。';
if inblock('建材')=1 then var100:=var100+'建材。';
if inblock('交通工具')=1 then var100:=var100+'交通工具。';
if inblock('交通设施')=1 then var100:=var100+'交通设施。';
if inblock('教育传媒')=1 then var100:=var100+'教育传媒。';
if inblock('旅游酒店')=1 then var100:=var100+'旅游酒店。';
if inblock('煤炭石油')=1 then var100:=var100+'煤炭石油。';
if inblock('酿酒食品')=1 then var100:=var100+'酿酒食品。';
if inblock('农林牧渔')=1 then var100:=var100+'农林牧渔。';
if inblock('其他行业')=1 then var100:=var100+'其他行业。';
if inblock('汽车')=1 then var100:=var100+'汽车。';
if inblock('汽配')=1 then var100:=var100+'汽配。';
if inblock('券商')=1 then var100:=var100+'券商。';
if inblock('商业连锁')=1 then var100:=var100+'商业连锁。';
if inblock('石化')=1 then var100:=var100+'石化。';
if inblock('通信')=1 then var100:=var100+'通信。';
if inblock('外贸')=1 then var100:=var100+'外贸。';
if inblock('医药')=1 then var100:=var100+'医药。';
if inblock('仪电仪表')=1 then var100:=var100+'仪电仪表。';
if inblock('银行类')=1 then var100:=var100+'银行类。';
if inblock('有色金属')=1 then var100:=var100+'有色金属。';
if inblock('运输物流')=1 then var100:=var100+'运输物流。';
if inblock('造纸印刷')=1 then var100:=var100+'造纸印刷。';
if inblock('其他制造业')=1 then var100:=var100+'其他制造业。';
if inblock('安徽')=1 then var100:=var100+'所属地区:安徽。';
if inblock('北京')=1 then var100:=var100+'所属地区:北京。';
if inblock('福建')=1 then var100:=var100+'所属地区:福建。';
if inblock('甘肃')=1 then var100:=var100+'所属地区:甘肃。';
if inblock('广东')=1 then var100:=var100+'所属地区:广东。';
if inblock('广西')=1 then var100:=var100+'所属地区:广西。';
if inblock('贵州')=1 then var100:=var100+'所属地区:贵州。';
if inblock('海南')=1 then var100:=var100+'所属地区:海南。';
if inblock('河北')=1 then var100:=var100+'所属地区:河北。';
if inblock('河南')=1 then var100:=var100+'所属地区:河南。';
if inblock('黑龙江')=1 then var100:=var100+'所属地区:黑龙江。';
if inblock('湖北')=1 then var100:=var100+'所属地区:湖北。';
if inblock('湖南')=1 then var100:=var100+'所属地区:湖南。';
if inblock('吉林')=1 then var100:=var100+'所属地区:吉林。';
if inblock('江苏')=1 then var100:=var100+'所属地区:江苏。';
if inblock('江西')=1 then var100:=var100+'所属地区:江西。';
if inblock('辽宁')=1 then var100:=var100+'所属地区:辽宁。';
if inblock('内蒙古')=1 then var100:=var100+'所属地区:内蒙古。';
if inblock('宁夏')=1 then var100:=var100+'所属地区:宁夏。';
if inblock('青海')=1 then var100:=var100+'所属地区:青海。';
if inblock('山东')=1 then var100:=var100+'所属地区:山东。';
if inblock('山西')=1 then var100:=var100+'所属地区:山西。';
if inblock('陕西')=1 then var100:=var100+'所属地区:陕西。';
if inblock('上海')=1 then var100:=var100+'所属地区:上海。';
if inblock('深圳')=1 then var100:=var100+'所属地区:深圳。';
if inblock('四川')=1 then var100:=var100+'所属地区:四川。';
if inblock('天津')=1 then var100:=var100+'所属地区:天津。';
if inblock('西藏')=1 then var100:=var100+'所属地区:西藏。';
if inblock('新疆')=1 then var100:=var100+'所属地区:新疆。';
if inblock('云南')=1 then var100:=var100+'所属地区:云南。';
if inblock('浙江')=1 then var100:=var100+'所属地区:浙江。';
if inblock('重庆')=1 then var100:=var100+'所属地区:重庆。';
if inblock('3G')=1 then var100:=var100+' 3G概念→';
if inblock('CDM项目')=1 then var100:=var100+' CDM项目概念→';
if inblock('H股')=1 then var100:=var100+' H股概念→';
if inblock('QFII持股')=1 then var100:=var100+'QFII持股概念→';
if inblock('ST')=1 then var100:=var100+'ST概念→';
if inblock('S板')=1 then var100:=var100+'S板概念→';
if inblock('奥运')=1 then var100:=var100+'奥运概念→';
if inblock('参股金融')=1 then var100:=var100+'参股金融概念→';
if inblock('成渝特区')=1 then var100:=var100+'成渝特区概念→';
if inblock('出口退税')=1 then var100:=var100+'出口退税概念→';
if inblock('次新股')=1 then var100:=var100+'次新股概念→';
if inblock('大订单')=1 then var100:=var100+'大订单概念→';
if inblock('大盘')=1 then var100:=var100+'大盘概念→';
if inblock('中盘')=1 then var100:=var100+'中盘概念→';
if inblock('小盘')=1 then var100:=var100+'小盘概念→';
if inblock('低价')=1 then var100:=var100+'低价概念→';
if inblock('低市净率')=1 then var100:=var100+'低市净率→';
if inblock('中价')=1 then var100:=var100+'中价概念→';
if inblock('定向增发')=1 then var100:=var100+'定向增发概念→';
if inblock('封闭基金')=1 then var100:=var100+'封闭基金概念→';
if inblock('高价')=1 then var100:=var100+'高价概念→';
if inblock('公募增发')=1 then var100:=var100+'公募增发概念→';
if inblock('股权改革')=1 then var100:=var100+'股权改革概念→';
if inblock('股权激励')=1 then var100:=var100+'股权激励概念→';
if inblock('股权投资')=1 then var100:=var100+'股权投资概念→';
if inblock('航天军工')=1 then var100:=var100+'航天军工概念→';
if inblock('沪深300')=1 then var100:=var100+'沪深300概念→';
if inblock('基金重仓')=1 then var100:=var100+'基金重仓→';
if inblock('节能环保')=1 then var100:=var100+'节能环保概念→';
if inblock('可转债')=1 then var100:=var100+'可转债概念→';
if inblock('农业龙头')=1 then var100:=var100+'农业龙头概念→';
if inblock('清欠')=1 then var100:=var100+'清欠概念→';
if inblock('权证')=1 then var100:=var100+'权证概念→';
if inblock('券商重仓')=1 then var100:=var100+'券商重仓概念→';
if inblock('社保重仓')=1 then var100:=var100+'社保重仓概念→';
if inblock('深成40')=1 then var100:=var100+'深成40概念→';
if inblock('数字电视')=1 then var100:=var100+'数字电视概念→';
if inblock('税收优惠')=1 then var100:=var100+'税收优惠概念→';
if inblock('送转')=1 then var100:=var100+'送转概念→';
if inblock('外资并购')=1 then var100:=var100+'外资并购概念→';
if inblock('网络游戏')=1 then var100:=var100+'网络游戏概念→';
if inblock('稀缺资源')=1 then var100:=var100+'稀缺资源概念→';
if inblock('预亏预减')=1 then var100:=var100+'预亏预减概念→';
if inblock('预盈预增')=1 then var100:=var100+'预盈预增概念→';
if inblock('整体上市')=1 then var100:=var100+'整体上市概念→';
if inblock('低市盈利')=1 then var100:=var100+'低市盈利概念→';
if inblock('新能源')=1 then var100:=var100+'新能源概念→';
if inblock('新材料')=1 then var100:=var100+'新材料概念→';
if inblock('新上海')=1 then var100:=var100+'新上海概念→';
if inblock('注资承诺')=1 then var100:=var100+'注资承诺概念→';
if inblock('中小板指')=1 then var100:=var100+'中小板指概念→';
end;
DRAWTEXTABS(10,160,var100),Color00FF00;
均线60角度:=atan((MA(C,60)/ref(MA(C,60),3)-1)*100)*180/3.14159;
均线125角度:=atan((MA(C,125)/ref(MA(C,125),3)-1)*100)*180/3.14159;
均线250角度:=atan((MA(C,250)/ref(MA(C,250),3)-1)*100)*180/3.14159;
DRAWTEXTABS(10,140,'■60天均线角度:'+NUMTOSTRN(均线60角度,2)+''),ColorFFFFFF;
DRAWTEXTABS(160,140,'■125天均线角度:'+NUMTOSTRN(均线125角度,2)+''),ColorFFFFFF;
DRAWTEXTABS(315,140,'■250天均线角度:'+NUMTOSTRN(均线250角度,2)+''),ColorFFFFFF;
DRAWTEXTABS(10,180,'■当前机构评级:'+EXTRASTRING('评级')),LINETHICK1,Color00FF00;
DRAWTEXTABS(10,200,'------------------------------------------------------------------------------------'),LINETHICK1,Color80BEFF;
{箱体空间}
NN:= DISPSTATUS=2;
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B1:=FILTER(A1,3);
C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,2*3+1);
B2:=FILTER(A2,3);
C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1=E2));
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H1,X2)>0,HHVBARS(IF(H1,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
UU:=BACKSET(BARSTATUS,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(BARSTATUS,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
前一低支撑:REF(L,BARSLAST(VV)),PRECIS2,COLOR99FF66,LINETHICK1,DOTLINE;
箱体下沿:REF(L,BARSLAST(XX)),ColorFFFF00,PRECIS2;
前一高压力:REF(H,BARSLAST(VV2)),PRECIS2,COLOR99FF66,LINETHICK1,DOTLINE;
箱体上沿:REF(H,BARSLAST(XX2)),PRECIS2,Color00FFFF;
DRAWTEXT(nn,前一低支撑,'前一低支撑: '+NUMTOSTRN(前一低支撑,2)+'元'),ALIGN2,Color00dd00,VALIGN0;
DRAWTEXT(nn,前一高压力,'前一高压力: '+NUMTOSTRN(前一高压力,2)+'元'),ALIGN2,Color00dd00,VALIGN2;
DRAWTEXT(nn,箱体下沿,'箱体下沿: '+NUMTOSTRN(箱体下沿,2)+'元'),ALIGN2,ColorFFFF00,LINETHICK1,VALIGN0;
DRAWTEXT(nn,箱体上沿,'箱体上沿: '+NUMTOSTRN(箱体上沿,2)+'元'),ALIGN2,Color00FFFF,LINETHICK1,VALIGN2;
DRAWTEXTREL(10,800,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));

更多大智慧股票公式知识请关注股票知识网

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top