最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 大智慧公式 > 大智慧乾坤K线解盘牛马线指标公式是什么?

大智慧乾坤K线解盘牛马线指标公式是什么?

来源:网络 点击: 时间:2019-02-23

  大智慧乾坤K线解盘牛马线指标公式是什么? ?www.igojr.com小编为您提供大智慧乾坤K线解盘牛马线指标公式相关讯息

{K线解盘}
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+

12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF

(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,19))/210,COLORRED;
马线:MA(牛线,6),COLORGREEN;
五日线:MA(CLOSE,5),COLORBLUE,CROSSDOT;
水平面:MA(CLOSE,60),COLORYELLOW,CROSSDOT;
TLDZH:=(IF((DATE <=1100630),1,0)) * (IF((CURRENTDATE <=1100630),1,0));
TAISHAN:=TLDZH;
IF TAISHAN THEN BEGIN

stickline(L>REF(H,1),L,REF(H,1),50,1001),colorred;
DRAWTEXT(L>REF(H,1),REF(H,1),NUMTOSTRN(REF(H,1),2)+'-'+NUMTOSTRN(L,2)),COLORred;
stickline(REF(L,1)>H,ref(L,1),H,50,1001),colorgreen;
DRAWTEXT(REF(L,1)>H,REF(L,1),NUMTOSTRN(ref(l,1),2)+'-'+NUMTOSTRN(h,2)),COLORgreen;PMA:=(o+H+L+c)/4;
天高云淡:=COUNT(ma(C,3)>ref(ma(C,3),1),3)>=3 and C<=ma(C,34) and C>O and C>ref(C,1);
蚂蚁撼树:=COUNT(ref(O,1)>REF(H,2) and ref(C,1)ref(C,2),2)>=2;
九天射日:=O>ref(H,1) and (h-max(o,c))/max(o,c)*100>3 and C>L;
弹剑长啸:=O>ref(H,1) and (h-max(o,c))/max(o,c)*100>3;
两阳夹一阴:=REF(C,2)>REF(O,2)*1.03{确定前天阳线实体大小} AND REF(C,1)O*1.023 AND C>REF(C,1)*0.99{确定今天阳线实体收盘价大于昨天阴线};
阳包阴:=ref(c,1)0.02{确定昨天阴线实体大小} and o<=ref(c,1) and c>ref(o,1){确定今天阳线将昨天阴线全部吞没};
包孕线:=ref(c,1)=0.03{确定昨天阴线实体大小} and l>ref(l,1) and c>o and h 黎明之星:=ref(c,2)=0.03{前天阴线实体大于-3%} and abs(ref(c,1)-ref(o,1))<( ref(o,2) -ref(c,2))/3 and (ref(h,1)<( ref(o,2) -ref(c,2))/3+ref(c,2)) and abs(ref(c,2)-ref(c,1))/ref(c,3)<=0.01{昨天跌幅小于1%的小阴或小阳,小阴的开盘价,小阳的收盘价要在前天的收盘价附近} and c>ref(c,1)*1.03 and c>( ref(o,2) -ref(c,2))/3*2+ref(c,2){今天涨幅大与3%,实体进入前天的阴线实体的三分之一以上};
早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
真实成交:=(BIGORDER(1,3)-BIGORDER(2,3))*AMOUNT/1000000+ BIGORDER(1,3)*AMOUNT/1000000+(BIGORDER(1,2)-BIGORDER(1,3))*AMOUNT/1000000+((BIGORDER(1,1)-BIGORDER(1,2))-(BIGORDER(2,1)-BIGORDER(2,2)))*AMOUNT/1000000+((1-BIGORDER(1,1))-(1-BIGORDER(2,1)))*AMOUNT/1000000-((BIGORDER(2,3)-BIGORDER(2,3))*AMOUNT/1000000+ BIGORDER(2,3)*AMOUNT/1000000+(BIGORDER(2,2)-BIGORDER(2,3))*AMOUNT/1000000+((BIGORDER(2,1)-BIGORDER(2,2))-(BIGORDER(2,1)-BIGORDER(2,2)))*AMOUNT/1000000+((1-BIGORDER(2,1))-(1-BIGORDER(2,1)))*AMOUNT/1000000);
KDJD:=SMA(SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1),3,1);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND
CLOSE/OPEN<0.97 AND CLOSE 长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE 射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSEREF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN 乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE 曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPENREF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1) 孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)OPEN;
出水芙蓉:=CLOSE>OPEN AND LOWMA(CLOSE,30) AND CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,40) AND CLOSE>MA(CLOSE,60) AND CLOSE>MA(CLOSE,5) AND C=HHV(C,20) AND REF(HHV(H,10),1)/REF(LLV(H,10),1)<1.05 AND (CLOSE-OPEN)>0.02*CLOSE;
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3) REF(LOW,4)REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4) REF(LOW,4)REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE 跳空缺口:=HIGHREF(HIGH,1);
三只乌鸦:=REF(CLOSE,2) 光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE 倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND OREF(O,1) AND C 三重底:=(hhv(c,3)-llv(c,3))/llv(c,3)<0.01;
跳空阴线后星:=ref(o>c,4) and ref(h0.07 and (o-c)/ref(c,1)>0.04{最大跌幅大于7%,实体大于4%}
,3) and ref(abs(o-c)1.8*abs(c-o) and h>=ref(l,1) and (h-l) ,2) and ref(abs(o-c)1.8*abs(c-o) and h>=ref(l,1) and (h-l) ,1) and l>ref(llv(l,2),1) and l 均线粘大阳破:=count(max(max(max(max(ma(c,5),ma(c,10)),ma(c,20)),ma(c,30)),ma(c,55))/min(min(min(min(ma(c,5),ma(c,10)),ma

(c,20)),ma(c,30)),ma(c,55))<1.05,3)>=1 and omax(max(max(max(ma(c,5),ma(c,10)),ma(c,20)),ma(c,30)),ma(c,55)) and c/o>1.03 and min(min(min(min(ma(c,5),ma(c,10)),ma(c,20)),ma(c,30)),ma(c,55))>ma(c,144) and ma(c,144)>ma(c,233) and v>max(max(ma(v,13),ma(v,34)),ma(v,55));
阴线巨量收复:=ref(cref(hhv(v,10),1)*2.5,1) and c>o and vref(h,1) or ref(cref(hhv(v,10),1)*2.5,2) and ref(c,1)o and vref(h,2) or ref(cref(hhv(v,10),1)*2.5,3) and ref(hhv(c,2),1)o and vref(h,2) or ref(cref(hhv(v,10),1)*2.5,4) and ref(hhv(c,3),1)o and vref(h,2);
DRAWFLAGTEXT(天高云淡>0,HIGH,'天高云淡--上升中途小压迫线:空头的压制力量有限,及早介入。'),COLORRED;
DRAWFLAGTEXT(蚂蚁撼树>0,HIGH,'蚂蚁撼树--上升中途伪阴线:股价一般将加速上行。可在第二根阴线处买入。'),COLORRED;
DRAWFLAGTEXT(阴线巨量收复,HIGH,'阴线巨量收复'),COLORCYAN;
DRAWFLAGTEXT(倾盆大雨,HIGH,'倾盆大雨,见顶信号'),COLORCYAN;
DRAWFLAGTEXT(跳空阴线后星,HIGH,'跳空阴线后星'),COLORRED;
DRAWFLAGTEXT(九天射日>0,HIGH,'九天射日--上升中途跳高弓形线:股价如不见顶,其后上攻速度将放慢.'),COLORRED;
DRAWFLAGTEXT(弹剑长啸>0,HIGH,'弹剑长啸--上升中途跳高剑形线:空头力量薄弱,第二天仍以高跳空开,股价会加速上扬。。'),COLORRED;
DRAWFLAGTEXT(均线粘大阳破,HIGH,'均线粘大阳破'),COLORRED;
DRAWFLAGTEXT(真实成交>0.1,HIGH,'真实成交-资金流入,结合趋势分析,重点关注!'),COLORRED;
DRAWFLAGTEXT(真实成交<-0.01,HIGH,'真实成交--资金流出,结合趋势分析!'),COLORBLUE;
DRAWFLAGTEXT(KDJD<25,HIGH,'KDJD值<25,底部形成注意!'),COLORRED;
DRAWFLAGTEXT(两阳夹一阴,HIGH,'两阳夹一阴'),COLORRED;
DRAWFLAGTEXT(阳包阴,HIGH,'阳包阴'),COLORRED;
DRAWFLAGTEXT(包孕线,HIGH,'包孕线'),COLORRED;
DRAWFLAGTEXT(黎明之星,HIGH,'黎明之星'),COLORRED;
DRAWFLAGTEXT(三重底,HIGH,'三重底,发生逆转'),COLORRED;
DRAWFLAGTEXT(大阴烛,HIGH,'大阴烛,后市向淡,发生逆转'),COLORCYAN;
DRAWFLAGTEXT(好友反攻,HIGH,'好友反攻,底部反转'),COLORRED;
DRAWFLAGTEXT(光脚阴线,HIGH,'光脚阴线,下跌信号'),COLORCYAN;
DRAWFLAGTEXT(跳空缺口,HIGH,'注意向上还是向下跳空'),COLORblue;
DRAWFLAGTEXT(光头阳线,HIGH,'光头阳线,后市看涨'),COLORRED;
DRAWFLAGTEXT(三只乌鸦,HIGH,'三只乌鸦,可能见顶回落'),COLORCYAN;
DRAWFLAGTEXT(分离,HIGH,'分离,注意看涨分离和看跌分离'),COLORblue;
DRAWFLAGTEXT(长下影,HIGH,'长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意'),COLORRED;
DRAWFLAGTEXT(长上影,HIGH,'长上影,表明行情上档压力沉重,升势受阻'),COLORCYAN;
DRAWFLAGTEXT(下跌三部曲,HIGH,'下跌三部曲,下跌信号'),COLORRED;
DRAWFLAGTEXT(上升三部曲,HIGH,'上升三部曲,上涨信号'),COLORCYAN;
DRAWFLAGTEXT(早晨之星,HIGH,'早晨之星,见底回升'),COLORRED;
DRAWFLAGTEXT(黄昏之星,HIGH,'黄昏之星,见顶回落'),COLORCYAN;
DRAWFLAGTEXT(十字星,HIGH,'十字星,有转向意味,注意股价位置在顶部还是底部'),COLORblue;
DRAWFLAGTEXT(长十字,HIGH,'长十字,注意在顶部还是底部'),COLORblue;
DRAWFLAGTEXT(垂死十字,HIGH,'垂死十字,下跌信号;'),COLORCYAN;
DRAWFLAGTEXT(早晨十字星,HIGH,'早晨十字星,上涨信号,见底回升'),COLORRED;
DRAWFLAGTEXT(黄昏十字星,HIGH,'黄昏十字星,下跌信号,见顶回落'),COLORCYAN;
DRAWFLAGTEXT(射击之星,HIGH,'射击之星,可能见顶回落,可靠性低'),COLORCYAN;
DRAWFLAGTEXT(倒转锤头,HIGH,'倒转锤头,可能见底回升'),COLORRED;
DRAWFLAGTEXT(锤头,HIGH,'锤头,可能见底回升,如有量配合,信号强烈'),COLORRED;
DRAWFLAGTEXT(吊颈,HIGH,'吊颈,上升行情中见顶回落,顶部出现,见顶信号'),COLORCYAN;
DRAWFLAGTEXT(平顶,HIGH,'平顶,温和的反转'),COLORCYAN;
DRAWFLAGTEXT(穿头破脚,HIGH,'穿头破脚,顶部出现,见顶回落信号'),COLORCYAN;
DRAWFLAGTEXT(乌云盖顶,HIGH,'乌云盖顶,见顶回落信号'),COLORCYAN;
DRAWFLAGTEXT(曙光初现,HIGH,'曙光初现,后市见底回升'),COLORRED;
DRAWFLAGTEXT(身怀六甲,HIGH,'身怀六甲,出现在底部,是见底回升;出现在顶部,是见顶回落'),COLORRED;
DRAWFLAGTEXT(十字胎,HIGH,'十字胎'),COLORRED;
DRAWFLAGTEXT(平底,HIGH,'平底,温和的反转'),COLORRED;
DRAWFLAGTEXT(大阳烛,HIGH,'大阳烛,,看涨'),COLORRED;
DRAWFLAGTEXT(三个白武士,HIGH,'三个白武士,每日收盘价上移,表示可能见底回升'),COLORRED;
DRAWFLAGTEXT(双飞乌鸦,HIGH,'双飞乌鸦,行情将见顶回落'),COLORCYAN;
DRAWFLAGTEXT(孕育线,HIGH,'孕育线,注意股价位置'),COLORblue;
DRAWFLAGTEXT(多方炮,HIGH,'多方炮,在底部出现上涨,中间上涨中继,顶部出现是复合见顶信号'),COLORRED;
DRAWFLAGTEXT(出水芙蓉>0,HIGH,'阳线穿过20、40、60日季均线,上攻势头初现!'),COLORRED;
END;

  想了解更多大智慧乾坤K线解盘牛马线指标公式相关资讯请关注www.igojr.com

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top