最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐进出顶底背离指标公式

飞狐进出顶底背离指标公式

来源:网络 点击: 时间:2019-03-31

DRAWGBK(1, COLORRGB(100,50,0), COLORRGB(100,100,0),0);
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,LINETHICK1,COLORRED;
RSI2:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100,LINETHICK2,COLORGREEN;
R1:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
VAR1:=4*SMA(R1,5,1)-3*SMA(SMA(R1,5,1),3.2,1),COLORYELLOW,LINETHICK1;
VAR2:=24,COLORGREEN,LINETHICK0;
IF(CROSS(VAR1,VAR2),10,0),STICK,COLORRED;
DRAWTEXT(CROSS(VAR1,VAR2),10,'加'), COLOReeFF00;
VAR3:= 4*SMA(R1,5,1)-3*SMA(SMA(R1,5,1),3,1);
STICKLINE(CROSS(80,VAR3),100,90,3,0),colorfff666;
DRAWTEXT(CROSS(80,VAR3),100,'减'), COLOReeFF00;
VAR4:= 4*SMA(R2,5,1)-3*SMA(SMA(R2,5,1),3,1);
STICKLINE(CROSS(72,VAR4),110,100,3,0),STICK,COLORRED;
DRAWTEXT(CROSS(72,VAR4),110,'出局'), COLOReeFF00;
VAR5:=4*SMA(R2,5,1)-3*SMA(SMA(R2,5,1),3.2,1),COLORYELLOW,LINETHICK1;
VAR6:=38,COLORGREEN,LINETHICK0;
IF(CROSS(VAR5,VAR6),15,0),STICK,COLORRED;
DRAWTEXT(CROSS(VAR5,VAR6),18,'进场'), COLOReeFF00;
AA:=REF(RSI1,3)=HHV(RSI1,2*3+1);
BB:=BACKSET(AA,3+1);
CC:=FILTER(BB,3) AND RSI1=HHV(RSI1,3+1);
A1:=BARSLAST(REF(CC,1));
顶背离:=REF(CLOSE,A1+1)RSI1 AND CC;
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORCYAN,LINETHICK2;
AA2:=REF(RSI1,3)=LLV(RSI1,2*3+1);
BB2:=BACKSET(AA2,3+1);
CC2:=FILTER(BB2,3) AND RSI1=LLV(RSI1,3+1);
AA2A:=BARSLAST(REF(CC2,1));
底背离:=REF(C,AA2A+1)>CLOSE AND REF(RSI1,AA2A+1) DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORMAGENTA,LINETHICK2;
DRAWTEXT(顶背离,RSI1*1.02,' -顶背'),COLORMAGENTA;
DRAWTEXT(底背离,RSI1*1.05,' -底背'),COLORMAGENTA;
AA00:=REF(RSI2,3)=HHV(RSI2,2*3+1);
BB00:=BACKSET(AA00,3+1);
CC00:=FILTER(BB00,3) AND RSI2=HHV(RSI2,3+1);
A11:=BARSLAST(REF(CC00,1));
顶背离:=REF(CLOSE,A11+1)RSI2 AND CC00;
DRAWLINE(CC00,RSI2,FILTER(顶背离>0,5),RSI2,0),COLORGREEN,LINETHICK2;
AA22:=REF(RSI2,3)=LLV(RSI2,2*3+1);
BB22:=BACKSET(AA22,3+1);
CC22:=FILTER(BB22,3) AND RSI2=LLV(RSI2,3+1);
AA22A:=BARSLAST(REF(CC22,1));
底背离:=REF(C,AA22A+1)>CLOSE AND REF(RSI2,AA22A+1) DRAWLINE(CC22,RSI2,FILTER(底背离>0,5),RSI2,0),COLORRED,LINETHICK2;
DRAWTEXT(顶背离,RSI2*1.02,' -顶背'),COLORMAGENTA;
DRAWTEXT(底背离,RSI2*1.05,' -底背'),COLORMAGENTA;
100,LINEDOT;
80,LINEDOT;
50,LINEDOT;
20,LINEDOT;
0,LINEDOT;

飞狐进出顶底背离指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top