最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐桂竹火焰指标公式

飞狐桂竹火焰指标公式

来源:网络 点击: 时间:2019-03-28

{DRAWGBK(CLOSE>0, COLORRGB(1,888,600), COLORRGB(33,33,0),3);}
X1:=hhv(h,5);
X2:=ref(hhv(h,5),1);
vertline(X1>=X2),pointdot,color808080;
VarAa:=LLV(LOW,30);
VarBb:=HHV(HIGH,30);
VarCc:=EMA((CLOSE-VarAa)/(VarBb-VarAa)*4,4)*25;
底背离: STICKLINE(VarCc<10 and 100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))>97,0,-5,5,2),COLORRED;
顶背离: STICKLINE(VarCc>90,100,105,10,2),COLORRED;
趋势: VarCc,Colorred,linethick1;
VarDd:=90;
VarEe:=(VarCc-LLV(VarCc,4))/(HHV(VarCc,4)-LLV(VarCc,4))*4*25;
目标位: DRAWTEXT(IF(CROSS(趋势,VarDd) AND VarEe=100,50,0),85,'目↑标'),ColorFF00FF,ALIGN0;
DRAWTEXT(IF(CROSS(趋势,VarEe) AND 趋势>87,95,0),88,'险'),Color00FF00,ALIGN1;
DRAWICON(CROSS(VarDd,趋势),95,10);
逢高出局:STICKLINE(filter(c/ref(c,1)>1.0918,21), 90,100, 3,0),color00ff00;
DRAWTEXT(filter(c/ref(c,1)>1.0918,21),80,'逢高↓出局'),Color00ff00,ALIGN1;
Var1:=EMA(HHV(HIGH,500),21);
Var2:=EMA(HHV(HIGH,250),21);
Var3:=EMA(HHV(HIGH,90),21);
Var4:=EMA(LLV(LOW,500),21);
Var5:=EMA(LLV(LOW,250),21);
Var6:=EMA(LLV(LOW,90),21);
Var7:=EMA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,21);
Var8:=EMA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,21);
Var9:=EMA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,21);
Var10:=IF(date>=1340722,0,1);
VarA:=EMA((Var7*3+Var8*2+Var9)/6*1.738,21);
VarB:=REF(LOW,1);
VarC:=SMA(ABS(LOW-VarB),3,1)/SMA(MAX(LOW-VarB,0),3,1)*100;
VarD:=EMA(IF(CLOSE*1.35<=VarA,VarC*10,VarC*var10/10),3);
VarE:=LLV(LOW,30)*var10;
VarF:=HHV(VarD,30);
Var11:=IF(MA(CLOSE,58),1,0);
火焰山:EMA(IF(LOW<=VarE,(VarD+VarF*2)/2,0),3)/618*Var11,COLOR00FF00,linethick2;
火焰:=STICKLINE(火焰山>0 ,0 ,火焰山 ,4 ,1);
今量:=火焰山*var10;
STICKLINE(火焰山>0,0 ,今量*1.2,8,0 ),COLOR00EEff;
STICKLINE(火焰山>0,0 ,今量*0.8,8,0 ),COLOR00BBff;
STICKLINE(火焰山>0,0 ,今量*0.6,8,0 ),COLOR0099ff;
STICKLINE(火焰山>0,0 ,今量*0.4,8,0 ),COLOR0066ff;
STICKLINE(火焰山>0,0 ,今量*0.2,8,0 ),COLOR0000ff;
var13:=if(year>=2005 and month>=11 and day>=1,0,1);
aa:=(ma(c,1)+ma(c,3)+ma(c,5)+ma(c,7)+ma(c,9))/5;
bb:=(ma(c,2)+ma(c,4)+ma(c,6)+ma(c,8)+ma(c,10))/5;
cc:=ema(aa,2);
dd:=ema(bb,5);
var14:=max(ema(aa,2)-ema(bb,5),0)*300;
var15:=ema(var14,5);
ss:=ema(var15,2);
风险:100,colorff00ff;
风险系数:(var15-ss)/10*var13,pointdot,colorffffff;
波浪系数:var15*var13,stick,colorff00ff;
stickline(var15>ref(var15,1) and var13,var15,0,1,0),colorff00ff;
stickline(var15>ref(var15,1) and var13,var15,ss,3.5,0),colorffffff;
stickline(var15 stickline(var15 升跌:=ema((c/ma((2*c+h+l)/4,8)-1)*100,3);
drawicon(升跌>=0 and var13,100,9);
drawicon(升跌<=0 and var13,100,10);
多情箭:cross(cc,dd) and var13,colorffff00;
drawicon(cross(cc,dd) and var13,0,4);
ee:=ref(c,1);
var16:=sma(max(c-ee,0),6,1)/sma(abs(c-ee),6,1)*100;
stickline(cross(84,var16) and var13,105,100,6,0),color00ff00;
drawicon(cross(84,var16) and var13,95,5);
ff:=sma(max(c-ee,0),5,1)/sma(abs(c-ee),5,1)*100;
stickline(cross(80,ff) and var13,105,100,6,0),color00ff00;
drawicon(cross(80,ff) and var13,95,5);
gg:=100*(1-winner(c))>99.8 and v/capital*100<5 and 100*(winner(1.1*c)-winner(0.9*c))<3.9;
火焰令:c>ref(c,1) and ref(gg,1)>0 and var13,color00ffff;
stickline(c>ref(c,1) and ref(gg,1)>0 and var13,0,-5,5,0),color00ffff;
drawicon(c>ref(c,1) and ref(gg,1)>0 and var13,-5,6);
drawtext(c>ref(c,1) and ref(gg,1)>0 and var13,-5,'★'),color00ffff;
H0:=SUM(IF((CLOSE > REF(CLOSE, 1)),VOL,IF((CLOSE < REF(CLOSE, 1)),(0 - VOL),0)),0);
H1:=SUMBARS(VOL,CAPITAL);
H2:=IF((CLOSE > LLV(CLOSE,H1)), 1,(0 - 1)) * IF((H0 > LLV(H0,H1)), 1,(0 -1));
H3:=(COUNT((IF((H2 = (0 - 1.000)), 1.000,0) = 1.000), 8.000) > 2.000);
H4:=((CLOSE - DMA(((( 3 * HIGH + LOW) + OPEN) + 2 * CLOSE) /7.000,VOL /SUM(AMOUNT,13) /AMOUNT /VOL /100 /100)) / DMA(((( 3* HIGH + LOW) + OPEN) + 2* CLOSE) /7,VOL / SUM(AMOUNT, 13) / AMOUNT / VOL /100 /100) * 100 < (0-18));
H5:=((CLOSE - MIN(REF(CLOSE, 5) * 0.865,REF(CLOSE, 21) * 0.772)) / CLOSE < 0.009);
H6:=((H3 and H4) and H5);
H7:=(((((OPEN < EMA(CLOSE, 5)) and (CLOSE = HIGH)) and (CLOSE / OPEN >= 1.105)) and (VOL / CAPITAL >=0.019)) and (VOL/CAPITAL <=0.200));
H8:=(H7 and (COUNT(H7, 5) = 1));
H9:=((((((((((((MA(CLOSE,3)> REF(MA(CLOSE,3),1)) and (MA(CLOSE,5) > REF(MA(CLOSE, 5),1))) and (MA(CLOSE, 10) > REF(MA(CLOSE, 10), 1))) and (VOL /240 > REF(VOL, 30) * 1.2 /240 * 1.5)) and (CLOSE > LOW *1.059)) and (CLOSE > REF(MA(CLOSE, 3), 1))) and REF(CLOSE, 1)) and (MA(CLOSE, 5) > REF(MA(CLOSE, 5),1))) and (MA(CLOSE, 10) > REF(MA(CLOSE, 10), 1))) and (MA(CLOSE, 20) > REF(MA(CLOSE, 20), 1))) and (MA(VOL, 5) > REF(MA(VOL, 5), 1))) and ((MA(CLOSE, 5) - MA(CLOSE,10))<= 0.579));
HH:=FILTER(H9, 5);
天地追杀:(H6 or H7) and HH,Color0000FF;
drawicon((H6 or H7) and HH,-5,8);

飞狐桂竹火焰指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top