最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐帝式OP自动测涨跌主图指标公式

飞狐帝式OP自动测涨跌主图指标公式

来源:网络 点击: 时间:2019-05-11

KG1:=20;F1:=10;P:=10;
D3X3:ma(c,3),SHIFT3,COLORMAGENTA;
KG:=IF(DATATYPE<=1,1,IF(DATATYPE<=3,5,IF(DATATYPE<=5,10,KG1)));
F:=IF(DATATYPE<=3,1,IF(DATATYPE=4,3,IF(DATATYPE=5,5,F1)));
ZX:=ZIG(4,KG);
CCH:=PEAK(4,KG,1);
CCY:=TROUGH(4,KG,1);
CC:IF(ZX W1:=CROSS(CCH-0.02,ZX);
W2:=CROSS(ZX,CCY+0.02);
FD:=F/100;
YS:=IF(ZX W:=IF(ZX H1:REF(CC*(1-YS*1),BARSLAST(W)),LINETHICK0;
H2:REF(CC*(1-YS*2),BARSLAST(W)),LINETHICK0;
H3:REF(CC*(1-YS*3),BARSLAST(W)),LINETHICK0;
H4:REF(CC*(1-YS*4),BARSLAST(W)),LINETHICK0;
H5:REF(CC*(1-YS*5),BARSLAST(W)),LINETHICK0;
H6:REF(CC*(1-YS*6),BARSLAST(W)),LINETHICK0;
H7:REF(CC*(1-YS*7),BARSLAST(W)),LINETHICK0;
H8:REF(CC*(1-YS*8),BARSLAST(W)),LINETHICK0;
H9:REF(CC*(1-YS*9),BARSLAST(W)),LINETHICK0;
H10:REF(CC*(1-YS*10),BARSLAST(W)),LINETHICK0;
H11:REF(CC*(1-YS*11),BARSLAST(W)),LINETHICK0;
H12:REF(CC*(1-YS*12),BARSLAST(W)),LINETHICK0;
H13:REF(CC*(1-YS*13),BARSLAST(W)),LINETHICK0;
H14:REF(CC*(1-YS*14),BARSLAST(W)),LINETHICK0;
H15:REF(CC*(1-YS*15),BARSLAST(W)),LINETHICK0;
HHD:=SYSPARAM(4);
LLD:=SYSPARAM(5);
系数:=IF(DATATYPE=2,1.00005,IF(DATATYPE<6,1.0005,1.002));
STICKLINE(CC>=LLD AND CC<=HHD,CC,CC*系数,20,0),colorFF;
STICKLINE(CC>=LLD AND CC<=HHD,H1,H1,5,0),colorA0A0A0;
STICKLINE(H1>LLD AND H1 STICKLINE(H2>LLD AND H2 STICKLINE(H3>LLD AND H3 STICKLINE(H4>LLD AND H4 STICKLINE(H5>LLD AND H5 STICKLINE(H6>LLD AND H6 STICKLINE(H7>LLD AND H7 STICKLINE(H8>LLD AND H8 STICKLINE(H9>LLD AND H9 STICKLINE(H10>LLD AND H10 STICKLINE(H11>LLD AND H11 STICKLINE(H12>LLD AND H12 STICKLINE(H13>LLD AND H13 STICKLINE(H14>LLD AND H14 DRAWTEXT(W AND CC>=LLD AND CC<=HHD,H1,''+NUMTOSTR(F*1,0)+'%'),PXDN5,colorA0A0A0;
DRAWTEXT(W AND H1>LLD AND H1 DRAWTEXT(W AND H2>LLD AND H2 DRAWTEXT(W AND H3>LLD AND H3 DRAWTEXT(W AND H4>LLD AND H4 DRAWTEXT(W AND H5>LLD AND H5 DRAWTEXT(W AND H6>LLD AND H6 DRAWTEXT(W AND H7>LLD AND H7 DRAWTEXT(W AND H8>LLD AND H8 DRAWTEXT(W AND H9>LLD AND H9 DRAWTEXT(W AND H10>LLD AND H10 DRAWTEXT(W AND H11>LLD AND H11 DRAWTEXT(W AND H12>LLD AND H12 DRAWTEXT(W AND H13>LLD AND H13 DRAWTEXT(W AND H14>LLD AND H14 AK1:=BARSLAST(W1)+1;
BK1:=BARSLAST(W2)+1;
目前:=IF(BK1>AK1,AK1,BK1);
{ Gupang.com 股-旁-网_飞狐股票指标公式}
DRAWNUMBER(W1,CC,REF(目前,1),0),ALIGN2,PXUP30,colorFF00FF;
DRAWNUMBER(W2,CC,REF(目前,1),0),ALIGN2,PXDN10,colorFF00;
方向:=IF(CC=CCH,'下行 ','上升 ');
周期:=IF(DATATYPE=6,'天 ',IF(DATATYPE=7,'周 ',IF(DATATYPE=8,'月 ','单位')));
DRAWTEXTEX(CLOSE>0,0,2,5,'目前波段'+方向+NUMTOSTR(目前,0)+周期);
DRAWTEXT(W1,CC,''+周期),PXUP30,colorFF00FF;
DRAWTEXT(W2,CC,''+周期),PXDN10,colorFF00;
{p:10,1,30}
X1:=TROUGH(4,P,1);
X8:=TROUGHBARS(4,P,1)=0;
X11:=TROUGHBARS(4,P,2);
X18:=TROUGHBARS(4,P,1);
X13:=TROUGHBARS(4,P,1);
X3:=PEAK(4,P,1);
X31:=PEAKBARS(4,P,2);
X38:=PEAKBARS(4,P,1);
X33:=PEAKBARS(4,P,1);
X5:=PEAKBARS(4,P,1)=0;
光标位置:=SYSPARAM(1);
CLDIS:=X13[SYSPARAM(1)];
CHDIS:=X33[SYSPARAM(1)];
TCL:=光标位置-CLDIS;
TCH:=光标位置-CHDIS;
BLDIS:=X18[SYSPARAM(1)];
BHDIS:=X38[SYSPARAM(1)];
TBL:=光标位置-BLDIS;
TBH:=光标位置-BHDIS;
ALDIS:=X11[SYSPARAM(1)];
AHDIS:=X31[SYSPARAM(1)];
TAL:=光标位置-ALDIS;
TAH:=光标位置-AHDIS;
K一浪A:=IF(TCL>TCH,TAL,TAH);
K二浪B:=IF(TCL>TCH,TBH,TBL);
K三浪C:=IF(TCL>TCH,TCL,TCH);
PH:=HIGH;
PL:=LOW;
P一浪A:IF(TCL>TCH,PL[TAL+0],PH[TAH+0]),LINETHICK0;
P二浪B:IF(TCL>TCH,PH[TBH+0],PL[TBL+0]),LINETHICK0;
P三浪C:IF(TCL>TCH,PL[TCL+0],PH[TCH+0]),LINETHICK0;
DRAWLINE(BARPOS=K一浪A,P一浪A,BARPOS=K二浪B,P二浪B,0),LINEDOT,color77FFFF;
DRAWLINE(BARPOS=K二浪B,P二浪B,BARPOS=K三浪C,P三浪C,0),LINEDOT,color77FFFF;
一浪长:=P二浪B-P一浪A;
Y1:=一浪长;
P1:=P三浪C+Y1;
VERTLINE(BARPOS=K三浪C),LINEDOT,colorFFFF;
DRAWTEXT(BARPOS=K三浪C,SYSPARAM(4)*0.95,'转\n \n\n折\n \n点'),colorFFFF;
Y0618:=一浪长*0.618;
P0618:=P三浪C+Y0618;
PARTLINE(BARPOS>K三浪C,P0618),colorCCFF;
DRAWTEXT(BARPOS=K三浪C,P0618,' '+NUMTOSTR(P0618,3)+' cop'),colorCCFF;
Y1000:=一浪长*1;
P1000:=P三浪C+Y1000;
PARTLINE(BARPOS>K三浪C,P1000),colorCCFF;
DRAWTEXT(BARPOS=K三浪C,P1000,' '+NUMTOSTR(P1000,3)+' op'),colorCCFF;
Y1618:=一浪长*1.618;
P1618:=P三浪C+Y1618;
PARTLINE(BARPOS>K三浪C,P1618),colorCCFF;
DRAWTEXT(BARPOS=K三浪C,P1618,' '+NUMTOSTR(P1618,3)+' xop'),colorCCFF;
DK:=MA(CLOSE,7);
STICKLINE(DK<=CLOSE AND CLOSE>=OPEN,HIGH,LOW,0.1,1),colorFF;
STICKLINE(DK<=CLOSE AND CLOSE>=OPEN,CLOSE,OPEN,8,1),colorFF;
STICKLINE(DK<=CLOSE AND CLOSE STICKLINE(DK<=CLOSE AND CLOSE STICKLINE(DK>CLOSE AND CLOSE>=OPEN,HIGH,LOW,0.1,1),colorFF00;
STICKLINE(DK>CLOSE AND CLOSE>=OPEN,CLOSE,OPEN,8,1),colorFF00;
STICKLINE(DK>CLOSE AND CLOSE STICKLINE(DK>CLOSE AND CLOSE 当前月:=FRACPART(ROUND(CURRENTDATE/100)/100)*100;
月:=MONTH;
日:=DAY;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='1',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(小寒)、6、15、20(大寒)、21、*25\n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='2',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:4(立春)、6、15、18(雨水)21\n \n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='3',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(惊蛰)、6、15、*20(春分)、21\n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='4',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:4(清明)、6、15、20(谷雨)21\n \n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='5',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(立夏)、6、*12、15、21(小满)\n \n \n \n \n'),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='6',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(芒种)、6、*14、21(夏至)\n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='7',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(小暑)、8、15、*19、23(大暑)\n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='8',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:*6、7(立秋)、8、18、23(处暑)\n \n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='9',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(白露)、8、15、*18、23(秋分)\n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='10',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:8(寒露)、15、23(霜降)、*31\n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='11',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(立冬)、8、15、22(小雪)23、*28\n \n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='12',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(大雪)、8、15、22(冬至)23、*31\n \n \n \n \n \n '),ALIGN5,colorFFFF;
DRAWTEXTEX(CLOSE,1,1,10,'板块:'+BLKNAME),colorFFFF;

飞狐帝式OP自动测涨跌主图指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top