最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐耐心等待指标公式

飞狐耐心等待指标公式

来源:网络 点击: 时间:2018-08-30

A1:=EMA(C,12)-EMA(C,25);
A2:=EMA(A1,6);
获利回吐:(A2>=0)*A2,COLORWHITE,LINETHICK;
空头回补:(A2<0)*A2,COLORD4FF7F,LINETHICK;
坚绝做空:(A1<0)*A1,COLORB00058,LINETHICK;
买入持股:(A1>=0)*A1,COLORRED,LINETHICK;
STICKLINE(A2>=0,A2,0,10,0),COLORWHITE;
STICKLINE(A2<0,A2,0,10,0),COLORD4FF7F;
STICKLINE(A1<0,A1,0,10,0),COLORB00058;
STICKLINE(A1>=0,A1,0,10,0),COLORRED;
VAR13:=IF(YEAR>=2018 AND MONTH>=11 AND DAY>=1,0,1);
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
VAR14:=MAX(EMA(AA,2)-EMA(BB,5),0)*1.2;
VAR15:=EMA(VAR14,5);
SS:=EMA(VAR15,2);
风险系数:=(VAR15-SS)/10*VAR13;
波浪系数:VAR15*VAR13,STICK,COLORFF00FF;
A10:=波浪系数,LINETHICK1 ;
B:MA(A10,3),COLORGREEN,LINETHICK1;
PARTLINE(B>REF(B,1) AND B>=0,B),COLORYELLOW,LINETHICK1;
{MACD1}
DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
UP:IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLORYELLOW,LINETHICK1;
PARTLINE(UP>REF(UP,1) AND UP>=0,UP),COLORGREEN,LINETHICK1;
PARTLINE(UP>REF(UP,1),UP),COLORFF00FF;
PARTLINE(UP0,UP),COLOR00FF00,LINETHICK2;
DN:IF(DIF DIF,COLORGREEN;
DEA,COLORGREEN;
零上金叉买:0,COLORYELLOW,LINETHICK1;
PARTLINE(DIF>REF(DIF,1) AND DIF>=0,DIF),COLORRED,LINETHICK1;
PARTLINE(DEA>REF(DEA,1) AND DEA>=0,DEA),COLORYELLOW,LINETHICK1;
DRAWICON(CROSS(DIF,DEA),DEA,4);
DRAWICON(CROSS(DEA,DIF),DEA,5);
PARTLINE(DIF>DEA,DIF),COLORRED,LINETHICK2;
PARTLINE(DEA>REF(DEA,1),DEA),COLORCYAN,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(MACD STICKLINE(MACD>REF(MACD,1)AND CROSS(J,K),0,MACD,1,0),COLORRED;
金叉:=CROSS(DIF,DEA) AND DIF<0.3;
STICKLINE(金叉,0.03,-0.03,4,0),COLORYELLOW;
DRAWTEXT(金叉,-0.03,'★金叉'),COLORYELLOW,LINETHICK2;
STICKLINE(金叉,0,0.03,2,0),COLORYELLOW;
DRAWICON(金叉,0.04,4);
STICKLINE(MACD0,0,MACD,2.6,0 ),COLOR00AAFF;
STICKLINE(MACD0,0,MACD,2,0 ),COLOR00BBFF;
STICKLINE(MACD0,0,MACD,1.6,0 ),COLOR00CCFF;
STICKLINE(MACD0,0,MACD,1.1,0 ),COLOR00DDFF;
STICKLINE(MACD0,0,MACD,0.6,0 ),COLOR00EEFF;
STICKLINE(MACD0,0,MACD,0.1,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.6,0 ),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0011BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.6,0 ),COLOR0022CC;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1,0 ),COLOR0033DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.6,0 ),COLOR0044EE;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.1 ,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.6,0 ),COLORAA00BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.6,0 ),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.6,0 ),COLOREE44BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.6,0 ),COLORFF7700;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFF8811;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.6,0 ),COLORFFAA22;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLORFFBB33;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.6,0 ),COLORFFDD44;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFFFF55;
DIFF:=EMA(CLOSE,11)-EMA(CLOSE,26);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1,COLORMAGENTA;
{www.gUPaNg.com _最新股票指标公式}
STICKLINE(低位金叉,0,0.08,4,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.2,' 低位金叉'),COLORWHITE;
VAR111111:=(HHV(H,13)-LLV(L,13));
VAR222222:=(HHV(H,13)-C);
VAR333333:=(C-LLV(L,13));
VAR444444:=VAR222222/VAR111111*100-70;
VAR555555:=(C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100;
VAR666666:=(2*C+H+L)/4;
VAR777777:=SMA((VAR333333/VAR111111*100),3,1);
VAR888888:=LLV(L,34);
VAR999999:=SMA(VAR777777,3,1)-SMA(VAR444444,9,1);
VAR1000000:=IF(VAR999999>100,VAR999999-100,0);
VARAAAAAA:=HHV(H,34);
防线:=EMA((VAR666666-VAR888888)/(VARAAAAAA-VAR888888)*100,8);
BB:=EMA(防线,5);
防:STICKLINE(防线>0 AND 防线-BB<0,0,0,10,0),COLORGREEN;
线:STICKLINE(防线>0 AND 防线-BB>=0,0,0,10,0),COLORRED;
DRAWTEXTEX(1,1,20,150,'严 格 执 行 纪 律'),COLORYELLOW;
DRAWTEXTEX(1,1,0,250,' 耐 心 等 待 '),COLORYELLOW;

飞狐耐心等待指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top