最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐资金进出指标公式

飞狐资金进出指标公式

来源:网络 点击: 时间:2019-02-22

input:n(5);
k1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
k2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
dt:=VOL*K1/(K1+K2);
kt:=VOL-DT;
买量:sum(dt,n),COLOR0000FF;
卖量:-sum(kt,n),COLORFFFF00;
FILLRGN(买量,0,买量), COLOR7800;
FILLRGN(卖量,0,卖量), COLOR5000;
进出量:买量+卖量,POINTDOT,COLOR00FFFF;
净量换手:100*进出量/CAPITAL,POINTDOT,COLOR00FF33;
STICKLINE(进出量>=0,0,进出量,6,1),COLOR0000FF;
STICKLINE(进出量<0,0,进出量,6,1),COLORFFFF00;
D5:=100*SUM(DT,5)/CAPITAL;
K5:=100*SUM(KT,5)/CAPITAL;
J5:=D5-K5;
D10:=100*SUM(DT,10)/CAPITAL;
K10:=100*SUM(KT,10)/CAPITAL;
J10:=D10-K10;
D20:=100*SUM(DT,20)/CAPITAL;
K20:=100*SUM(KT,20)/CAPITAL;
J20:=D20-K20;
yyzq:=sysparam(3)-sysparam(2);
FILL:=barscount(c)>SYSPARAM(2) and barscount(c)20,SYSPARAM(2)+INTPART(yyzq/2),20);
pich:=refx(hhv(买量,yyzq),yyzq);
picl:=refx(llv(卖量,yyzq),yyzq);
kg0:=' ';
kg:=' ';
kg1:=' ';
bgh:=refx(pich,yyzq)*0.89;
bgl:=refx(picl,yyzq)*0.89;
jg:=(bgh*0.89-bgl*0.89)/10;
fillrgn(fill,refx(pich,yyzq)*0.9,refx(picl,yyzq)*0.9),colorcc00cc;
fillrgn(ref(fill,1) and refx(fill,1),refx(pich,yyzq)*0.885,refx(picl,yyzq)*0.885),color333333;
BL5:=(bgh-bgl)/2*0.9/MAX(D5,K5);
BL10:=(bgh-bgl)/2*0.9/MAX(D10,K10);
BL20:=(bgh-bgl)/2*0.9/MAX(D20,K20);
D5B:=bgl+D5*BL5;
K5B:=bgl+K5*BL5;
J5B:=bgl+ABS(J5)*BL5;
D10B:=bgl+D10*BL10;
K10B:=bgl+K10*BL10;
J10B:=bgl+ABS(J10)*BL10;
D20B:=bgl+D20*BL20;
K20B:=bgl+K20*BL20;
J20B:=bgl+ABS(J20)*BL20;
zx:=if(sysparam(3)-sysparam(2)>40,yyzq/2,20)/20;
fillrgn(barpos>SYSPARAM(2)+2*zx and barpos fillrgn(barpos>SYSPARAM(2)+3*zx and barpos fillrgn(barpos>SYSPARAM(2)+4*zx and barpos fillrgn(barpos>SYSPARAM(2)+8*zx and barpos fillrgn(barpos>SYSPARAM(2)+9*zx and barpos fillrgn(barpos>SYSPARAM(2)+10*zx and barpos fillrgn(barpos>SYSPARAM(2)+14*zx and barpos fillrgn(barpos>SYSPARAM(2)+15*zx and barpos fillrgn(barpos>SYSPARAM(2)+16*zx and barpos DRAWTEXT(BARPOS=SYSPARAM(2),bgh-jg,kg1+'买量'), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-jg,kg1+kg+'卖量'), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-jg,kg1+kg+kg+'进出量'), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-2*jg,kg0+'今日'), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-2*jg,kg1+NUMTOSTR(100*refx(DT,yyzq)/CAPITAL,2)), color33ffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-2*jg,kg1+kg+NUMTOSTR(100*refx(KT,yyzq)/CAPITAL,2)), color33ffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-2*jg,kg1+kg+kg+NUMTOSTR(100*refx(DT,yyzq)/CAPITAL-100*refx(KT,yyzq)/CAPITAL,2)), color33ffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-3*jg,kg0+' 5日'),colorddffff;
{www.gUPang.com _最新股票指标公式}
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-3*jg,kg1+NUMTOSTR(refx(D5,yyzq),2)), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-3*jg,kg1+kg+NUMTOSTR(refx(K5,yyzq),2)), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-3*jg,kg1+kg+kg+NUMTOSTR(refx(J5,yyzq),2)), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-4*jg,kg0+'10日'), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-4*jg,kg1+NUMTOSTR(refx(D10,yyzq),2)), color33ffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-4*jg,kg1+kg+NUMTOSTR(refx(K10,yyzq),2)), color33ffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-4*jg,kg1+kg+kg+NUMTOSTR(refx(J10,yyzq),2)), color33ffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-5*jg,kg0+'20日'), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-5*jg,kg1+NUMTOSTR(refx(D20,yyzq),2)), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-5*jg,kg1+kg+NUMTOSTR(refx(K20,yyzq),2)), colorddffff;
DRAWTEXT(BARPOS=SYSPARAM(2),bgh-5*jg,kg1+kg+kg+NUMTOSTR(refx(J20,yyzq),2)), colorddffff;
DRAWTEXT(BARSSINCE(barpos>SYSPARAM(2)+zx)=1,bgl+(bgh*0.89-bgl*0.89)/4,' 5\n日'),align0,COLORwhite;
DRAWTEXT(BARSSINCE(barpos>SYSPARAM(2)+7*zx)=1,bgl+(bgh*0.89-bgl*0.89)/4,'10\n日'),align0,COLORwhite;
DRAWTEXT(BARSSINCE(barpos>SYSPARAM(2)+13*zx)=1,bgl+(bgh*0.89-bgl*0.89)/4,'20\n日'),align0,COLORwhite;

飞狐资金进出指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top