最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐动态涨跌振幅指标公式

飞狐动态涨跌振幅指标公式

来源:网络 点击: 时间:2018-08-24

INPUT:P1(5,1,100), P2(22,1,100), P3(63,1,100), P4(124,1,300), P5(183,1,300), P6(246,1,999);
p:=SYSPARAM(1);
n1:=if(p>p1,p1,if(p>1,p-1,0)); n2:=if(p>p2,p2,if(p>1,p-1,0));n3:=if(p>p3,p3,if(p>1,p-1,0));
n4:=if(p>p4,p4,if(p>1,p-1,0));n5:=if(p>p5,p5,if(p>1,p-1,0));n6:=if(p>p6,p6,if(p>1,p-1,0));
n10:=if(p>10,10,if(p>1,p-1,0));n15:=if(p>15,15,if(p>1,p-1,0));
XX:=IF(P=1,O,REF(CLOSE,1));
{动态振幅}
当日振幅:=(HIGH-LOW)/XX*100;
周振幅 :=(HHV(HIGH,P1)-LLV(LOW,P1))/LLV(LOW,P1)*100;
月振幅 :=(HHV(HIGH,P2)-LLV(LOW,P2))/LLV(LOW,P2)*100;
季振幅 :=(HHV(HIGH,P3)-LLV(LOW,P3))/LLV(LOW,P3)*100;
半年振幅:=(HHV(HIGH,P4)-LLV(LOW,P4))/LLV(LOW,P4)*100;
三季振幅:=(HHV(HIGH,P5)-LLV(LOW,P5))/LLV(LOW,P5)*100;
年振幅 :=(HHV(HIGH,P6)-LLV(LOW,P6))/LLV(LOW,P6)*100;
{-股票公式网站 www.GUpang.com}
DRAWTEXTEX(CLOSE,1,810,10, ' 动态振幅:'),COLORWHITE;
DRAWTEXTEX(CLOSE,1,780,60,'\n'+'-----------------\n'+
'当日振幅:'+NUMTOSTR(当日振幅[p],2)+'%\n'+
'周 振 幅:'+NUMTOSTR(周振幅[p],2)+'%\n'+
'月 振 幅:'+NUMTOSTR(月振幅[p],2)+'%\n'+
'季 振 幅:'+NUMTOSTR(季振幅[p],2)+'%\n'+
'半年振幅:'+NUMTOSTR(半年振幅[p],2)+'%\n'+
'三季振幅:'+NUMTOSTR(三季振幅[p],2)+'%\n'+
'年 振 幅:'+NUMTOSTR(年振幅[p],2)+'%\n'+
'-----------------'),COLORffffff;
{动态涨跌幅}
当日涨幅:=(CLOSE-xx)/xx*100;
周涨幅 :=(CLOSE-REF(CLOSE,N1))/REF(CLOSE,N1)*100;
十日涨幅:=(CLOSE-REF(CLOSE,N10))/REF(CLOSE,N10)*100;
十五涨幅:=(CLOSE-REF(CLOSE,N15))/REF(CLOSE,N15)*100;
月涨幅 :=(CLOSE-REF(CLOSE,N2))/REF(CLOSE,N2)*100;
季涨幅 :=(CLOSE-REF(CLOSE,N3))/REF(CLOSE,N3)*100;
半年涨幅:=(CLOSE-REF(CLOSE,N4))/REF(CLOSE,N4)*100;
三季涨幅:=(CLOSE-REF(CLOSE,N5))/REF(CLOSE,N5)*100;
年涨幅 :=(CLOSE-REF(CLOSE,N6))/REF(CLOSE,N6)*100;
DRAWTEXTEX(CLOSE,1,540,10, ' 动态涨跌幅:'),COLORWHITE;
DRAWTEXTEX(CLOSE,1,520,60,'\n'+'-----------------\n'+
'当日涨幅:'+NUMTOSTR(当日涨幅[p],2)+'%\n'+
'周 涨 幅:'+NUMTOSTR(周涨幅[p],2)+'%\n'+
'十日涨幅:'+NUMTOSTR(十日涨幅[p],2)+'%\n'+
'十五涨幅:'+NUMTOSTR(十五涨幅[p],2)+'%\n'+
'月 涨 幅:'+NUMTOSTR(月涨幅[p],2)+'%\n'+
'季 涨 幅:'+NUMTOSTR(季涨幅[p],2)+'%\n'+
'半年涨幅:'+NUMTOSTR(半年涨幅[p],2)+'%\n'+
'三季涨幅:'+NUMTOSTR(三季涨幅[p],2)+'%\n'+
'年 涨 幅:'+NUMTOSTR(年涨幅[p],2)+'%\n'+
'-----------------'),COLORffffff;

飞狐动态涨跌振幅指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top