最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐精品趋势主图指标公式

飞狐精品趋势主图指标公式

来源:网络 点击: 时间:2019-03-23

input:W(13,3,34),N(12,5,60),M(8,5,60),n2(3,0,20),m2(20,0,100),P1(28,20,32),P2(32,32,35),P3(35,35,38);
精品:=EMA(EMA(EMA(CLOSE,2),2),2);
精品1:6*HHV(精品,2)-5*精品,COLORWHITE,linethick1;
分离1:2*精品-精品1,COLORMAGENTA,linethick1;
精品2:(MA(精品,W) * 0.999),COLORWHITE,linethick3;
分离2:6*HHV(精品2,3)-5*精品2,COLORRED,linethick3;
{逃顶抄底}
Var1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=SMA(Var3,3,1);
RSV:=(c-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K:=SMA(RSV,3,1),colorwhite;
D:=SMA(K,3,1),coloryellow;
J:=3*K-2*D,colorff00ff;
bb:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
b1:=SMA(bb,24,1),colorwhite;
b2:=SMA(b1,12,1),coloryellow;
b3:=3*b1-2*b2,colorff00ff;
x:=b1-b2;
x1:=ref(x,1);
c1:=(cross(x1,x) and b1>b2 and c>ma(c,20) and b3>70) and (cross(d,k) and k>80);
c2:=(cross(x1,x) and b1>b2 and c>ma(c,20) and b3>70) and (CROSS(Var4,Var3) AND Var3>80);
c3:=(CROSS(Var4,Var3) AND Var3>80) and (cross(d,k) and k>80);
c4:=c1 and c2 and c3;
DRAWICON(c1 or c2 or c3,high*1.08,2);
DRAWTEXT(c1,h*1.06,'清'),COLORCYAN;
DRAWTEXT(c1,h*1.04,'仓'),COLORCYAN;
DRAWTEXT(c1,h*1.02,'1'),COLORCYAN;
DRAWTEXT(c2,h*1.06,'清'),COLORCYAN;
DRAWTEXT(c2,h*1.04,'仓'),COLORCYAN;
DRAWTEXT(c2,h*1.02,'2'),COLORCYAN;
DRAWTEXT(c3,h*1.06,'清'),COLORCYAN;
DRAWTEXT(c3,h*1.04,'仓'),COLORCYAN;
DRAWTEXT(c3,h*1.02,'3'),COLORCYAN;
DRAWTEXT(c4,h*1.06,'清'),COLORCYAN;
DRAWTEXT(c4,h*1.04,'仓'),COLORCYAN;
DRAWTEXT(c4,h*1.02,'4'),COLORCYAN;
{买卖指示}
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,70))/(0.015*AVEDEV(VAR5,70));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
预警系统:= IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+60;
DRAWTEXT(ref(预警系统=70,1) and 预警系统=60,h*1.08,'●'),COLORCYAN;
DRAWTEXT(ref(预警系统=70,1) and 预警系统=60,h*1.06,'出'),COLORCYAN;
DRAWTEXT(ref(预警系统=70,1) and 预警系统=60,h*1.04,'货'),COLORCYAN;
DRAWTEXT(ref(预警系统=70,1) and 预警系统=60,h*1.02,'1'),COLORCYAN;
{难得高手}
上:=(SMA(HIGH,21,2) * 1.05);
下轨道:=(SMA(LOW,21,2) * 0.969),POINTDOT,colorFFFF;
BMA:=MA(CLOSE,118);
阻挡:=(SMA(HIGH,21,2) * 1.05);
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV12:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=((3 * K12) - (2 * D12));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
压力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),colorFF00;
U2L:=IF((CLOSE >= MA(CLOSE,20)),80,50);
L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
RH1:=IF(((J < U2L) AND (REF(J,1) >= U2L)),HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),BARSLAST(((J < U2L) AND REF(J,1)))));
RH4:=IF((HIGH > RH1),LOW,REF(LOW,BARSLAST((HIGH > RH1))));
RH42:=IF((HIGH > RH1),J,REF(J,BARSLAST((HIGH > RH1))));
RH5:=IF((((HIGH > RH4) AND (J < RH42)) AND (J < J24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH4) AND (J < RH42)) AND (J < J24)))));
RL1:=IF(((J > L2L) AND (REF(J,1) <= L2L)),LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),BARSLAST(((J > L2L) AND REF(J,1)))));
RL4:=IF((LOW < RL1),HIGH,REF(HIGH,BARSLAST((LOW < RL1))));
RL42:=IF((LOW < RL1),J,REF(J,BARSLAST((LOW < RL1))));
RL5:=IF((((LOW < RL4) AND (J > RL42)) AND (J > J24)),LOW,REF(LOW,BARSLAST((((LOW < RL4) AND (J > RL42)) AND (J > J24)))));
CB:=((AMOUNT / VOL) / 100);
CD:=((CB > HIGH) OR (CB < LOW));
黑马趋势:=MA(CLOSE,3);
MAP:=MA(CLOSE,8);
AA5:=MA(CLOSE,21);
AA10:=MA(CLOSE,8),colorFF;
AA12:=MA(CLOSE,12),colorFF;
BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
DRAWTEXT(FILTER(((((((CLOSE / OPEN) > 1.04) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (CLOSE > 下轨道)) AND ((AA10 - REF(AA10,1)) > 0)) AND (CLOSE < 上)),3),(LOW - 0.07),'追'),colorD1E768;
DRAWTEXT(FILTER(((((((CLOSE / OPEN) > 1.04) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (CLOSE > 下轨道)) AND ((AA10 - REF(AA10,1)) > 0)) AND (CLOSE < 上)),3),(LOW - 0.09),'击'),colorD1E768;
VARD:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);
支撑:=EMA(VARD,5);
短期底部:=LLV(OPEN,30);
DRAWTEXT(((((((CROSS(黑马趋势,短期底部) AND ((RL5 - REF(RL5,1)) > 0)) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (黑马趋势 > 1)) AND (LOW <= 支撑位)) AND (CLOSE > 支撑位)) AND (HIGH < 压力位)),(LOW - 0.15),'黑'),colorFFFF;
DRAWTEXT(((((((CROSS(黑马趋势,短期底部) AND ((RL5 - REF(RL5,1)) > 0)) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (黑马趋势 > 1)) AND (LOW <= 支撑位)) AND (CLOSE > 支撑位)) AND (HIGH < 压力位)),(LOW - 0.3),'马'),colorFFFF;
DRAWTEXT(((((((CROSS(黑马趋势,短期底部) AND ((RL5 - REF(RL5,1)) > 0)) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (黑马趋势 > 1)) AND (LOW <= 支撑位)) AND (CLOSE > 支撑位)) AND (HIGH < 压力位)),(LOW - 0.45),'发'),colorFFFF;
DRAWTEXT(((((((CROSS(黑马趋势,短期底部) AND ((RL5 - REF(RL5,1)) > 0)) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (黑马趋势 > 1)) AND (LOW <= 支撑位)) AND (CLOSE > 支撑位)) AND (HIGH < 压力位)),(LOW - 0.6),'现'),colorFFFF;
X1:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
X2:=EMA(X1,10);
X3:=REF(X2,1);
X4:=((REF(HIGH,1) + REF(LOW,1)) / 2);
X5:=(MA(CLOSE,21) + (2 * STD(CLOSE,21)));
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
MAP1:=MA(CLOSE,60);
均线30:=MA(CLOSE,30);
均线89:=MA(CLOSE,89);
均线:=MA(CLOSE,16);
均线34:=MA(CLOSE,34);
均线55:=MA(CLOSE,55);
VAr1:=EMA(CLOSE,8);
VAR2:=EMA(VAr1,20);
VAR3:=CROSS(VAr1,VAR2);
VAR4:=(VAr1 < MA(CLOSE,60));
VAR5:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
VAR6:=SMA(VAR5,5,1);
VAR7:=SMA(VAR6,8,1);
VAR8:=(CROSS(VAR6,VAR7) AND (VAR7 < 16));
VAR9:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND VAR8);
VARA:=IF((CLOSE > 1000),VAR8,VAR9);
黑马起步:=(VAR3 AND VAR4);
逃遁:=VARA;
均线20:=MA(CLOSE,20);
均线120:=MA(CLOSE,120);
牛熊线:=MA(CLOSE,250);
VA:=CROSS(MA(CLOSE,19),MA(CLOSE,120));
VB:=(MA(CLOSE,20) > MA(CLOSE,120));
VC:=CROSS(MA(CLOSE,120),MA(CLOSE,89));
VD:=(MA(CLOSE,20) < MA(CLOSE,120));
VE:=CROSS(MA(CLOSE,20),MA(CLOSE,250));
VF:=(MA(CLOSE,20) > MA(CLOSE,250));
VG:=CROSS(MA(CLOSE,250),MA(CLOSE,20));
DRAWTEXT(FILTER(((((((((OPEN > 均线120) AND (均线20 < 均线120)) AND (LOW <= 均线120)) AND ((均线20 - REF(均线20,1)) > 0)) AND (CLOSE > OPEN)) AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= 均线120)),15),LOW*0.99,'★'),color89E0;
DRAWTEXT(FILTER(((((((((OPEN > 均线120) AND (均线20 < 均线120)) AND (LOW <= 均线120)) AND ((均线20 - REF(均线20,1)) > 0)) AND (CLOSE > OPEN)) AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= 均线120)),15),LOW*0.97,'120'),color89E0;
DRAWTEXT(FILTER(((((((((OPEN > 均线120) AND (均线20 < 均线120)) AND (LOW <= 均线120)) AND ((均线20 - REF(均线20,1)) > 0)) AND (CLOSE > OPEN)) AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= 均线120)),15),LOW*0.95,'跳'),color89E0;
DRAWTEXT(FILTER(((((((((OPEN > 均线120) AND (均线20 < 均线120)) AND (LOW <= 均线120)) AND ((均线20 - REF(均线20,1)) > 0)) AND (CLOSE > OPEN)) AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= 均线120)),15),LOW*0.93,'马'),color89E0;
DRAWTEXT((((VA AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE > OPEN)),LOW*0.99,'★'),colorFFFFFF;
DRAWTEXT((((VA AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE > OPEN)),LOW*0.97,'宝'),colorFFFFFF;
DRAWTEXT((((VA AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE > OPEN)),LOW*0.95,'马'),colorFFFFFF;
DRAWTEXT((((VA AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE > OPEN)),LOW*0.93,'望'),colorFFFFFF;
DRAWTEXT((((VA AND ((均线120 - REF(均线120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE > OPEN)),LOW*0.91,'月'),colorFFFFFF;
DRAWTEXT((((((均线 - REF(均线,1)) > 0) AND CROSS(均线20,均线120)) AND (LOW <= 均线120)) AND (CLOSE >= 均线120)),LOW*0.99,'三'),colorFFFFFF;
DRAWTEXT((((((均线 - REF(均线,1)) > 0) AND CROSS(均线20,均线120)) AND (LOW <= 均线120)) AND (CLOSE >= 均线120)),LOW*0.97,'线'),colorFFFFFF;
DRAWTEXT((((((均线 - REF(均线,1)) > 0) AND CROSS(均线20,均线120)) AND (LOW <= 均线120)) AND (CLOSE >= 均线120)),LOW*0.95,'开'),colorFFFFFF;
DRAWTEXT((((((均线 - REF(均线,1)) > 0) AND CROSS(均线20,均线120)) AND (LOW <= 均线120)) AND (CLOSE >= 均线120)),LOW*0.93,'花'),colorFFFFFF;
短期底部2:=LLV(HIGH,30),LINETHICK2,colorFF;
上轨:=(SMA(HIGH,21,2) * 1.092),POINTDOT,colorFFFFFF;
中轨道:=(SMA(HIGH,21,2) * 1.017),POINTDOT,colorFFFFFF;
DRAWTEXT(FILTER(((((LOW < 下轨道) AND (CLOSE > MA(CLOSE,15))) AND (CLOSE > 短期底部2)) AND (HIGH < 压力位)),10),LOW*0.99,'★'),color9DC522;
DRAWTEXT(FILTER(((((LOW < 下轨道) AND (CLOSE > MA(CLOSE,15))) AND (CLOSE > 短期底部2)) AND (HIGH < 压力位)),10),LOW*0.97,'短'),color9DC522;
DRAWTEXT(FILTER(((((LOW < 下轨道) AND (CLOSE > MA(CLOSE,15))) AND (CLOSE > 短期底部2)) AND (HIGH < 压力位)),10),LOW*0.95,'线'),color9DC522;
DRAWTEXT(FILTER(((((LOW < 下轨道) AND (CLOSE > MA(CLOSE,15))) AND (CLOSE > 短期底部2)) AND (HIGH < 压力位)),10),LOW*0.93,'5%'),color9DC522;
DRAWTEXT(FILTER(((HIGH > 阻挡) AND (CLOSE < 阻挡)),5),(HIGH *1.08),'▼'),color9DC522;
DRAWTEXT(FILTER(((HIGH > 阻挡) AND (CLOSE < 阻挡)),5),(HIGH *1.06),'逃'),color9DC522;
DRAWTEXT(FILTER(((HIGH > 阻挡) AND (CLOSE < 阻挡)),5),(HIGH *1.04),'命'),color9DC522;
DRAWTEXT(FILTER(((HIGH > 阻挡) AND (CLOSE < 阻挡)),5),(HIGH *1.02),'1'),color9DC522;
DRAWTEXT(((VE > VG) AND (HIGH < 阻挡)),(LOW - 0.65),'★黑马短线'),colorFFFF;
DRAWTEXT(FILTER(((((((((((OPEN < X2) AND (CLOSE > X2)) AND ((支撑 - REF(支撑,1)) > 0)) AND ((支撑 - REF(支撑,1)) > 0)) AND (CLOSE < 阻挡)) AND ((均线 - REF(均线,1)) > 0)) AND (CLOSE >= 均线)) AND (HIGH < 阻挡)) AND ((AA10 - REF(AA10,1)) > 0)) AND ((阻挡 - REF(阻挡,2)) > 0)),11),(LOW - 0.11),'★快马加鞭'),colorFF;
DRAWTEXT(X9,(HIGH * 1.08),'●'),coloryellow;
DRAWTEXT(X9,(HIGH * 1.06),'出'),coloryellow;
DRAWTEXT(X9,(HIGH * 1.04),'货'),coloryellow;
DRAWTEXT(X9,(HIGH * 1.02),'2'),coloryellow;
DRAWTEXT((((黑马起步 > 0) AND (LOW <= X2)) AND ((均线 - REF(均线,1)) > 0)),(LOW - 0.11),'★黑马起步'),colorFF00;
DRAWTEXT((逃遁 > 0),(HIGH * 1.08),'▼'),coloryellow;
DRAWTEXT((逃遁 > 0),(HIGH * 1.06),'逃'),coloryellow;
DRAWTEXT((逃遁 > 0),(HIGH * 1.04),'命'),coloryellow;
DRAWTEXT((逃遁 > 0),(HIGH * 1.02),'2'),coloryellow;
RDV:=SMA(LOW,8,1);
DRAWTEXT(((((CROSS(K,D) AND (CLOSE >= OPEN)) AND ((X2 - REF(X2,1)) > 0)) AND ((RDV - REF(RDV,1)) > 0)) AND (K <= 33)),(LOW - 0.08),'★黑马初现'),color8500DE;
RCK:=(SMA(LOW,21,2) * 0.95);
趋势线:=SMA(LOW,5,1);
DRAWTEXT(((CROSS(趋势线,RCK) AND (LOW <= X2)) AND ((X2 - REF(X2,1)) > 0)),LOW*0.99,'★'),coloryellow;
DRAWTEXT(((CROSS(趋势线,RCK) AND (LOW <= X2)) AND ((X2 - REF(X2,1)) > 0)),LOW*0.97,'大'),coloryellow;
DRAWTEXT(((CROSS(趋势线,RCK) AND (LOW <= X2)) AND ((X2 - REF(X2,1)) > 0)),LOW*0.95,'胆'),coloryellow;
DRAWTEXT(((CROSS(趋势线,RCK) AND (LOW <= X2)) AND ((X2 - REF(X2,1)) > 0)),LOW*0.93,'买'),coloryellow;
DRAWTEXT(((CROSS(趋势线,RCK) AND (LOW <= X2)) AND ((X2 - REF(X2,1)) > 0)),LOW*0.91,'入'),coloryellow;
B1:=(((HIGH + LOW) + CLOSE) / 3);
B6:=HHV(B1,(4 * 15));
B7:=LLV(B1,(4 * 15));
B8:=(B6 - B7);
飞龙顶底线:=(MA(((B1 - B7) / B8),2) * 80);
DRAWTEXT((((((OPEN <= 均线) AND ((均线30 - REF(均线30,1)) > 0)) AND (CLOSE > 均线89)) AND (BB10 > 1)) AND ((CLOSE / OPEN) > 1.04)),LOW*0.99,'★'),colorCC99FF;
DRAWTEXT((((((OPEN <= 均线) AND ((均线30 - REF(均线30,1)) > 0)) AND (CLOSE > 均线89)) AND (BB10 > 1)) AND ((CLOSE / OPEN) > 1.04)),LOW*0.97,'天'),colorCC99FF;
DRAWTEXT((((((OPEN <= 均线) AND ((均线30 - REF(均线30,1)) > 0)) AND (CLOSE > 均线89)) AND (BB10 > 1)) AND ((CLOSE / OPEN) > 1.04)),LOW*0.95,'马'),colorCC99FF;
DRAWTEXT((((((OPEN <= 均线) AND ((均线30 - REF(均线30,1)) > 0)) AND (CLOSE > 均线89)) AND (BB10 > 1)) AND ((CLOSE / OPEN) > 1.04)),LOW*0.93,'过'),colorCC99FF;
DRAWTEXT((((((OPEN <= 均线) AND ((均线30 - REF(均线30,1)) > 0)) AND (CLOSE > 均线89)) AND (BB10 > 1)) AND ((CLOSE / OPEN) > 1.04)),LOW*0.91,'桥'),colorCC99FF;
{买卖主图}
VAR1:=IF(DATE<1500830 AND DATE>900101,1,0);
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
K1:=(P1/10)*VAR1*100;
K2:=(P2/10)*VAR1*100;
K3:=(P3/10)*VAR1*100;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1),COLORFFFFFF;
D:=SMA(K,3,1),COLOR00FFFF;
J:=3*K-2*D,COLORFF00FF;
X:=LLV(J,2)=LLV(J,8);
主力:=EMA( (CLOSE-MA(CLOSE,n2))/MA(CLOSE,n2)*4800,2);
散户:=EMA( (CLOSE-MA(CLOSE,m2))/MA(CLOSE,m2)*4800,7);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1,COLORA0A0FF;
{DRAWTEXT(CROSS(动能趋势线,K1),HIGH*1.02,'风险'),COLORGREEN;}
{DRAWTEXT(CROSS(动能趋势线,K2),HIGH*1.02,'减仓3'),COLOR00FF00;}
DRAWTEXT(CROSS(动能趋势线,K3),HIGH*1.08,'★'),COLORWHITE;
DRAWTEXT(CROSS(动能趋势线,K3),HIGH*1.06,'出'),COLORWHITE;
DRAWTEXT(CROSS(动能趋势线,K3),HIGH*1.04,'局'),COLORWHITE;
DRAWTEXT(CROSS(动能趋势线,K3),HIGH*1.02,'35'),COLORWHITE;
{DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'短进'),COLORFF00FF;}
DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'见底'),COLORRED;
DRAWICON(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,1);
{主图BS}
VAR1:=EMA(C,3);
MA12:=EMA(SLOPE(L,27)*25+L,54);
XG:=CROSS(VAR1,MA12);
XG1:=CROSS(MA12,VAR1);
{-股票公式网站 www.GUpang.com}
DRAWICON(XG,LOW*0.98,1),COLORYELLOW;
DRAWTEXT(XG,LOW *0.94,'进'),COLORYELLOW;
DRAWTEXT(XG,LOW *0.92,'攻'),COLORYELLOW;
{DRAWICON(XG1,HIGH*1.01,2),COLORFFFF00;}
DRAWTEXT(XG1,HIGH *1.06,'▼'),COLORWHITE;
DRAWTEXT(XG1,HIGH *1.04,'撤'),COLORWHITE;
DRAWTEXT(XG1,HIGH *1.02,'退'),COLORWHITE;
{霸占}
M5:=EMA(C,34),COLORFFAA66,LINETHICK2;
M6:=EMA(C,55),COLORBLUE,LINETHICK3;
M7:=MA(C,75),COLOR00FFFF,LINETHICK1;
M8:=EMA(M7,3),COLOR00FFFF,LINETHICK1;
M9:=EMA(M8,3),COLOR00FFFF,LINETHICK1;
M11:=EMA(M9,3),COLOR00FFFF,LINETHICK1;
MA47:=EMA(CLOSE,44),COLORFFAA66,LINETHICK2;
MA60:=EMA(CLOSE,60),COLORBLUE,LINETHICK3;
Y:=(H+L)/5;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3 JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0 JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1) JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1) DRAWTEXT(JDU2,M9*0.90,'【锁定】'),COLORYELLOW;
DRAWTEXT(CROSS(M6,M9),M9*0.98,'【霸占】'),COLOR0000FF;
{北斗星 QSWW}
D1:=MA(CLOSE,4);
操作线:=MA(CLOSE,4),LINETHICK2,colorFFFF;
大底:=LLV(D1,55);
VAR11:=大底=REF(大底,1);
波段金股:=VAR11 AND CROSS(CLOSE,大底);
DRAWTEXT(波段金股,L*0.98,'波段金股'),COLOR0000FF;

飞狐精品趋势主图指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top