最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐自动百分箱体主图指标公式

飞狐自动百分箱体主图指标公式

来源:网络 点击: 时间:2018-08-28

input:k(1,1,3,1);
hh:= SYSPARAM(4);
ll:= SYSPARAM(5);
HL:=hh-ll;
wH := BARSlast(H=hh);
wL :=BARSlast(L=ll);
KK := wH-wL;
a1 :=if(kk<0,hh- HL*0.25,ll+HL*0.25);
a2 :=if(kk<0,hh- HL*0.75,ll+HL*0.75);
a3 :=if(kk<0,hh- HL*0.3125,ll+HL*0.3125);
mHL:= hh-HL*0.5;b1:=if(kk<0,hh- HL*0.125,ll+HL*0.125);b2:=if(kk<0,hh- HL*0.0625,ll+HL*0.0625);b3:=if(kk<0,hh- HL*0.375,ll+HL*0.375);b4:=if(kk<0,hh- HL*0.625,ll+HL*0.625);
b5:=if(kk<0,hh- HL*0.1875,ll+HL*0.1875);b6:=if(kk<0,hh- HL*0.875,ll+HL*0.875);b7:=if(kk<0,hh- HL*0.4375,ll+HL*0.4375);b8:=if(kk<0,hh- HL*0.5625,ll+HL*0.5625);
b9:=if(kk<0,hh- HL*0.6875,ll+HL*0.6875);b10:=if(kk<0,hh- HL*0.9375,ll+HL*0.9375);b11:=if(kk<0,hh- HL*0.8125,ll+HL*0.8125);A := islastbar;
DRAWTEXT(A and K<>3,HH, ' 最高价:'+NUMTOSTR(HH,2)),ALIGN2,colorred;DRAWTEXT(A and K<>3,LL, ' 最低价:'+NUMTOSTR(ll,2)),ALIGN2,,COLORCYAN;
{-股票公式网站 www.igojr.com}
DRAWTEXT(A and K<>3,mHL,' 50%:'+NUMTOSTR(mHL,2)),ALIGN2,coloryellow;DRAWTEXT(A and K=1, a1, ' 25%:'+NUMTOSTR(a1,2)),ALIGN2,coloryellow;
DRAWTEXT(A and K=1, a2, ' 75%:'+NUMTOSTR(a2,2)),ALIGN2,colorgreen;DRAWTEXT(A and K=1, a3, ' 31.25%:'+NUMTOSTR(a3,3)),ALIGN2,COLORGRAY;
DRAWTEXT(A and K=1, b1, ' 12.5%:'+NUMTOSTR(b1,2)),ALIGN2,COLORGRAY;DRAWTEXT(A and K=1, b2, ' 6.25%:'+NUMTOSTR(b2,2)),ALIGN0,COLORGRAY;
DRAWTEXT(A and K=1, b3, ' 37.5%:'+NUMTOSTR(b3,2)),ALIGN2,COLORGRAY;DRAWTEXT(A and K=1, b4, ' 62.5%:'+NUMTOSTR(b4,2)),ALIGN2,COLORGRAY;
DRAWTEXT(A and K=1, b5, ' 18.75%:'+NUMTOSTR(b5,3)),ALIGN2,COLORGRAY;DRAWTEXT(A and K=1, b6, ' 87.5%:'+NUMTOSTR(b6,2)),ALIGN2,COLORGRAY;
DRAWTEXT(A and K=1, b7, ' 43.75%:'+NUMTOSTR(b7,2)),ALIGN2,COLORGRAY;DRAWTEXT(A and K=1, b8, ' 56.25%:'+NUMTOSTR(b8,2)),ALIGN2,COLORGRAY;
DRAWTEXT(A and K=1, b9, ' 68.75%:'+NUMTOSTR(b9,2)),ALIGN2,COLORGRAY;DRAWTEXT(A and K=1, b10, ' 93.75%:'+NUMTOSTR(b10,2)),ALIGN2,COLORGRAY;
DRAWTEXT(A and K=1, b11, ' 81.25:'+NUMTOSTR(b11,2)),ALIGN2,COLORGRAY;
DRAWTEXT(A and K=1, b7, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b8, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b9, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b10, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b11, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K<>3,HH, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K<>3,LL, '--------------------------------------------------------------------------------------------------------------------------------------------------------------------'),ALIGN2,COLORCYAN,linethick7;
DRAWTEXT(A and K<>3,mHL,'-------------------------------------------------------------------------------------------------------------------------------'),ALIGN2,coloryellow,linethick7;
DRAWTEXT(A and K=1, a1, '-------------------------------------------------------------------------------------------------------------------------------'),ALIGN2,COLORMAGENTA,linethick7;
DRAWTEXT(A and K=1, a2, '-------------------------------------------------------------------------------------------------------------------------------'),ALIGN2,colorgreen,linethick7;
DRAWTEXT(A and K=1, a3, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b1, '--------------------------------------------------------------------------------------------------'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b2, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b3, '--------------------------------------------------------------------------------------------------'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b4, '--------------------------------------------------------------------------------------------------'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b5, '- - - - - - - - - - - - - - - - - -'),ALIGN2,COLORGRAY,linethick7;
DRAWTEXT(A and K=1, b6, '--------------------------------------------------------------------------------------------------'),ALIGN2,COLORGRAY,linethick7;
VAR1:=ZIG(3,10) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);
VAR2:=ZIG(3,10)>REF(ZIG(3,10),1)
AND REF(ZIG(3,10),1) STICKLINE(VAR1,C,O,8,0),COLORYELLOW,LINETHICK2;
STICKLINE(VAR1,C,O,3,0),COLORYELLOW,LINETHICK2;
STICKLINE(VAR1,H,L,1,0),COLORYELLOW,LINETHICK2;
STICKLINE(VAR2,C,O,8,0),COLORFF00FF,LINETHICK2;
STICKLINE(VAR2,C,O,3,0),COLORFF00FF,LINETHICK2;
STICKLINE(VAR2,H,L,1,0),COLORFF00FF,LINETHICK2;
DRAWTEXT(TROUGHBARS(3,15,1)<1,LOW,'→买入') , COLORRED,LINETHICK1;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.001,'→走人') , COLORGREEN,LINETHICK1;
DRAWICON(CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)) ,LOW*0.99,6);{
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)) ,HIGH*1.02,7);};

飞狐自动百分箱体主图指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top