最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 飞狐公式 > 飞狐碧海扬帆指标公式

飞狐碧海扬帆指标公式

来源:网络 点击: 时间:2019-02-19

DRAWGBK((DATE > 0),COLORRGB(0,33,0),COLORRGB(0,33,0),1);
D_C:=INDEXC; D_H:=MA(INDEXH,3); D_L:=MA(INDEXL,3);
D_F:=if(INDEXC>ref(D_H,1),1,if(INDEXC for i=5+1 to datacount do begin
if D_C[i]>D_H[i-1] then
D_F[i]:=1
else if D_C[i] D_F[i]:=-1
else
D_F[i]:=D_F[i-1];
end;
K1:=IF(D_F>0,-3,IF(D_F<0,1,0));
K2:=VALUEWHEN(K1<>0,K1);
G:=IF(K2<0,-30,0);
FILLRGN(K2<0,G,0),COLORBLUE;
FILLRGN(K2<0,-G,0),Color00B0A3;
{仿天狼剑2}
强:=FORCAST(IF((C-L=O-L),O,C),4);
弱:=(ref(c,1)+ref(c,2)+O)/3;
B_h1:=(O+C*3+L+H)/6;
B_h2:=REVERSE(B_h1)+2*WMA(B_h1,5);
B_h3:=3*B_h2-2*SMA(B_h2,2,1);
B_h4:=BARSLAST((强>弱)=1);
B_h5:=0-BARSLAST((强>弱)=0);
B_h6:=IF(B_h4>0,B_h4,B_h5);
B_h7:=(-1)*B_h6*10;
B_h8:=CROSS(强,弱)&&C>B_h3;
B_h9:=CROSS(弱,强)&&C DRAWICON(CROSS(强,弱),B_h7,10),PXUP1;//进
STICKLINE(B_h8=0 and B_h7>0,0,B_h7,5,0),ColorFFA8FF,COLORMAGENTA;//持:
DRAWICON(B_h9,0,12),PXDN1;//减
STICKLINE(B_h9=0 and B_h7<=0,0,B_h7,5,0),Color009800;//空:
大盘强势区:IF(G,168,0),LINETHICK,Color00D9C5;
{-股票公式网站 www.igojr.com}
趋势:=4*SMA((C-LLV(L,5))/(HHV(H,5)-LLV(L,5))*10,5,1)-3*SMA(SMA((C-LLV(L,5))/(HHV(H,5)-LLV(L,5))*10,5,1),3.2,1);
N_2:=SMA(MAX(C-REF(C,4),0),2,1)/SMA(ABS(C-REF(C,4)),2,1)*100<10;//处女线
低位:=趋势<1.5 or N_2;
PARTLINE(1,0),COLORWHITE;
PARTLINE(低位,0),SHIFT1,LINETHICK2,COLORGREEN;
平滑:=sma(趋势,3,1);
有戏:if((平滑-ref(平滑,1))>=0,888,0),LINETHICK,COLORRED;
无戏:if((平滑-ref(平滑,1))<=0,666,0),LINETHICK,colorFFFF00;

飞狐碧海扬帆指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top