最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式教程 > 写一个画线指标

写一个画线指标

来源:网络 点击: 时间:2019-03-15

求老师帮忙写一个画线指标,条件如下:
已知:
AC,BC 分别是K线图上的两个收盘价,AC在左方,BC在右方。
求:
过AC与BC间的最低价的最低值向右画平行线。

这里已有已知部分,
指标如下:
{参数:AC(0,9999,25),BC(0,9999,1)}
HH:=REFDATE(HHV(H,AC),DATE);
LL:=REFDATE(LLV(L,AC),DATE);
DRAWTEXT(CURRBARSCOUNT=AC,H,'←AC'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=BC,H,'←BC'),COLORWHITE;

可以整个画线指标写完,也可以在已有的基础上续写。


?

老K股票学习网解答:


{参数:AC(0,9999,25),BC(0,9999,1)}
{参数:AC(0,9999,25),BC(0,9999,1)}
HH:=REFDATE(HHV(H,AC),DATE);
LL:=REFDATE(LLV(L,AC),DATE);
DRAWTEXT(CURRBARSCOUNT=AC,H,'←AC'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=BC,H,'←BC'),COLORWHITE;
N:=BARSLAST(L=LL);
A1:=BACKSET(BARSTATUS=2,N+1);
N1:=BARSLAST(A1>REF(A1,1));
L1:REF(L,N1),COLORYELLOW,LINETHICK2;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top