最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > K线一阳穿同时上穿最大的三条均线

K线一阳穿同时上穿最大的三条均线

来源:网络 点击: 时间:2019-03-21

编写要求:

说明:1、阳线(收盘大于开盘,可能有假阳线); 2、最高三线位于阳线实体内,即阳线开盘小于三线但收盘大于三线; 3、编了两个选股,第一个语句有些复杂,第二个简单些;

解答:

【选股1】:
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M30:=MA(C,30);
M60:=MA(C,60);
M120:=MA(C,120);
最大:=MAX(M5,MAX(M10,MAX(M20,MAX(M30,MAX(M60,M120)))));
P1:=IF(M5!=最大,M5,M10);
P2:=IF(M10!=最大,M10,M20);
P3:=IF(M20!=最大,M20,M30);
P4:=IF(M30!=最大,M30,M60);
P5:=IF(M60!=最大,M60,M120);
P6:=IF(M120!=最大,M120,M5);
次大:=MAX(P1,MAX(P2,MAX(P3,MAX(P4,MAX(P5,P6)))));
P11:=IF(M5!=最大 AND M5!=次大,M5,IF(M10!=最大 AND M10!=次大,M10,M20));
P22:=IF(M10!=最大 AND M10!=次大,M10,IF(M20!=最大 AND M20!=次大,M20,M30));
P33:=IF(M20!=最大 AND M20!=次大,M20,IF(M30!=最大 AND M30!=次大,M30,M60));
P44:=IF(M30!=最大 AND M30!=次大,M30,IF(M60!=最大 AND M60!=次大,M60,M120));
P55:=IF(M60!=最大 AND M60!=次大,M60,IF(M120!=最大 AND M120!=次大,M120,M5));
P66:=IF(M120!=最大 AND M120!=次大,M120,IF(M5!=最大 AND M5!=次大,M5,M10));
第三大:=MAX(P11,MAX(P22,MAX(P33,MAX(P44,MAX(P55,P66)))));
O<最大 AND O<次大 AND O<第三大 AND C>最大 AND C>次大 AND C>第三大 AND C>O;
【选股2】:
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M30:=MA(C,30);
M60:=MA(C,60);
M120:=MA(C,120);
最大:=MAX(M5,MAX(M10,MAX(M20,MAX(M30,MAX(M60,M120)))));
M55:=BETWEEN(M5,O,C);
M101:=BETWEEN(M10,O,C);
M202:=BETWEEN(M20,O,C);
M303:=BETWEEN(M30,O,C);
M606:=BETWEEN(M60,O,C);
M12012:=BETWEEN(M120,O,C);
BETWEEN(最大,C,O) AND M55+M101+M202+M303+M606+M12012>=3 AND C>O;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top