最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将135战法改成选股公式,内附战法公式

将135战法改成选股公式,内附战法公式

来源:网络 点击: 时间:2019-05-20

编写要求:

求将135战法改成选股公式 将公式中的“红杏出墙” 黑客点击 红衣侠侣 条件改为3个选股公式 谢谢了 公式如下 EMA13:EMA(C,13),COLORWHITE,LINETHICK2; EMA34:EMA(C,34),COLORYELLOW; EMA55:EMA(C,55),COLORFF00FF; EMA120:EMA(C,120),COLORFFCC66; AR1:=EMA55>EMA34 AND EMA34>EMA13; AR2:=BARSLAST((C-EMA13)/EMA13*100<-6); AR3:=EMA13>=REF(EMA13,2); AR4:=COUNT(CROSS(C,EMA13),AR2)=1; AR5:=AR1 AND AR2 AND AR3 AND AR4; AR6:=AR5 AND FILTER(AR5,10); DRAWTEXT(AR6,L-0.09,'红杏出墙'),COLORYELLOW; {STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;} {STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;} BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5; BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2; BR3:=C>EMA55 AND (REF(C,1)0.5; CR2:=V>MA(V,5)*0.6; CR3:=COUNT(CROSS(EMA13,EMA55),3)=1; CR4:=ABS(EMA34-EMA55)/EMA55<0.03; CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1); CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2); {STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;} {STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;} DRAWTEXT(CR6,L-0.09,'红衣侠女'),COLORF00FF0; DR1:=EMA13>EMA34 AND EMA34C AND CEMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1; DR6:=C>REF(C,1) ; DR7:= DR1 AND DR5 AND DR6 ; DR8:=DR7 AND FILTER(DR7 ,10); DRAWTEXT(DR8,L-0.09,'黑客点击'),COLORD6BA63; {STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;} STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63; ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55); DRAWTEXT(ER,L-0.09,'均线互换'),COLOR0099FF; {STICKLINE(ER,H,L,0.5,1),COLOR0099FF;} {STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;} FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34); DRAWTEXT(FR,L-0.09,'梅开二度'),COLORWHITE; STICKLINE(FR,H,L,0.5,1),COLORWHITE; {STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;} GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) ); GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1); GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1); GR4:=H=HHV(H,GR1); GR5:="MACD.MACD"(12,26,9)=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS (C,EMA55){ AND CROSS(C,EMA120)}; DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,'三线推进'),COLORFFC8FF; {STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF; STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;};

解答:

?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top