最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 指标中黄色启动点 改为选股

指标中黄色启动点 改为选股

来源:网络 点击: 时间:2019-03-28

编写要求:

箱顶:MA(REF(HHV(C,30),1),2),COLOR0000FF,LINETHICK2; 箱底:MA(REF(LLV(C,30),1),2),COLOR00FF00,LINETHICK2; A:=(3*CLOSE+LOW+OPEN+HIGH)/6; HJX21:=(21*A+20*REF(A,1)+19*REF(A,2)+18*REF(A,3)+17*REF(A,4)+16*REF(A,5)+ 15*REF(A,6)+14*REF(A,7)+13*REF(A,8)+12*REF(A,9)+11*REF(A,10)+ 10*REF(A,11)+9*REF(A,12)+8*REF(A,13)+7*REF(A,14)+6*REF(A,15)+ 5*REF(A,16)+4*REF(A,17)+3*REF(A,18)+2*REF(A,19)+ REF(A,21))/231; HJX3:=(3*A+2*REF(A,1)+REF(A,2))/6; DC1:EMA(HJX3,4),COLORFF00FF; DC2:EMA(DC1,3),COLORRED; DC3:EMA(DC1,7),COLORRED; K1:=BACKSET(DC1REF(D,1); YX3:=DC4>DC6 AND DC5>DC6; YX4:=CLOSE>DC4 AND CLOSE/DC4<1.1; YX5:=DC1>DC2 AND DC2>DC3; XG:=YX2 AND YX3 AND YX4; 神:=XG AND COUNT(XG,10)=1 AND COUNT(YX5,10)<5,LINETHICK0; DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); DEA:=EMA(DIFF,9); MACD:=2*(DIFF-DEA); XG0:=CROSS(MACD,0); 叠:=CROSS(CLOSE,DC1) AND CROSS(CLOSE,DC2) AND CROSS(CLOSE,DC3) AND BARSLAST(XG0)<=5 AND CLOSE1.0035; MIDRISE:=HJX>REF(HJX,1); LBDOWN:=HDOWN0.99 AND (OPEN+LOW)/2.1OPEN AND ((HIGH-CLOSE)+(OPEN-LOW))/(CLOSE-OPEN)<1.2 AND HIGH/CLOSE<1.035; TDKD:=100*(HUP-HDOWN)/HJX; TDXT:=TDKD<15 AND LLV(TDKD,8)<10; XGG:=LBRISE AND MIDRISE AND CLB1 AND KXT AND TDXT; CXG:=COUNT(XGG,20); 喇:=XGG AND CXG=1 AND COUNT(LBRISE,10)<10 AND HIGH/HHV(HIGH,5)>0.98,LINETHICK0; DRAWICON(神,LOW*0.970,9); 金:=CROSS(DC1,DC2),LINETHICK0; CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2+O)/5; E:=CDP; ZL:=2*E-REF(L,1); ZC:=2*E-REF(H,1); FZ:=E-(REF(H,1)-REF(L,1)); ZZ:=CDP+(REF(H,1)-REF(L,1)); VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VARD:=CLOSE=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1; VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD; STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR00FFFF; STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),4,0),COLORFF50FF; DRAWTEXT(FILTER(EMA(EMA(C,5),5)>REF(EMA(EMA(C,5),5),1) AND HHV(MA(H,13),13)REF(C,1),11),L*0.98,'追'),COLORYELLOW; DRAWTEXT(CROSS(84,SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100),H*1.03,'逃'),COLORYELLOW ; MA5:MA(C,5),COLORFF50FF,LINETHICK1; DRAWBAND(MA5,RGB(150,0,0),REF(MA5,1),RGB(0,150,0));

解答:

?VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARD:=CLOSE VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top