最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把有庄控盘的有庄改选股

把有庄控盘的有庄改选股

来源:网络 点击: 时间:2018-08-30

编写要求:

原码: VAR1:=EMA(EMA(CLOSE,13),13); 控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000; STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00; STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF; 无庄控盘:=控盘<0; STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF; 有庄控盘:=控盘>REF(控盘,1) AND 控盘>0; VAR2:=100*WINNER(CLOSE*0.95); STICKLINE(控盘0,控盘,0,1,1),COLORFFFF00; 主力出货:=控盘0; STICKLINE(VAR2>50 AND COST(85)0,控盘,0,1,1),COLOR00FFFF; 高度控盘: VAR2>50 AND COST(85)0,COLOR00FFFF,LINETHICK2; A10:=CROSS(控盘,0); 控盘B:=FILTER(IF(A10,1,0),5); {分时价格原码} JJ:=DYNAINFO(11); {波段买卖原码} P:=55;S:=8;M1:=3; 财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2; 神:=EMA(财,M1),COLORGREEN,LINETHICK1; DRAWBAND(财,RGB(255,0,0),神,RGB(0,100,50)); {股价与均线偏离买卖条件} BTJ1:=(C-JJ)/JJ<-0.03; BTJ11:=(C-JJ)/JJ<-0.03; BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005; STJ1:=(C-JJ)/JJ>0.005; {控盘买卖条件} STJ01:=控盘0.5; STJ02:=控盘>0; BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2; BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ; {波段买卖条件} BTJ3:=CROSS(财,神) AND 财<-0.3; BTJ32:=CROSS(财,神) AND 财<-0.1; STJ31:=CROSS(神,财); STJ32:=CROSS(神,财) AND 财>1.618; {以下为信号}; BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13); BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13); BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13); DRAWTEXT(BTJ81,神,'↑买底'),COLORRED; DRAWTEXT(BTJ811,神*1.2,'↑有庄'),COLORWHITE; STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13); STJ82:=FILTER(STJ02 AND STJ32 ,13); STJ83:=STJ81 AND STJ82; DRAWTEXT(STJ83,神,'↓卖'),COLOR00FF00; DIFF: (EMA(CLOSE,8) - EMA(CLOSE,55))*10,COLORRED; DEA: EMA(DIFF,3),COLORGREEN; 庄:= BTJ11 AND BTJ2 AND BTJ3; 有庄:FILTER(庄,55),COLORWHITE; DRAWTEXT(BTJ811,有庄,'有庄'),COLORWHITE;

解答:

?VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
JJ:=DYNAINFO(11);
P:=55;
S:=8;
M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10;
神:=EMA(财,M1);
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ3:=CROSS(财,神) AND 财<-0.3;
有庄:BTJ11 AND BTJ2 AND BTJ3;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top