最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把绝处逢生做个选股

把绝处逢生做个选股

来源:网络 点击: 时间:2019-02-25

编写要求:

请老师把绝处逢生、和回调找低点出现必大涨各做个选股 有未来 VAR59:=1/WINNER(CLOSE); VAR33:=MA(CLOSE,13); VAR34:=100-ABS((CLOSE-VAR33)/VAR33*100); VAR35:=LLV(LOW,75); VAR36:=HHV(HIGH,75); VAR37:=(VAR36-VAR35)/100; VAR38:=SMA((CLOSE-VAR35)/VAR37,20,1); VAR39:=SMA((OPEN-VAR35)/VAR37,20,1); VARA3:=3*VAR38-2*SMA(VAR38,15,1); VARB3:=3*VAR39-2*SMA(VAR39,15,1); VARC3:=100-VARB3; VARE3:=REF(LOW,1)*0.9; VARF3:=LOW*0.9; VAR40:=(VARF3*VOL+VARE3*(CAPITAL-VOL))/CAPITAL; VAR41:=EMA(VAR40,30); VAR42:=CLOSE-REF(CLOSE,1); VAR43:=MAX(VAR42,0); VAR44:=ABS(VAR42); VAR45:=SMA(VAR43,7,1)/SMA(VAR44,7,1)*100; VAR46:=SMA(VAR43,13,1)/SMA(VAR44,13,1)*100; VAR47:=BARSCOUNT(CLOSE); VAR48:=SMA(MAX(VAR42,0),6,1)/SMA(ABS(VAR42),6,1)*100; VAR49:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100; VAR3A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100; VAR3B:=SMA((SMA(VAR3A,4,1)-50)*2,3,1); VAR3C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100; VAR3D:=SMA(VAR3C,4,1); VAR3E:=SMA(VAR3D,3,1); VAR3F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100; VAR50:=VAR48<=25 AND VAR49<-95 AND VAR3F>20 AND VAR3B<-30 AND VAR3E<30 AND VAR41-CLOSE>=-0.25 AND VAR45<22 AND VAR46<28 AND VAR47>50; VAR51:=(HIGH+LOW+CLOSE)/3; VAR52:=(VAR51-MA(VAR51,14))/(0.015*AVEDEV(VAR51,14)); VAR53:=(VAR51-MA(VAR51,70))/(0.015*AVEDEV(VAR51,70)); VAR54:=IF(VAR52>=150 AND VAR52<200 AND VAR53>=150 AND VAR53<200,10,0); VAR55:=IF(VAR52<=-150 AND VAR52>-200 AND VAR53<=-150 AND VAR53>-200,-10,VAR54); 绝处逢生: IF(VAR53>=200 AND VAR52>=150,15,IF(VAR53<=-200 AND VAR52<=-150,-15,VAR55))+50,LINETHICK1,CROSSDOT,COLORWHITE; VAR56:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100; VAR57:=REVERSE(VAR56); VAR58:=SMA(VAR56,3,1); 波段王: SMA(VAR58,3,1),COLORFF10FF,LINETHICK0; 波段鬼: SMA(波段王,3,1),COLORWHITE,LINETHICK0; 低吸: IF(CROSS(波段王,波段鬼) AND 波段王<50,25,0),STICK,LINETHICK3,COLORRED; DRAWTEXT(CROSS(波段王,波段鬼) AND 波段王<50,25,'低吸'),LINETHICK1,COLORWHITE; VARF:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1); VAR19:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1); VAR20:=VARFREF(VOL,1) AND CLOSE>REF(CLOSE,1); DRAWTEXT(VAR20 AND COUNT(VAR20,30)=1,45,'大资金活动'),LINETHICK2,COLOR0000FF; 大资金:IF(VAR20 AND COUNT(VAR20,30)=1,30,0),STICK,LINETHICK2,COLOR0000FF; VAR1:=(CLOSE*2+HIGH+LOW)/4*10; VAR2:=EMA(VAR1,13)-EMA(VAR1,34); VAR3:=EMA(VAR2,5); VAR4:=2*(VAR2-VAR3)*5.5; 主力撤: IF(VAR4<=0,VAR4,0),COLORWHITE; 主力进: IF(VAR4>=0,VAR4,0),LINETHICK2,COLOR0000FF; VAR5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8; VAR6:=EMA(3*VAR5-2*SMA(VAR5,18,1),5); VAR7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10; VAR8:=(INDEXC*2+INDEXH+INDEXL)/4; VAR9:=EMA(VAR8,13)-EMA(VAR8,34); VARA:=EMA(VAR9,3); VARB:=(VAR9-VARA)/2; VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; VAR10:=(HIGH+LOW+CLOSE)/3; VAR11:=(VAR10-MA(VAR10,14))/(0.015*AVEDEV(VAR10,14)); VAR12:=(VAR10-MA(VAR10,70))/(0.015*AVEDEV(VAR10,70)); VAR13:=IF(VAR11>=150 AND VAR11<200 AND VAR12>=150 AND VAR12<200,10,0); VAR14:=IF(VAR11<=-150 AND VAR11>-200 AND VAR12<=-150 AND VAR12>-200,-10,VAR13); VAR15:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100; VAR16:=100-ABS(VAR15); VAR17:=IF(VAR16<90,VAR16,100); VAR1A:=IF(VARE>0,VARE,0); VAR1B:=IF(VAR12>=200 AND VAR11>=150,15,IF(VAR12<=-200 AND VAR11<=-150,-15,VAR14))+60; VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR17<100; DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,40,'出现必大涨'),LINETHICK2,COLORRED; DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,25,'回调找低点'),LINETHICK2,COLORYELLOW; 出货:IF(VAR1C AND COUNT(VAR1C,30)=1,30,0),STICK,LINETHICK2,COLORRED; MA5:=MA(CLOSE,5); MA10:=MA(CLOSE,10); MA30:=MA(CLOSE,30); MA60:=MA(CLOSE,60); MA65:=MA(CLOSE,65); MA250:=MA(CLOSE,250); 均线流:(((((MA5 > MA65) AND (MA10 > MA65)) AND (MA30 > MA65)) AND (MA5 < MA30)) * 7),POINTDOT,LINETHICK3; PL1:=(((CLOSE - MA60) / MA60) < 0.1); PL2:=(((CLOSE - MA250) / MA250) < 0.3); 偏离率:(((PL1 = 1) AND (PL2 = 1)) * 5),STICK,LINETHICK0,COLORWHITE; STICKLINE((偏离率 = 5),0,5,5,1),COLORWHITE; DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); DEA :=EMA(DIFF,9); MACD超跌:=(COUNT((DIFF < DEA),10) = 10); MACD:(MACD超跌 * "MACD.MACD"(26,12,9))*(-1),STICK,LINETHICK2,COLORFFFF00; 目标:IF(均线流=7 AND MACD AND 偏离率=5 ,-15,0),LINETHICK2,COLORFFFFFF; MBSJ:=BARSLAST((目标 =10)); 放量上涨:=(((VOL / REF(VOL,1)) >= 1.1) AND ((CLOSE / REF(CLOSE,1)) >= 1.01)); SZSJ:=BARSLAST((放量上涨 = 1)); MACD金叉:=CROSS(DIFF,DEA); JCSJ:=BARSLAST((MACD金叉 = 1)); 金叉:((MACD金叉 AND (REF(MACD,1) < 0)) * -15),STICK,COLOR66FF00,LINETHICK2; DRAWTEXT(金叉,-3,'金叉'),COLOR66FF00,LINETHICK2; 突破:((((偏离率 = 0) AND (REF(偏离率,1) = 5)) AND (REF((COUNT((偏离率 = 5),10) = 10),1) = 1)) * 40),STICK,LINETHICK2,COLOR66FF00; DRAWTEXT(突破,50,'突★破'),LINETHICK3,COLOR66FF00; LC:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100; DRAWICON(CROSS(84,RSI) ,H*1.03,5); DRAWICON(CROSS(RSI,11) ,L*0.99,4); VAR27A:=REF(CLOSE,1); VAR28A:=SMA(MAX(CLOSE-VAR27A,0),5.5,1)/SMA(ABS(CLOSE-VAR27A),6,1)*100; DRAWICON(IF(CROSS(76,VAR28A),1,0),H*1.03,5); VARA1:=((AMOUNT)/(VOL))/(100); VARB1:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7); VARC1:=((SUM(AMOUNT,7))/(VARA1))/(100); VARD1:=DMA(VARB1,(VOL)/(VARC1)); VARE1:=((CLOSE-VARD1)/(VARD1))*(100); VARF1:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100); VARJ1:=MA(VARE1,20)+STD(VARE1,20); BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100); AA1:=SMA(VARF1,3,1); SS1:=(REF(BIAS18,1)>=5) AND CROSS(VARJ1,VARE1) AND (AA1>79); VAR1AA:=ZIG(3,10)REF(ZIG(3,10),2);{ZIG 有未来} VAR2AA:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)= 1.099); VAR100:=((OPEN = LOW) AND (HIGH = CLOSE)); VAR101:=((VOL < MA(VOL,5)) AND (VOL < REF(VOL,1))); VAR102:=(((VAR4F AND VAR100) AND VAR101) AND (COUNT(((VAR4F AND VAR100) AND VAR101),20) = 1)); (VAR102 AND (((((((VAR98 OR VAR99) OR VAR4A) OR VAR3B) OR VAR4C) OR VAR4D) OR VAR4E) OR (VAR95 < 38))); DRAWTEXT(VAR102 AND COUNT(VAR102,20)=1,60,'井★喷'),LINETHICK2,COLOR00FF00; 井喷:IF(VAR102 AND COUNT(VAR102,20)=1,50,0),STICK,LINETHICK2,COLOR00FF00;

解答:

?VAR59:=1/WINNER(CLOSE);

VAR33:=MA(CLOSE,13);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top