最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 改机会来临选股公式三个信号的颜色

改机会来临选股公式三个信号的颜色

来源:网络 点击: 时间:2019-05-18

编写要求:

这个公式 底部 机会来临 和 低位金叉 这三个信号 个人感觉 参考性很强 就是信号的颜色都是红的 不美观 请老师 略微点几下金手指 把他改成三种不同的颜色 A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1); 黑马线:=EMA(A1,5),LINETHICK2 ; A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100; A3:=EMA(C,5); A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100; 趋势线:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)) ; A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100; 底部:(A2<-10 AND A2>REF(A2,1))*25,COLORRED; DRAWICON(底部 AND A3>REF(A3,1),25,4); 机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0; 大势已去:=IF(CROSS(黑马线,A1)AND 黑马线>70 AND 趋势线>80,90,100),COLORFF0000; A6:=C>REF(C,1) AND V>REF(C,1); 低位金叉:(CROSS(趋势线,黑马线) AND 趋势线<20 AND 黑马线<20 AND A6)*25;

解答:

?A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A1,5),LINETHICK2 ;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)) ;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
底部:(A2<-10 AND A2>REF(A2,1))*25,COLORRED;
DRAWICON(底部 AND A3>REF(A3,1),25,4);
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1)*1.5,COLOR0066FF;
大势已去:=IF(CROSS(黑马线,A1)AND 黑马线>70 AND 趋势线>80,90,100),COLORFF0000;
A6:=C>REF(C,1) AND V>REF(C,1);
低位金叉:(CROSS(趋势线,黑马线) AND 趋势线<20 AND 黑马线<20 AND A6)*25,COLORFFFFFF;

标签:信号

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top