最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把"懒猫" 指标出现'会员★之星'改为选股

把"懒猫" 指标出现'会员★之星'改为选股

来源:网络 点击: 时间:2019-02-11

编写要求:

麻烦老师把 懒猫 出现黄色‘ 会员之星’ 改为选股指标 》》》 N:=10; VAR01:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)- 3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLOR0099FF,LINETHICK1; VAR02:8,COLORGREEN,LINETHICK1; 上升在即: IF(CROSS(VAR01,VAR02),80,0),STICK,COLORRED,LINETHICK2; 专吸庄血: IF(VAR01<=8,25,0),STICK,COLORBLUE,LINETHICK2; DRAWTEXT(CROSS(VAR01,VAR02),80,'准备买入'),COLORRED; VARO5:=LLV(LOW,27); VARO6:=HHV(HIGH,34); VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25; 建仓区: IF((VARO7<10),80,100) ,COLORFFFF00,LINETHICK1; 0,LINETHICK2 ,COLORFFCC00; VAR1:="DMI.PDI"(12,6); VAR2:="DMI.MDI"(12,6); VAR3:=VAR1>65 AND VAR1>REF(VAR1,1); VAR4:=LLV(VAR1,0); VAR5:=BARSLAST(VAR4=VAR1); VAR6:=(0-REF(VAR2,4))/(VAR4-REF(VAR2,VAR5))>2; VAR7:=VAR1>REF(VAR1,1); VAR8:=VOL>2*MA(VOL,30); VAR9:="DMI.ADX"(12,6); VARA:="DMI.ADXR"(12,6); VARB:=CLOSE>MA(CLOSE,30) AND CLOSEREF(MA(CLOSE,30),1); VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))REF(EMA(CLOSE,30),2); VAR11:=IF(VARF=1,50,0); VAR12:=CROSS(VAR2,VAR1) AND CROSS(VARA,VAR9); VAR13:=CROSS(VAR2,VAR1) AND CROSS(VAR9,VARA); VAR14:=VARB AND VARC AND VARD AND VAR10 AND VAR6 AND VAR7 AND VAR8*50; VAR15:=BARSLAST(CROSS(VAR2,VAR1)=1); VAR16:=BARSLAST(CROSS(VAR1,VAR2)=1); VAR17:=HHV(VAR1,VAR16); VAR18:=BARSLAST(VAR1=VAR17); 多空:EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE; 0,COLORRED; STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,15,0),COLORF00FF0; STICKLINE(FILTER(VARF=1,5),50,0,4,0),COLORYELLOW; VAR19:=VAR3 OR VAR12 OR VAR13*100; VAR1A:=VAR13*100; DRAWTEXT(FILTER(VARF=1,3),25,'会员★之星'),COLORRED ; STICKLINE(多空<-10,0,多空,0.85,0),COLORYELLOW; STICKLINE(多空>10,0,多空,0.95,0),COLORRED;

解答:

?N:=10;

VAR01:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top