最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把大智慧的CPX操盘线改成通达信能用的

把大智慧的CPX操盘线改成通达信能用的

来源:网络 点击: 时间:2018-08-13

编写要求:

大智慧CPX操盘线源码: {CPX操盘线} bu:=cross(high,SAR(3,1,20)); sel:=cross(SAR(3,1,20),low); var1:=last(highsar(3,1,20)); drawflagtext(bu,high,'买入'); drawflagtext(sel,low,'卖出'); drawtext(bu,LOW,'B'),valign0,align1,coloryellow,linethick2; drawtext(sel,HIGH,'S'),valign2,align1,colorgreen,linethick2; STICKLINE(low>SAR(3,1,20) and isdown,high,open,0.5,1),colorred; STICKLINE(low>SAR(3,1,20) and isdown,close,open,7.5,1),colorred; STICKLINE(low>SAR(3,1,20) and isdown,close,low,0.5,1),colorred; STICKLINE(high=ref(high,1),high,'明日突破'+forcast(sar(3,1,20),max(var1,2))+'建议关注'); drawflagtext(highSAR(3,1,20) and low<=ref(low,1),low,'明日跌破'+forcast(sar(3,1,20),max(var2,2))+'注意止盈'); drawflagtext(low>SAR(3,1,20) and low>ref(low,1),low,'继续持股'); {DPCW大盘仓位} Ms5:=SMA(MA(C,2),5,3); Ms13:=SMA(C,13,2); Ms21:=SMA(C,21,1); RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100; a:=SMA(RSV,3,1); b:=SMA(a,3,1); DDX:=bigorder(1,2)-bigorder(2,2); DIFF:=EMA(DDX,6) - EMA(DDX,13); DIFF2:=EMA(DDX,9) - EMA(DDX,20); IF(Ms5>REF(Ms5,1)) then m1:=10; ELSE IF(Ms5C) then m2:=-5; IF(Ms13>REF(Ms13,1)) then m3:=5; ELSE IF(Ms13REF(Ms21,1)) then m4:=10; ELSE IF(Ms2190) then m5:=-10; ELSE IF(b<90 AND b>10) then m5:=0; ELSE IF(b<10) then m5:=10; IF(diff>0 AND diff2>0) then m6:=10; ELSE IF(diff>0 OR diff2>0) then m6:=0; ELSE IF(diff<0 AND diff2<0) then m6:=-10; 大盘仓位:(m1+m2+m3+m4+m5+m6+50); STICKLINE(大盘仓位>50,0,大盘仓位,9,1),colorF000FF; STICKLINE(大盘仓位<=50,0,大盘仓位,9,0),colorgreen;

解答:

?BU:=CROSS(HIGH,SAR(3,1,20));

SEL:=CROSS(SAR(3,1,20),LOW);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top