最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把AAA量线指标10根量线中,上升趋势大于5根时做选股公式

把AAA量线指标10根量线中,上升趋势大于5根时做选股公式

来源:网络 点击: 时间:2019-03-22

编写要求:

请求各位老师编应该aaa量线的选股公式,要求:10根量线(b1 b2....b10)中,上升趋势(今天的数值比昨天大)大于5. 原公式如下:(在此感谢原创老师): CV:=CLOSE; BBIBOLL:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4; UPR:=BBIBOLL+6*STD(BBIBOLL,11); DWN:=BBIBOLL-6*STD(BBIBOLL,11); QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN)); XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSEOPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSEREF(B1,1),B1,DRAWNULL),COLORRED; A2:IF(B2>REF(B2,1),B2,DRAWNULL),COLORRED; A3:IF(B3>REF(B3,1),B3,DRAWNULL),COLORRED; A4:IF(B4>REF(B4,1),B4,DRAWNULL),COLORRED; A5:IF(B5>REF(B5,1),B5,DRAWNULL),COLORRED; A6:IF(B6>REF(B6,1),B6,DRAWNULL),COLORRED; A7:IF(B7>REF(B7,1),B7,DRAWNULL),COLORRED; A8:IF(B8>REF(B8,1),B8,DRAWNULL),COLORRED; A9:IF(B9>REF(B9,1),B9,DRAWNULL),COLORRED; A10:IF(B10>REF(B10,1),B10,DRAWNULL),COLORRED; XG:=B1 AND B2 AND B3 AND B4 AND B5 AND B6 AND B7 AND B8 AND B9 AND B10 AND (CLOSE-OPEN)>=(UPR-BBIBOLL) AND V/REF(V,1)>=1.9; DRAWICON(XG,-100,1);

解答:

?QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSEOPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE HSL:=(XVL/20)/1.15;
攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击,3);
B1:=SUM(LLJX,1);
B2:=SUM(LLJX,2);
B3:=SUM(LLJX,3);
B4:=SUM(LLJX,4);
B5:=SUM(LLJX,5);
B6:=SUM(LLJX,6);
B7:=SUM(LLJX,7);
B8:=SUM(LLJX,8);
B9:=SUM(LLJX,9);
B10:=SUM(LLJX,10);
A1:=B1>REF(B1,1);
A2:=B2>REF(B2,1);
A3:=B3>REF(B3,1);
A4:=B4>REF(B4,1);
A5:=B5>REF(B5,1);
A6:=B6>REF(B6,1);
A7:=B7>REF(B7,1);
A8:=B8>REF(B8,1);
A9:=B9>REF(B9,1);
A10:=B10>REF(B10,1);
XG:(A1+A2+A3+A4+A5+A6+A7+A8+A9+A10)>=5;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top