最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将下面的公式增加大黑马选股

将下面的公式增加大黑马选股

来源:网络 点击: 时间:2019-05-10

编写要求:

请老师将下面的公式大黑马增加一个选股功能 ............................谢谢 Var1:=MA(CLOSE,152); Var2:=MA(CLOSE,194); Var3:=Var2+2*STD(CLOSE,170); Var4:=Var1+2*STD(CLOSE,170); 顶:(CLOSE>Var3)*13*10,colorblue,linethick2; Var6:=EMA(HHV(HIGH,500),21); Var7:=EMA(HHV(HIGH,250),21); Var8:=EMA(HHV(HIGH,90),21); Var9:=EMA(LLV(LOW,500),21); VarA:=EMA(LLV(LOW,250),21); VarB:=EMA(LLV(LOW,90),21); VarC:=EMA((Var9*0.96+VarA*0.96+VarB*0.96+Var6*0.558+Var7*0.558+Var8*0.558)/6,21); VarD:=EMA((Var9*1.25+VarA*1.23+VarB*1.2+Var6*0.55+Var7*0.55+Var8*0.65)/6,21); VarE:=EMA((Var9*1.3+VarA*1.3+VarB*1.3+Var6*0.68+Var7*0.68+Var8*0.68)/6,21); VarF:=EMA((VarC*3+VarD*2+VarE)/6*1.738,21); Var10:=REF(LOW,1); Var11:=SMA(ABS(LOW-Var10),3,1)/SMA(MAX(LOW-Var10,0),3,1)*100; Var12:=EMA(IF(CLOSE*1.35<=VarF,Var11*10,Var11/10),3); Var13:=LLV(LOW,30); Var14:=HHV(Var12,30); Var15:=IF(MA(CLOSE,58),1,0); Var16:=EMA(IF(LOW<=Var13,(Var12+Var14*2)/2,0),3)/618*Var15; Var17:=IF(Var16>50,50,Var16)/3.82*6; 底部吸筹: STICKLINE(Var17>0,0,Var17,5,1),colormagenta , ; Var18:=HHV(HIGH,30); Var19:=LLV(LOW,30); NL:=EMA((CLOSE-Var19)/(Var18-Var19)*100,5)/8*10,coloryellow,linethick2; Var1A:=(EMA(AMOUNT,5)/EMA(VOL,5)/100-EMA(AMOUNT,125)/EMA(VOL,125)/100)/(EMA(AMOUNT,5)/EMA(VOL,5)/100)<-0.4; Var1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100; Var1C:=SMA(Var1B,3,1); Var1D:=SMA(Var1C,3,1); Var1E:=(-100)*(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52)); Var1F:=COUNT(Var1A,5)>=1 AND (Var1E<-99.9 OR Var1D<15 AND Var1C<12); Var20:=VOL/FINANCE(7); Var21:=100*WINNER(CLOSE); Var22:=MA(Var21,3); Var23:=MA(Var20,34); Var24:=Var22REF(CLOSE,1),1,0),0); Var26:=SUMBARS(VOL,CAPITAL); Var27:=IF(CLOSE>LLV(CLOSE,Var26),1,-1)*IF(Var25>LLV(Var25,Var26),1,-1); Var28:=COUNT(IF(Var27=-1,1,0)=1,8)>2; Var29:=(CLOSE-DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100)))/DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100))*100<-18; Var2A:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.01; Var2B:=Var28 AND Var29 AND Var2A; Var2C:=VOL/CAPITAL>=0.02 AND VOL/CAPITAL<=0.2 AND OPEN=1.105; Var2D:=Var2C AND COUNT(Var2C,5)=1; Var2E:=Var2B OR Var2C; Var2F:=REF(CLOSE,1); Var30:=SMA(MAX(CLOSE-Var2F,0),7,1)/SMA(ABS(CLOSE-Var2F),7,1)*100; Var31:=SMA(MAX(CLOSE-Var2F,0),13,1)/SMA(ABS(CLOSE-Var2F),13,1)*100; Var32:=Var30<20 AND Var31<25; Var33:=Var32; Var34:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSELLV(CLOSE,Var26),1,-1); Var36:=IF(Var34>LLV(Var34,Var26),1,-1); Var37:=Var35*Var36; Var38:=IF(Var37=-1,1,0); Var39:=Var38 AND CLOSE=LLV(CLOSE,120) AND Var210,4),70,0); DRAWTEXT(FILTER(Var24 AND Var2E AND Var33 OR Var33 AND Var39,1),Var2*4-13,'抄底'),colorred; STICKLINE(IF(Var24 AND Var2E AND Var33 OR Var33 AND Var39,35,0),0,Var2*4-4,15,0); Var3B:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100; Var3C:=SMA(Var3B,3,1); Var3D:=SMA(Var3C,3,1); Var3E:=SMA(Var3D,3,1); Var3F:=CROSS(Var3D,Var3E) AND Var3D<20; Var40:=CROSS(Var3E,Var3D) AND Var3D>80; Var41:=5; DRAWTEXT(CROSS(Var41,NL),30,'★做底'),colorwhite; Var42:="RSI#WEEK"(12,12,12); Var43:="RSI#WEEK"(55,55,55); Var44:=REF(CLOSE,1); Var45:=SMA(MAX(CLOSE-Var44,0),6,1)/SMA(ABS(CLOSE-Var44),6,1)*100; Var46:=FILTER(Var40,5)=1 AND BARSLAST(CROSS(Var42,Var43) AND Var42<=60)>=20; STICKLINE(CROSS(Var42,Var43) AND Var42<=60,0,Var2*15+5,3,0),colormagenta; DRAWTEXT(CROSS(Var42,Var43) AND Var42<=60,(Var2*12+3)/1,'加仓'),colormagenta; STICKLINE(CROSS(84,Var45),0,Var2*15+3,5,1),colorgreen; STICKLINE(Var46,Var2*15+10,10,6,0.3),colorgreen ; {IF(CROSS(84,Var45),DRAWTEXT(CROSS(84,Var45),80,'预警'),IF(Var46,DRAWTEXT(Var46,100,'减仓'),0)),colorgreen ,;} DRAWTEXT(CROSS(84,Var45),80,'预警'),colorgreen ,; DRAWTEXT(Var46,100,'减仓'),colorgreen ,; Var47:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5); Var48:=(CLOSE-LLV(CLOSE,126))/(HHV(CLOSE,126)-LLV(CLOSE,126))*100; Var49:=EMA(CLOSE,2)-EMA(CLOSE,150); Var4A:=EMA(Var49,100); Var4B:=2*(Var49-Var4A); Var4C:=POW(Var4B,3)*0.1+POW(Var4B,1); Var4D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE)); Var4E:=EMA(Var4D*0.97,3); Var4F:=(HIGH+LOW+CLOSE)/3; Var50:=(Var4F-MA(Var4F,14))/(0.015*AVEDEV(Var4F,14)); Var51:=IF(Var4B>0.1,Var4C,0)*5; Var52:=LLV(HIGH,240); Var53:=100*(CLOSE-Var52)/Var52; Var54:=AMOUNT/VOL; Var55:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5); Var56:=INDEXC; Var57:=MA(Var56,5); Var58:=MA(Var56,20); Var59:=MA(Var56,30); Var5A:=Var59>Var57*1.08 AND Var58>Var57*1.055; Var5B:=Var57>Var56*1.03 AND Var58>Var56*1.13; Var5C:=Var5B; Var5D:=IF(FILTER(Var55<6,5)=1,1,0); Var5E:=(Var5D AND Var53<-2.5 AND Var47<5 AND Var48=0)*60; Var5F:=Var55<6 AND Var5C; Var60:=IF(FILTER(Var5F,1)=1,1,0)*80; Var61:=Var5F AND Var5D*80; Var62:=CROSS(Var51,2); Var63:=CROSS(Var51,4); Var64:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100; Var65:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100; Var66:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100; Var67:=REF(CLOSE,1); Var68:=SMA(MAX(CLOSE-Var67,0),5,1)/SMA(ABS(CLOSE-Var67),5,1)*100; Var69:=(HIGH+LOW+CLOSE)/3; Var6A:=(Var69-MA(Var69,14))/(0.015*AVEDEV(Var69,14)); Var6B:=(Var64>=-15.8 AND Var64<=-12.2 AND Var65<=-20.8 AND Var66<=-27.5 AND Var68<=11.7 AND Var6A<=-145)*100; Var6C:=Var48=0; Var6D:=Var48=100; Var6E:=LLV(HIGH,240); Var6F:=100*(CLOSE-Var6E)/Var6E; Var70:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100; Var71:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100; Var72:=0; Var73:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100; Var74:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100; Var75:=BARSCOUNT(CLOSE); Var76:=Var73<20 AND Var74<23 AND Var75>35; Var77:=Var76 AND COUNT(Var76,1)=1; Var78:=EMA(CLOSE,21)-EMA(CLOSE,8); Var79:=EMA(Var78,5); Var7A:=TROUGHBARS(3,6,1)<4 AND CROSS(Var78,Var79); Var7B:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0); Var7C:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0); Var7D:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100; Var7E:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100; Var7F:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100; Var80:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5; Var81:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5; Var82:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5; Var83:=(Var7D+Var7E+Var7F+Var80+Var81+Var82)/6; Var84:=EMA(Var83,3); Var85:=ABS(Var80-Var82); Var86:=(Var83+Var85)/2; Var87:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50; Var88:=Var87+Var86; Var89:=IF(Var7C>0 AND Var88<0,200,0); Var8A:=IF(Var86<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0); Var8B:=IF(Var88<0 AND Var8A=-50,100,0); Var8C:=MA(CLOSE,3); Var8D:=REF(CLOSE,2)*0.865; Var8E:=REF(CLOSE,13)*0.772; Var8F:=MIN(Var8D,Var8E); Var90:=100*VOL/CAPITAL; Var91:=MA(CLOSE,13); Var92:=IF((CLOSE-Var8F)/CLOSE<0.03 AND SUM(Var90,5)/5<1.8,1,0); Var93:=IF(Var92>0 AND (Var8A<0 OR Var7C>0),100,0); Var94:=Var93; Var95:=IF(Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0) AND (Var8A<0 OR Var7C>0) AND Var93<10,50,0); Var96:=(Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0) AND (Var8A<0 OR Var7C>0); Var97:=Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902; Var98:=Var96 OR Var97; Var99:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1); Var9A:=HIGH-REF(HIGH,1); Var9B:=REF(LOW,1)-LOW; Var9C:=SMA(IF(Var9A>0 AND Var9A>Var9B,Var9A,0),12,1); Var9D:=SMA(IF(Var9B>0 AND Var9B>Var9A,Var9B,0),12,1); Var9E:=Var9C*100/Var99; Var9F:=Var9D*100/Var99; VarA0:=SMA(ABS(Var9F-Var9E)/(Var9F+Var9E)*100,12,1); VarA1:=(VarA0+REF(VarA0,5))/2; VarA2:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100; VarA3:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100; VarA4:=AMOUNT/VOL/100; VarA5:=(3*HIGH+LOW+OPEN+2*CLOSE)/7; VarA6:=SUM(AMOUNT,5)/VarA4/100; VarA7:=SUM(AMOUNT,13)/VarA4/100; VarA8:=SUM(AMOUNT,34)/VarA4/100; VarA9:=SUM(AMOUNT,209)/VarA4/100; VarAA:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4); VarAB:=VarAA/CAPITAL; VarAC:=VOL/CAPITAL*VarA5+VarAB*REF(VarA4,1); VarAD:=DMA(VarA5,VOL/VarA6); VarAE:=DMA(VarA5,VOL/VarA7); VarAF:=DMA(VarA5,VOL/VarA8); VarB0:=DMA(VarA5,VOL/CAPITAL); VarB1:=MA(HHV(HIGH,488),18); VarB2:=MA(HHV(HIGH,220),18); VarB3:=MA(HHV(HIGH,98),18); VarB4:=MA(LLV(LOW,488),18); VarB5:=MA(LLV(LOW,220),18); VarB6:=MA(LLV(LOW,98),18); VarB7:=MA((VarB4*0.96+VarB5*0.96+VarB6*0.96+VarB1*0.558+VarB2*0.558+VarB3*0.558)/6,18); VarB8:=MA((VarB4*1.25+VarB5*1.23+VarB6*1.2+VarB1*0.55+VarB2*0.55+VarB3*0.65)/6,18); VarB9:=MA((VarB4*1.3+VarB5*1.3+VarB6*1.3+VarB1*0.68+VarB2*0.68+VarB3*0.68)/6,18); VarBA:=MA((VarB7*3+VarB8*2+VarB9)/6*1.738,18); VarBB:=IF(DATE<=1021231,VarBA,VarBA*DAY); VarBC:=LOW; VarBD:=REF(LOW,1); VarBE:=SMA(ABS(VarBC-VarBD),3,1)/SMA(MAX(VarBC-VarBD,0),3,1)*100; VarBF:=MA(IF(CLOSE*1.35<=VarBB,VarBE*10,VarBE/10),3); VarC0:=LLV(LOW,30); VarC1:=HHV(VarBF,30); VarC2:=IF(LOW<=VarC0,(VarBF+VarC1*2)/2,0); WXBM:(MA(VarC2 AND CLOSE0,STICKLINE(Var7B>0,0,130,4,0),IF(Var60>0,STICKLINE(Var60>0,0,100,8,0),0)),colorred , linethick3;} 大黑马:{IF(Var61,DRAWTEXT(Var61 OR Var98,70,'★大黑马'),coloryellow; 黑马:IF(Var60>0,DRAWTEXT(Var60>0,40,'★黑马'),IF(Var7B>0,DRAWTEXT(Var7B>0,120,'★探底'),IF(WXBM,DRAWTEXT(WXBM,120,''),10))))*Var5,colorred ,linethick2;} {IF(Var61,STICKLINE(Var61,0,120,8,0),IF(Var98,STICKLINE(Var98,0,60,8,0),0))*Var5,coloryellow ,linethick3 ;} STICKLINE(Var7B>0,0,120,2,0),colorwhite; STICKLINE(Var60>0,0,80,8,0),colorred;

解答:

?Var7B:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

Var7B>0;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top