最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将MACD参数按照SHORT5 .LONG26 .MID50修改

将MACD参数按照SHORT5 .LONG26 .MID50修改

来源:网络 点击: 时间:2018-08-28

编写要求:

我想将MACD的参数按照SHORT 5 , LONG 26 ,MID 50,修改。请哪位帮忙!!!! 源码: W:=1; M:=1; MM:=9*M; SHORT:=MM*4/3; LONG:=MM*26/9; DIFF:=(EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)); DEA:=EMA(DIFF,MM),COLOR58FF58; MACD:=2*(DIFF-DEA),COLORFFFF00,LINETHICK0; 红柱:DRAWBAND(MACD,RGB(180,50,50),0,RGB(0,128,0)); 绿柱:DRAWBAND(0,RGB(0,128,0),MACD,RGB(180,50,50)); AMACD:=ABS(MACD); {STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,W,1),COLOR6058FF; STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,W,0),COLOR6058FF; STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,W,1),COLORFFFF00; STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,W,0),COLORFFFF00;} 红柱面积 := IF (MACD>0,SUM(AMACD,BARSLAST(MACD<0)),0),LINETHICK0,COLORRED; 绿柱面积 := IF (MACD<0,SUM(AMACD,BARSLAST(MACD>0)),0),LINETHICK0,COLORBLUE; BV:=SUM(MACD,0); 红转绿:=CROSS(MACD,0); 绿转红:=CROSS(0,MACD); BC:=BARSLAST(红转绿 OR 绿转红)+1; 最高红柱子:IF(MACD>0,HHV(MACD,BC),0),NODRAW; 最低绿柱子:IF(MACD<0,LLV(MACD,BC),0),NODRAW; DRAWTEXT(绿转红 ,REF(最高红柱子,1),''+REF(INTPART((红柱面积)*10)/10,1)),COLORRED; DRAWTEXT(红转绿 ,REF(最低绿柱子,1),''+REF(INTPART((绿柱面积)*10)/10,1)),COLORRED; CDIFF:DIFF;CDEA:DEA;

解答:

?W:=1;

M:=1;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top