最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把“趋势顶底”指标做个预警

把“趋势顶底”指标做个预警

来源:网络 点击: 时间:2018-08-19

编写要求:

请老师帮忙把“趋势顶底”做个预警! 预警要求如下: 1、长期线小于10, 2、买等于2, 3、金底等于1。满足这三个条件时跳出预警 先谢了,老师!!源码如下: {50,COLORRED; FILLRGN(1,20,80),COLOR222222; FILLRGN(1,90,100),COLOR000068; FILLRGN(1,79,90),COLOR663366; FILLRGN(1,10,20),COLOR666600; FILLRGN(1, 0,10),COLOR663300;} A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED; B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)); D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2; 长期线:A+100,COLOR9900FF; 短期线:B+100,COLOR888888; 中期线:D+100,COLORYELLOW,LINETHICK2; {见顶:(长期线>85 OR REF(长期线,1)>85 ) AND (CROSS(中期线,短期线) OR CROSS(REF(中期线,1),REF(短期线,1)) )AND CROSS(长期线,短期线);} 见顶:(REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线) ; 顶部区域:(中期线80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5 AND 短期线<中期线 AND 短期线<长期线+4; 顶部:=FILTER(顶部区域,4); {DRAWICON( 见顶, 108, 2 );} 底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1))) OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ; STICKLINE( {见顶 OR} 顶部,99,103,20,1 ),COLORRED,LINETHICK2; STICKLINE( 底部区域,-4,0,22,0 ),COLORGREEN; 低位金叉:长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线 AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=长期线 OR REF( 短期线,1)<1 ); STICKLINE( 低位金叉,0,5,11,0 ),COLORRED; 10,COLORCC6633,LINETHICK2; 20,COLORGREEN; 80,COLOR996699;90,COLOR9966FF,LINETHICK2; KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:="KDJ.J"(9,3,3); 买1:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND KDJ_D<26); 买2:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)); 买3:=CROSS("MACD.DIF","MACD.DEA") OR CROSS("MACD.MACD",0); 买0:=买1+买2+买3; 买:IF(买0>1,买0,0); 主力:=EMA((C-MA(C,7))/MA(C,7)*480,2)*5; 散户:=EMA((C-MA(C,11))/MA(C,11)*480,7)*5; RSI1:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100; BT1:=CROSS(RSI1,25); BT2:=CROSS(主力,散户) AND 主力<-10; 金底:FILTER(COUNT(BT1 OR BT2,3)>=2,3);

解答:

?A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);

长期线:=A+100;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top