最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 在智能看盘K线主图改为7、14、25、30、60、120日线

在智能看盘K线主图改为7、14、25、30、60、120日线

来源:网络 点击: 时间:2018-08-26

编写要求:

智能看盘主图源码: 参数m1:2.00 1000.00 5.00 m2:2.00 1000.00 30.00 m3:2.00 1000.00 120.00 m4:2.00 1000.00 250.00 五日线:MA(CLOSE,M1); 月线:MA(CLOSE,M2); 半年线:MA(CLOSE,M3); 年线:MA(CLOSE,M4); VAR1:=(2*CLOSE+HIGH+LOW)/4; VAR2:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR3:=LLV(LOW,5); VAR4:=HHV(HIGH,4); 散户:=EMA((VAR1-VAR3)/(VAR4-VAR3)*100,4)*VAR2; 庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR2; DRAWTEXT(CROSS(散户,庄家) AND 散户<47,L-0.05,'←低吸'),COLORLIRED; DRAWTEXT(CROSS(庄家,散户) AND 散户>60,H+0.05,'←高抛'),COLOR80FF00; DRAWICON(CROSS(散户,庄家) AND 散户<47,L-0.05,1); DRAWICON(CROSS(庄家,散户) AND 散户>60,H+0.05,2); 市场成本:DMA(AMOUNT/V/100,V/CAPITAL),NODRAW; 操盘成本:(MA(C,30)+MA(C,72))/2,COLORRED; 市盈率:DYNAINFO(39),COLORFF00FF,NODRAW; TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01; STICKLINE(TJ,OPEN,CLOSE,1.5,0),COLORFF00FF; 量_价:=1;CTKG:=1; W:=量_价; EPSL:=0.0001; ZZ:=(C+H+L)/3; TJA:=ZZ>=MAX(C,O) AND CTKG=1;{倒锤头}; TJB:=ZZ<=MIN(C,O) AND CTKG=1;{正锤头}; ZF:=IF(TJA,1,IF(TJB,-1,0));{正负数}; TJ0:=TJA OR TJB; TJ1:=H=L AND C>REF(C,1);{一字涨停}; TJ2:=H=L AND C=0,CLOSE,OPEN,3,0),COLOR000099; STICKLINE(量差>=0,CLOSE,OPEN,2.2,0),COLOR0000CC; STICKLINE(量差>=0,CLOSE,OPEN,1.5,0),COLOR0000FF; STICKLINE(量差>=0,CLOSE,OPEN,0.5,0),COLORCC66FF; V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1); STICKLINE(V2V,OPEN,CLOSE,0.5,0),COLORYELLOW; ZT:=C/REF(C,1)>1.097; STICKLINE(ZT,OPEN,CLOSE,0.5,0),COLORYELLOW; V3V:=V/REF(V,1)>=1.9 AND CMA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSEOPEN,VAR1*(HIGH-LOW),IF(CLOSEOPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSEOPEN,VAR5*(HIGH-LOW),IF(CLOSEOPEN,0-VAR5*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE=2; 主持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF,LINETHICK2,NODRAW; 主筹码:WINNER(C)*100 ,COLORRED,LINETHICK2,NODRAW; 散筹码:(WINNER(C*1.1)-WINNER(C*0.9))*100 ,COLOR80FF00,LINETHICK2,NODRAW; 业绩:FINANCE(33),COLORWHITE,NODRAW; STICKLINE(C>0,0,VOL,3,0),COLOR005500; STICKLINE(C>0,0,VOL,2,0),COLOR007700; STICKLINE(C>0,0,VOL,1,0),COLOR009900; STICKLINE(C>0,0,VOL,0,0),COLOR00CC00; STICKLINE(买盘>0,0,买盘,3,0),COLOR000055; STICKLINE(买盘>0,0,买盘,2,0),COLOR000077; STICKLINE(买盘>0,0,买盘,1,0),COLOR000099; STICKLINE(买盘>0,0,买盘,0,0),COLOR0000FF; STICKLINE(天量,0,买盘,0.5,1),COLORMAGENTA; STICKLINE(地量>0,0,买盘,0.5,1),COLORYELLOW;

解答:

?把以下参数填入参数栏
{参数M1:2.00 1000.00 7.00
M2:2.00 1000.00 14.00
M3:2.00 1000.00 25.00
M4:2.00 1000.00 30.00
M5::2.00 1000.00 60.00
M6:2.00 1000.00 120.00}

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top