最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将下面通达信唐能通买卖主图改成飞狐能用的公式

将下面通达信唐能通买卖主图改成飞狐能用的公式

来源:网络 点击: 时间:2019-05-25

编写要求:

AB:=CONST(HHV(H,5)); CD:=1; DRAWTEXT(CD AND CURRBARSCOUNT=30,AB-(AB*0.03),'其新组合老鸭头 芝麻点 空中加油继续涨 断头铡刀全清仓')COLORGRAY; DRAWTEXT(CD AND CURRBARSCOUNT=30,AB-(AB*0.05),'看准2+3五线上买 、2-3 五线顺下股价死 放量打拐必满仓')COLORGRAY; MA5:MA(C,5),COLORRED; MA10:MA(C,10),COLORYELLOW; MA20:MA(C,20),COLORMAGENTA; MA30:MA(C,30),COLORWHITE; MA40:MA(C,40),COLORCYAN; MA60:MA(C,60),COLORGREEN ; MA120:MA(C,120),COLORBLUE; MA240:MA(C,240),COLORBROWN; V5:=MA(VOL,5); V10:=MA(VOL,10); V20:=MA(VOL,20); LDAY1:=BARSLAST(CROSS(V5,V10)); LDAY2:=BARSLAST(CROSS(V5,V20)); LDAY3:=BARSLAST(CROSS(V10,V20)); LTJ1:=(LDAY1>LDAY2 OR LDAY1=LDAY2) {AND COUNT(CROSS(V5,V20),LDAY1)=1} AND LDAY2=0 AND V10O AND REF(C,1)REF(O,2) AND C>REF(C,2)); LTJ:=LTJ1 AND LTJ2; LTJ0:=LTJ1 AND V10>REF(V10,1); PDAY1 := BARSLAST(CROSS(MA5,MA60));{5日均线上穿60日均线} PDAY2 := BARSLAST(CROSS(MA10,MA60));{10日均线上穿60日均线,至此形成鸭颈部} PDAY3 := BARSLAST(REF(HIGH=HHV(HIGH,PDAY2),1));{形成头部,要下跌} PDAY4 := BARSLAST(CROSS(MA10,MA5){ OR (REF(MA10,1)MA10)});{回落不久,5日均线和10日均线形成金叉,形成底部} A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5; A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1; A3:=MA5>MA60 AND MA10>MA60; {JT:=CROSS(MA20,MA60) AND C>O AND REF(C,1)REF(O,2); CSFR:=CROSS(C,MA20) AND CROSS(C,MA40) AND CROSS(C,MA60); STICKLINE(JT,H,L,1,0),COLORYELLOW; STICKLINE(JT,O,C,8,0),COLORYELLOW; STICKLINE(CSFR,H,L,1,0),COLORWHITE; STICKLINE(CSFR,O,C,8,0),COLORWHITE; DRAWTEXT(CSFR,H,'出水芙蓉'),COLORMAGENTA; DRAWTEXT(JT ,L, '价托'),COLORYELLOW;} CSFR:=CROSS(C,MA20) AND CROSS(C,MA40) AND CROSS(C,MA60); YDAY1:=BARSLAST(CROSS(MA5,MA10)); YDAY2:=BARSLAST(CROSS(MA5,MA20)); YDAY3:=BARSLAST(CROSS(MA10,MA20)); YJZZ:=(YDAY1=YDAY2 AND YDAY2=YDAY3 OR (YDAY1-YDAY2=1 OR YDAY2-YDAY3=1)) AND REF(MA5,2)MA10 AND MA10>MA20 ; YJZZ1:=YDAY1=YDAY2 AND YDAY2=YDAY3 AND MA5>MA10 AND MA10>MA20 AND YDAY1=1; YJT:=YDAY1>=YDAY2 AND YDAY2=0 AND MA10=DAY2 AND DAY3<5; JZZ:=DAY1=DAY2 AND DAY2=DAY3 AND REF(MA20,1)MA40 AND MA40>MA60; TJ1:=DAY1>=DAY2 AND COUNT(CROSS(MA20,MA60),DAY1)=1{AND (DAY1-DAY2)<10}; TJ3:=VOL>REF(VOL,1); TJ4:=MA20>MA60 AND MA40>REF(MA40,1) AND MA40=DAY2 AND DAY2=0 AND MA400 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85) AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10); STICKLINE(LTJ0,H,L,1,0),COLORGREEN; STICKLINE(LTJ0,O,C,8,0),COLORGREEN; STICKLINE(TJ,H,L,1,0),COLORYELLOW; STICKLINE(TJ,O,C,8,0),COLORYELLOW; {STICKLINE(TJ22,H,L,1,0),COLORYELLOW; STICKLINE(TJ22,O,C,8,0),COLORYELLOW;} STICKLINE(LTJ,H,L,1,0),COLORYELLOW; STICKLINE(LTJ,O,C,8,0),COLORYELLOW; STICKLINE(CSFR,H,L,1,0),COLORYELLOW; STICKLINE(CSFR,O,C,8,0),COLORYELLOW; DRAWTEXT(CSFR,H,'↖出水芙蓉'),COLORMAGENTA; DRAWTEXT(TJ,L-0.2, '↖放量突破'),COLORYELLOW; {DRAWTEXT(TJ22,H+0.2, '↖轻松过顶'),COLORBLUE;} DRAWTEXT(LTJ,H+0.5,'↖量托+多方炮'),COLORRED; DRAWTEXT(LTJ0,H+0.5,'↖量托'),COLORYELLOW; DRAWTEXT(TJ5,MA60-0.2,'↖季价托'),COLORCYAN; DRAWTEXT(YJT,MA20-0.5,'↖月价托'),COLORCYAN; DRAWTEXT(JZZ,MA60-0.2,'↖金蜘蛛'),COLORWHITE; DRAWTEXT(YJZZ OR YJZZ1,MA20-0.2,'↖月金蜘蛛'),COLORWHITE; 老鸭头:=(A1 AND A2 AND A3) AND FILTER(A1 AND A2 AND A3 ,5); DRAWTEXT(老鸭头,L,'↖老鸭头'),COLORGREEN; STICKLINE(老鸭头,H,L,0.5,0),COLORGREEN; STICKLINE(老鸭头,O,C,6,1),COLORGREEN,LINETHICK3; STICKLINE(C>=O,H,L,0,0),COLORRED; STICKLINE(C=O,C,O,4,1),COLORRED; STICKLINE(CGDCS2,0,1); AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1); QY1X:=BACKSET(AA1,LOWN+1); CC1:=FILTER(QY1X,LOWN) AND L=LLV(L,LOWN+1); DRAWICON(CC1,L*0.98,7); DD1:=BARSLAST(CC1); DDTS:=IF(CC1,CURRBARSCOUNT,0); YDB:=IF(DD1,REF(L,DD1),L); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS); DDCS1:=CONST(DDTS1); ZDB:=REF(YDB,DD1+1); DDTS2:=REF(DDTS1,DD1+1); DDCS2:=CONST(DDTS2); M:=INTPART(3*8/5); A12:=REF(H,M)=HHV(H,2*M+1); B12:=FILTER(A12,M); C12:=BACKSET(B12,M+1); D12:=FILTER(C12,M);{高点} R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1); DRAWLINE(D12,H,S112,H,1),COLORGREEN; A22:=REF(L,M)=LLV(L,2*M+1); B22:=FILTER(A22,M); C22:=BACKSET(B22,M+1); D22:=FILTER(C22,M);{低点} T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1); DRAWLINE(D22,L,U112,L,1),COLORRED; 底:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1),COLORGRAY,LINETHICK1; 头:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1),COLORGRAY,LINETHICK1; 断头铡刀:=MA5C AND MA10>MA20 AND MA20>MA60 AND CLOSEREF(压力2,1),C*0.99,C,4,0),COLORYELLOW; 底部:=LLV(HIGH,30),COLORMAGENTA; 底部位:=IF(ISLASTBAR,底部,DRAWNULL); STICKLINE(ISLASTBAR ,底部位,底部位,100,0),LINETHICK4,COLORMAGENTA; A:=V*100/CAPITAL; VAR22:=100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)); VAR23:=MA(VAR22,3); VAR24:=EMA(AMOUNT/VOL/100,5); VAR25:=EMA(AMOUNT/VOL/100,13); VAR26:=VAR24-VAR25; VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21)) )); VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21)) )); VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6)) ),34)); DRAWTEXT(CROSS(VAR2,MA(VAR3,6)) AND CROSS(IF(1000*VAR26/VAR24>0,1000*VAR26/ VAR24,0) *0.19+1.9,IF((HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*120>100,100, (HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*120)*0.07),(LOW * 0.984), '↖强牛股出现 '),COLORWHITE; VAR0:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0); VAR01:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3); VAR02:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3); VAR03:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3); VAR04:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3); VAR05:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3); VAR06:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3); VAR07:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3); VAR08:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3); VAR09:=EMA(CLOSE,2)-EMA(CLOSE,150); 买1:=VAR0; 买2:=(VAR01+VAR03+VAR05+VAR07); 卖1:=(VAR02+VAR04+VAR06+VAR08); 买:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),,COLORRED; DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'↖买'),COLORRED;

解答:

?CURRBARSCOUNT:=DATACOUNT-BARPOS+1;

AB1:=HHV(H,5);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top