最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把百发百中指标改成大智慧,并做选股

把百发百中指标改成大智慧,并做选股

来源:网络 点击: 时间:2018-08-25

编写要求:

源码: BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100; BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100; BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100; MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6; MN:=MA(MM,3); VAR24:=LLV(LOW,36); VAR25:=HHV(HIGH,30); VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25; 底背离:IF(MN<-4 ,17,0),COLORA67D3D,LINETHICK3; 顶背离: IF((VAR26>90),17,0), COLOR6B238E,LINETHICK3; IF(MN<-4 ,12,0),COLORBLACK,LINETHICK3; IF((VAR26>90),12,0), COLORBLACK,LINETHICK3; DRAWTEXT(底背离,6,'底背离'),COLORA67D3D; DRAWTEXT(顶背离,6,'顶背离'),COLORGREEN; N:=20; MID:=MA(C,N); VART1:=POW((C-MID),2); VART2:=MA(VART1,N); VART3:=SQRT(VART2); UPPER:=MID+2*VART3; LOWER:=MID-2*VART3; BOLL:=REF(MID,1); UB:=REF(UPPER,1); LB:=REF(LOWER,1); LOWER1:=MID-VART3; LB1:=REF(LOWER1,1); 股价线:(C-LB1)/(UB-LB)*100,COLORGREEN, LINETHICK1; 趋势线:MA(股价线,6),COLORRED, LINETHICK3; 90,COLORGREEN, LINETHICK1; 50,COLORWHITE, LINETHICK1; 0,COLORWHITE, LINETHICK1; VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1); 准备建仓:EMA(IF(L<= LLV(L,30),VARC,0),3),COLORFF00FF,LINETHICK2; VARO5:=LLV(LOW,27); VARO6:=HHV(HIGH,34); VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25; 建仓区: IF((VARO7<10),80,100) ,COLORFFFF00,LINETHICK3; IF((VARO7<10),85,100) ,COLORBLACK,LINETHICK2; 下单: IF(CROSS(3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),10),38,0),STICK ,COLORYELLOW, LINETHICK4; DRAWTEXT(下单,38,'下单!'),COLORGREEN; BIAS1:=(C-MA(C,6))/MA(C,6)*100; BIAS2:=(C-MA(C,12))/MA(C,12)*100; BIAS3:=(C-MA(C,24))/MA(C,24)*100; BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6; 乖离1:=MA(BIAS,3); 乖离:IF(CROSS(BIAS,乖离1) AND 乖离1<-9,28,0),COLORRED,LINETHICK2; IF(CROSS(BIAS,乖离1) AND 乖离1<-9,18,0),COLORRED,LINETHICK2; STICKLINE(CROSS(BIAS,乖离1) AND 乖离1<-9,-12,0,6,0),COLORYELLOW; DRAWTEXT(乖离,18,'低买'),COLORRED; TRJ:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5); HD:=(HIGH - REF(HIGH,1)); LD:=(REF(LOW,1) - LOW); DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) ); DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5); 神偷线:=(((DMP ) * 100) / TRJ); 辅助线:=((DMM * 100) / TRJ); 动向趋势线:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),3)); ADXR:=((动向趋势线 + REF(动向趋势线,3)) / 2); VAR3:=MA(CLOSE,2); VAR7:=REF(VAR3,1); 【强弱】:=((SMA(MAX((VAR3 - VAR7),0),5,1) / SMA(ABS((VAR3 - VAR7)),5,1)) * 100); 快买:( IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),68,0)),LINETHICK1,COLORFF00FF; ( IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),48,0)),LINETHICK1,COLORFF00FF; DRAWTEXT(快买,60,'准备'),COLORFF00FF; MA2:=EMA(C,2);MA5:=EMA(C,5);MA13:=EMA(C,13);MA30:=EMA(C,30);MA55:=EMA(C,55);YCX:=MA5>=REF(MA5,1);H1:=MAX(MAX(MA5,MA13),MA30);L1:=MIN(MIN(MA5,MA13),MA30);一阳穿三线:= H1REF(MA2,1);满仓选股:IF(一阳穿三线,88,0),COLORFFFF00,LINETHICK2; IF(一阳穿三线,58,0),COLORFFFF00,LINETHICK2; DRAWTEXT(一阳穿三线,88,'满仓'),COLORYELLOW; VAR2:=0.0001*AMOUNT,; MA1:=0.0001*MA(AMOUNT,5); M2:=0.0001*MA(AMOUNT,10); 百日地量:LLV(VAR2,100)=VAR2,STICK,COLORRED,LINETHICK0; DRAWTEXT(百日地量,-10,'地量'),COLORRED; DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); {选股设JC=10即可} DEA:=EMA(DIFF,9); MACD:=2*(DIFF-DEA); A:=IF(CROSS(0,DEA),1,0); A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0); SS:=IF(A,SUM(A1,0),0); SSB:=HHV(SS,0); SSS:=SUM(A1,0); JC:IF(SSS-SSB=2 AND SSS>REF(SSS,1),-22,0),LINETHICK2,COLORFFFF00; IF(SSS-SSB=2 AND SSS>REF(SSS,1),-12,0),LINETHICK2,COLORFFFF00; DRAWTEXT(A1,-10,'W底'),COLORYELLOW; VAR1:=(CLOSE*2+HIGH+LOW)/4; SK:= EMA(VAR1,13)-EMA(VAR1,73); SD:= EMA(SK,2); V1:(CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)); IF(V1,28,0),COLORYELLOW,LINETHICK2; IF(V1,18,0),COLORYELLOW,LINETHICK2; DRAWTEXT(V1,28,'买点'),COLORRED; AA05:=MA(C,5); 五日乖离率:=(C-AA05)/AA05*100; BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416; 速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1); 加速度5:=EMA((速度5-REF(速度5,1)),3); AA10:=MA(C,10);AA20:=MA(C,20); BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416; AA30:=MA(C,30); 三拾日乖离率:=(C-AA30)/AA30*100; (AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1); (AA30-AA20)30 AND BB10>45 AND CROSS(BB05,60),10); 加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ; MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1) (LOW * 1.051)) AND (COUNT((HIGH > (LOW * 1.051)),5) > 1)) AND ((((CLOSE / MA(CLOSE,40)) * 100) < 78) OR (((CLOSE / MA(CLOSE,60)) * 100) < 74))),2,0) AND (SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100)<15 AND IF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)>REF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1) AND REF(SMA((CLOSE-LLV(LOW,8))/ (HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1)0.02 OR C>REF(C,1)*1.01) AND V1.1,5)>3),3) ; DRAWTEXT(QUAN,88,'弱市百发百中'),COLORFFFF00; IF(QUAN,88,0),COLORFFFF00,LINETHICK2; IF(QUAN,60,0),COLORFFFF00,LINETHICK2; AA:=1; BB:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100; CC:=IF(AMOUNT/C/HHV(AMOUNT,9)/HHV(C,9)*100>100,100,AMOUNT/C/HHV(AMOUNT,9)/HHV(C,9)*100); DD:=CC/BB; 顶部雷达:CROSS(80,RSI)*88,LINETHICK2 ,COLORGREEN; CROSS(80,RSI)*58,LINETHICK2 ,COLORGREEN; DRAWTEXT(CROSS(80,RSI),88,'逃顶 '),COLORGREEN;

解答:

?BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

标签:

    上一篇:止跌回升公式 下一篇:写出笑脸和哭脸的选股

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top