最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把超级黄金公式改成选股公式

把超级黄金公式改成选股公式

来源:网络 点击: 时间:2019-05-12

编写要求:

请老师将出现紫色向上三角形改成选股公式 DRAWTEXTABS(30,0,BKNAME ); DRAWTEXTABS(30,15,'流通盘:'+CAPITAL/100+'万股,利润增长:'+FINANCE2(10)+'%。每股收益:'+FINANCE2(3)+'元。' ),colorwhite; DRAWTEXTABS(30,30,'B买入,S卖出。' ),colorwhite; MID : MA(CLOSE,N),CIRCLEDOT,COLORyellow,linethick1; UPPER: MID + P*STD(CLOSE,N),COLORwhite; LOWER: MID - P*STD(CLOSE,N),COLORblue; k1:=UPPER; K2:=LOWER; k3:=ma(c,14); 买线:=EMA(C,2); 卖线:EMA(SLOPE(C,21)*20+C,42),pointdot,COLORwhite,linethick3; BU:=cross(买线,卖线); SEL:=cross(卖线,买线); drawtext(bu,LOW*0.99,'B'),coloryellow,linethick2; drawtext(sel,HIGH*1.04,'S'),color00CC00,linethick2; stickline(买线>=卖线,low,high,0.1,0),colorred; stickline(买线>=卖线,close,open,7,0),colorred; 左侧:=买线-卖线; DRAWGBK(左侧>0,STRIP(RgB(20,50,180),RGB(50,50,50),0)),LAYER0; 工作线:=MID; A2:="cpzb@cp"; STICKLINE((A2 >= 8),H,L,0.8,1),colorGreen; STICKLINE(((A2 >= 8) AND (C > O)),O,C,8,1),colorGreen; STICKLINE(((A2 >= 8) AND (C < O)),C,O,8,0),colorGreen; STICKLINE(((A2 > 0) AND (A2 <= 2)),H,L,0.8,1),colorRed; STICKLINE((((A2 > 0) AND (A2 <= 2)) AND (C > O)),O,C,8,1),colorRed; STICKLINE((((A2 > 0) AND (A2 <= 2)) AND (C < O)),C,O,8,0),colorRed; DRAWTEXT((A2 = 1),L,' ̄'),linethick2,ALIGN1,Color208FFF; DRAWTEXT((A2 = 1),L,'B'),linethick5,ALIGN1,colorYellow; DRAWTEXT((A2 = 9),H,' ̄'),linethick2,ALIGN1,colorCyan; DRAWTEXT((A2 = 9),H+0.38,'S'),linethick5,colorCyan; STICKLINE((A2 = 9),C,O,0,0),colorWhite; STICKLINE((A2 = 9),C,O,8,0),colorWhite; STICKLINE((A2 = 9),C,O,7,0),ColorDDDDDD; STICKLINE((A2 = 9),C,O,6,0),ColorCCCCCC; STICKLINE((A2 = 9),C,O,5,0),colorWhite; STICKLINE((A2 = 9),C,O,4,0),ColorEEEEEE; STICKLINE((A2 = 9),C,O,3,0),ColorDDDDDD; STICKLINE((A2 = 9),C,O,2,0),ColorCCCCCC; STICKLINE((A2 = 9),C,O,1,0),colorWhite; STICKLINE((A2 = 1),C,O,0,0),ColorFFBBFF; STICKLINE((A2 = 1),C,O,8,0),colorMagenta; STICKLINE((A2 = 1),C,O,7,0),ColorFF22FF; STICKLINE((A2 = 1),C,O,6,0),ColorFF44FF; STICKLINE((A2 = 1),C,O,5,0),ColorFF66FF; STICKLINE((A2 = 1),C,O,4,0),ColorFF88FF; STICKLINE((A2 = 1),C,O,3,0),ColorFF99FF; STICKLINE((A2 = 1),C,O,2,0),ColorFFAAFF; STICKLINE((A2 = 1),C,O,1,0),ColorFFBBFF; STICKLINE(((C < 卖线) AND (C >= O)),H,L,0.5,1),Colorgreen; STICKLINE(((C < 卖线) AND (C >= O)),O,C,8,1),Colorgreen; STICKLINE(((C < 卖线) AND (C <= O)),H,L,0.5,0),Colorgreen; STICKLINE(((C < 卖线) AND (C <= O)),O,C,8,0),Colorgreen; 高1:=REF(HHV(H,120),3); 低1:=REF(LLV(L,120),3);H1:=高1-(高1-低1)*0.191; H2:=高1-(高1-低1)*0.382; H3:=高1-(高1-低1)*0.5; H4:=高1-(高1-低1)*0.618; H5:=高1-(高1-低1)*0.809; 突破:=REF(EMA(C,14),1); A1X:=(EMA(C,10)-突破)/突破*100; 基准:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1)); stickline(A1X>=0,突破,突破,10,0),coloryellow,LAYER6; stickline(A1X<0,突破,ref(突破,1),0,-1000),LAYER6;{} STICKLINE(A1X>=0,基准,突破,10,0),COLOR000099,LAYER6; STICKLINE(A1X<0,基准,突破,10,0),COLORccCC66,LAYER6; G:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3); X:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3); DRAWTEXT(G,L*0.997,'▲'),ALIGN1,VALIGN0,Colorff00ff; DRAWTEXT(G,L,' ̄'),ALIGN1,VALIGN0,Color00ff00; DRAWTEXT(X,H*1.002,'▼'),ALIGN1,VALIGN2,Color00ffff; DRAWTEXT(X,H,' ̄'),ALIGN1,VALIGN0,Color00ffff; A7:=(2*C+H+L)/4; 短撑:LLV(a7,21),coloryellow,linethick2; lowave:=(ema(low,10)+ema(low,20)+ema(low,30))*0.28; highave:=(ema(high,10)+ema(high,20)+ema(high,30))*0.382; 短压:ema(highave,18),COLORyellow,linethick2; DRAWTEXTABS(620,15,'★铁律:按大盘个股30分钟操盘纪律进出 ' ),coloryellow; DRAWTEXTABS(670,30,'买入出击组合 卖出逃命组合' ),coloryellow;

解答:

?ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top