最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把反弹和加仓改成选股公式

把反弹和加仓改成选股公式

来源:网络 点击: 时间:2019-05-25

编写要求:

选出当天出现反弹和加仓,谢谢 老师我没有共享币了,请把源码直接帖出来谢谢。 底:=SUM(MA(CLOSE,10),9)/11.114; DRAWTEXT(CROSS(LOW,底) AND REF(底,1)>REF(HIGH,1) OR CROSS(HIGH,底),0.85*CLOSE,'---铁底'),color00FF00; X1:=(3*CLOSE+HIGH+LOW+OPEN)/6; X2:=EMA(X1,10); X3:=REF(X2,1); X4:=(REF(HIGH,1)+REF(LOW,1))/2; X5:=MA(CLOSE,21)+2*STD(CLOSE,21); X6:=REF(CLOSE,1); X7:=(SMA(MAX(CLOSE-X6,0),7,1))/(SMA(ABS(CLOSE-X6),7,1))*100; X8:=CROSS(79,X7); X9:=FILTER(X8,4); WZ1:=POW(MA(CLOSE,5),2)+MA(CLOSE,5); WZ2:=POW(MA(LOW,5),2)+MA(LOW,5); WZ3:=POW(MA(HIGH,5),2)+MA(HIGH,5); WZ4:=(WZ1-LLV(WZ2,9))/(HHV(WZ3,9)-LLV(WZ2,9))*150+65; DK:=SMA(WZ4,3,1)*1.5; DD:=SMA(DK,3,1); DJ:=3*DK-2*DD; WZ5:=EMA(CLOSE,12)-EMA(CLOSE,26); WZ6:=EMA(WZ5,9); WZ7:=2*(WZ5-WZ6); WZ8:=REF(WZ7,1); WZ9:=CROSS(WZ8,WZ7) AND WZ8>0; VAR1T:=EMA(CLOSE,8); VAR2T:=EMA(VAR1T,20); VAR3T:=CROSS(VAR1T,VAR2T); VAR4T:=VAR1TLLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR8T; VARA:=IF(CLOSE>1000,VAR8T,VAR9T); 起步:=VAR3T AND VAR4T; 逃遁:=VARA; XL1:=EMA(CLOSE,10)/100; XL2:=MA((XL1-REF(XL1,10))/REF(XL1,10),3)*100; XL3:=MA(XL2,3); XL4:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1); DRAWTEXT(IF(CROSS(3*XL4-2*SMA(XL4,3,1),8),87,0) AND X2>X3,LOW-0.1,'←反弹'),colorred; DRAWTEXT(IF(CROSS((VAR1T-LLV(VAR1T,4))/(HHV(VAR1T,4)-LLV(VAR1T,4))*4*25,87.5) AND VAR1T<40,87,0) AND X2>X3,LOW-0.15,'←短买'),colorFFFF00; DRAWTEXT(IF(CROSS(2*(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26)-(EMA(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26),2)))*5.8,0.47),LOW,0) AND X2>X3,LOW-0.2,'←加仓'),colorFF5ED8; DRAWTEXT(CROSS(X4,X5),HIGH*1.01,'←减'),color00FF00; DRAWTEXT(FILTER((WZ9 AND DJ>250) OR X9 ,5),HIGH*1.02,'←跑'),colorBCFF8B; STICKLINE(起步>0,HIGH,LOW,0.8,0),color00FFFF; STICKLINE(起步>0,OPEN,CLOSE,5,0),color00FFFF; DRAWTEXT(逃遁>0,HIGH*1.04,'●←逃'),color7FFFD6; sam:=(C+L+H)/3; BB13:=ATAN(EMA(sam,13)-REF(EMA(sam,13),1))*3.1416*10; EMA8:=EMA(C,8); DRAWTEXT(FILTER(BB13>1 AND EMA(sam,13)>REF(EMA(sam,8),1),10), EMA8,'∠45上升'),COLORWHITE; VAR3aa:=IF((CLOSE>REF(CLOSE,1)),88,0); VAR4aa:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3aa>0),91,0); DRAWTEXT(FILTER((VAR4aa>90),45),(LOW)*(0.94999998),'★大胆搏 '),Color00FFFF; L23:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; L24:=(HIGH+LOW+CLOSE)/3; L25:=(L24-MA(L24,14))/(0.015*AVEDEV(L24,14)); L26:=(L24-MA(L24,70))/(0.015*AVEDEV(L24,70)); L27:=IF(L25>=150 AND L25<200 AND L26>=150 AND L26<200,10,0); L28:=IF(L25<=-150 AND L25>-200 AND L26<=-150 AND L26>-200,-10,L27); L29:=100-ABS((CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100); L30:=IF(L29<90,L29,100); L31:=IF(L23>0,L23,0); XL1:=(IF(L28>=200 AND L25>=150,15,IF(L26<=-200 AND L25<=-150,-15,L28)))+60; XL2:=L31>48 AND XL1>60 AND L30<100; DRAWTEXT(XL2 AND COUNT(XL2,30)=1,l,'大笔成交'),colorFF00FF; MTM:=C-REF(C,1); DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6); 买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0); DRAWTEXT(filter(买=1,5),LOW-0.3,'▲拉升'),Colormagenta; {放量股价上穿布林中轨} 放量:=close>ma(close,24) and vol/ref(vol,1)>2; DRAWTEXT(放量,low-0.3,'放量'),Colorgreen;

解答:

?X1:=(3*CLOSE+HIGH+LOW+OPEN)/6;

X2:=EMA(X1,10);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top