最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 合并一个(低位公式

合并一个(低位公式

来源:网络 点击: 时间:2019-03-14

编写要求:

请老师帮忙将(低位公式)用‘绿色箭头’加入第二个公式的下面,谢谢!!!!!! (低位公式): 公式Y1:=C/REF(C,1)>0.905 AND C/REF(C,1)<1.05; VAR2:=IF(EMA(C,10)/EMA(EMA(C,30),16)<0.85 AND Y1 AND V/CAPITAL*100<5,50,0); VAR3:=(-100)*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))+100; VAR4:=(-100)*(HHV(H,50)-C)/(HHV(H,50)-LLV(L,50))+100; VAR5:=(-100)*(HHV(H,70)-C)/(HHV(H,70)-LLV(L,70))+100; VAR6:=((C-MA(C,34))/MA(C,34)*100+10)*5; VAR7:=((C-MA(C,50))/MA(C,50)*100+10)*5; VAR8:=((C-MA(C,70))/MA(C,70)*100+10)*5; VAR9:=(VAR3+VAR4+VAR5+VAR6+VAR7+VAR8)/6; VARC:=(VAR9+ABS(VAR6-VAR8))/2; VARD:=(-1)*(EMA(100*(1-WINNER(C)),1)-50)+50; VARF:=IF(VAR2>0 AND VARD+VARC<0,1,0); 反弹:VARF*200; 第二个公式: VAR1:=(C+H+O+L)/4; 卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2; 买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA, LINETHICK2; 幅度:100*(卖出-买入)/买入,NODRAW; MA1:=MA(VAR1,3); STICKLINE(卖出>LOW AND 卖出MIN(C,O) AND 卖出LOW AND 卖出LOW AND 买入MIN(C,O) AND 买入LOW AND 买入HIGH,OPEN,CLOSE,3,0),COLORMAGENTA; STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA; DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'买'),COLORRED,LINETHICK2; DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'卖'),COLORGREEN;

解答:

?N:=10;P1:=5;M:=3;P2:=3;
Y1:=C/REF(C,1)>0.905 AND C/REF(C,1)<1.05;
VAR2:=IF(EMA(C,10)/EMA(EMA(C,30),16)<0.85 AND Y1 AND V/CAPITAL*100<5,50,0);
VAR3:=(-100)*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))+100;
VAR4:=(-100)*(HHV(H,50)-C)/(HHV(H,50)-LLV(L,50))+100;
VAR5:=(-100)*(HHV(H,70)-C)/(HHV(H,70)-LLV(L,70))+100;
VAR6:=((C-MA(C,34))/MA(C,34)*100+10)*5;
VAR7:=((C-MA(C,50))/MA(C,50)*100+10)*5;
VAR8:=((C-MA(C,70))/MA(C,70)*100+10)*5;
VAR9:=(VAR3+VAR4+VAR5+VAR6+VAR7+VAR8)/6;
VARC:=(VAR9+ABS(VAR6-VAR8))/2;
VARD:=(-1)*(EMA(100*(1-WINNER(C)),1)-50)+50;
VARF:=IF(VAR2>0 AND VARD+VARC<0,1,0);


VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA, LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出 STICKLINE(卖出>MIN(C,O) AND 卖出LOW AND 卖出LOW AND 买入MIN(C,O) AND 买入LOW AND 买入HIGH,OPEN,CLOSE,3,0),COLORMAGENTA; STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA; DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'买'),COLORRED,LINETHICK2; DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'卖'),COLORGREEN;

DRAWICON(VARF,买入*0.998,1);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top