最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > MACD+KDJ+RSI顶底背离指标改为通达信可用

MACD+KDJ+RSI顶底背离指标改为通达信可用

来源:网络 点击: 时间:2019-02-16

编写要求:

请老师将此同花顺的MACD+KDJ+RSI顶底背离指标改为通达信可用谢谢 底:-50; 顶:50; TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14); HD := HIGH-REF(HIGH,1); LD := REF(LOW,1)-LOW; PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14); MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14); PDI:= PDM*100/TR; MDI:= MDM*100/TR; A1:=BARSLAST(REF(CROSS("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1)); B1:=REF(C,A1+1)>C AND REF("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) AND CROSS("macd.diff"(12,26,9),"macd.dea"(12,26,9)); A2:=BARSLAST(REF(CROSS("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1)); B2:=REF(C,A2+1)>C AND REF("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) AND CROSS("kdj.k"(9,3,3),"kdj.d"(9,3,3)); A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1)); B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)); C1:=BARSLAST(REF(CROSS("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1)); D1:=REF(C,C1+1)"macd.diff"(12,26,9) AND CROSS("macd.dea"(12,26,9),"macd.diff"(12,26,9)); C2:=BARSLAST(REF(CROSS("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1)); D2:=REF(C,C2+1)"kdj.k"(9,3,3) AND CROSS("kdj.d"(9,3,3),"kdj.k"(9,3,3)); C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1)); D3:=REF(C,C3+1)"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)); C4:=BARSLAST(REF(CROSS(MDI,pdi),1)); D4:=REF(C,C+1)MDI AND CROSS(MDI,pdi); A4:=BARSLAST(REF(CROSS(PDI,MDI),1)); B4:=REF(C,A4+1)>C AND REF(pdi,A4+1)

0,-50,0),COLOR0099FF,POINTDOT; DRAWTEXT(DMI底背,-5,'DMI底背'),color0099FF; DMI顶背:IF(D4>0,50,0),colorblue,POINTDOT; DRAWTEXT(DMI顶背,15,'DMI顶背'),colorblue; MACD底背:IF(B1>0,-50,0),colorred,POINTDOT; DRAWTEXT(MACD底背,-15,'MACD底背'),colorred; KDJ底背:IF(B2>0,-50,0),colorff00ff,POINTDOT; DRAWTEXT(KDJ底背,-25,'KDJ底背'),COLORff00ff; RSI底背:IF(B3>0,-50,0),coloryellow,POINTDOT; DRAWTEXT(RSI底背,-35,'RSI底背'),coloryellow; MACD顶背:IF(D1>0,50,0),color00ff00,POINTDOT; DRAWTEXT(MACD顶背,25,'MACD顶背'),COLOR00ff00; KDJ顶背:IF(D2>0,50,0),colorffcc66,POINTDOT; DRAWTEXT(KDJ顶背,35,'KDJ顶背'),COLORffcc66; RSI顶背:IF(D3>0,50,0),colorffffff,POINTDOT; DRAWTEXT(RSI顶背,45,'RSI顶背'),COLORffffff; STICKLINE(B1>0,-50,0,2,0),colorred; STICKLINE(B2>0,-50,0,2,0),colorff00ff; STICKLINE(B3>0,-50,0,2,0),coloryellow; STICKLINE(d1>0,50,0,2,0),color00ff00; STICKLINE(d2>0,50,0,2,0),colorffcc66; STICKLINE(d3>0,50,0,2,0),colorwhite; STICKLINE(B4>0,-50,0,2,0),color0099ff; STICKLINE(D4>0,50,0,2,0),colorblue;

解答:

?底:-50;

顶:50;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top