最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 经典大智慧的轨道

经典大智慧的轨道

来源:网络 点击: 时间:2019-02-13

编写要求:

牛熊分界线:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),COLOR0000FF; 年线:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL); M:=MA(C,3); N:=MA(C,7); 买2:=CROSS(MA(CLOSE,3),MA(CLOSE,7)); DRAWTEXT(买2,LOW*0.97,'㊣' ),COLORYELLOW;{3日上穿7日} 买:=M>REF(M,1) AND REF(M,1) =REF(上,1),RGB(255,0,255)),CIRCLEDOT; PARTLINE(中,中>=REF(中,1),RGB(255,0,255)),CIRCLEDOT; PARTLINE(下,下>=REF(下,1),RGB(255,0,255)),CIRCLEDOT; XA:=(REF(CROSS(C,上),1) AND C>上); DRAWTEXT(XA,上*0.99,'●'),COLORBB0000; XG:=(REF(CROSS(C,中),1) AND C>中); DRAWTEXT(XG,中*0.99,'★'),COLOR0000FF; XB:=(REF(CROSS(C,下),1) AND C>下); DRAWTEXT(XB,下,'弹'); 均线5角度:=atan((MA(C,5)/ref(MA(C,5),3)-1)*100)*180/3.14159; 均线10角度:=atan((MA(C,10)/ref(MA(C,10),3)-1)*100)*180/3.14159; 均线20角度:=atan((MA(C,20)/ref(MA(C,20),3)-1)*100)*180/3.14159; 均线30角度:=atan((MA(C,30)/ref(MA(C,30),3)-1)*100)*180/3.14159; 均线60角度:=atan((MA(C,60)/ref(MA(C,60),3)-1)*100)*180/3.14159; 均线125角度:=atan((MA(C,125)/ref(MA(C,125),3)-1)*100)*180/3.14159; 均线250角度:=atan((MA(C,250)/ref(MA(C,250),3)-1)*100)*180/3.14159; DRAWTEXTABS(5,10,'■5天均线角度:'+NUMTOSTRN(均线5角度,2)+''),ColorFFFFFF; DRAWTEXTABS(160,10,'■10天均线角度:'+NUMTOSTRN(均线10角度,2)+''),ColorFFFFFF; DRAWTEXTABS(315,10,'■20天均线角度:'+NUMTOSTRN(均线20角度,2)+''),ColorFFFFFF; DRAWTEXTABS(515,10,'■30天均线角度:'+NUMTOSTRN(均线30角度,2)+''),ColorFFFFFF; DRAWTEXTABS(5,25,'■60天均线角度:'+NUMTOSTRN(均线60角度,2)+''),ColorFFFFFF; DRAWTEXTABS(160,25,'■125天均线角度:'+NUMTOSTRN(均线125角度,2)+''),ColorFFFFFF; DRAWTEXTABS(315,25,'■250天均线角度:'+NUMTOSTRN(均线250角度,2)+''),ColorFFFFFF; XF:=均线5角度>=45 AND 均线10角度>=60 AND 均线20角度>=45; DRAWTEXT(XF,下*0.99,'∠'),COLORRED; XP:=XG AND XF; XL:=XA AND XF; DRAWTEXT(XP,上*1.025,'←中牛'); DRAWTEXT(XL,上*1.025,'←强牛'); VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3); VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3); VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3); VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3); VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3); VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3); VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3); VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3); 卖1:=(VAR12+VAR14+VAR16+VAR18); DRAWTEXT(卖1>0,HIGH*1.02,'←卖出'),CROSSDOT,LINETHICK1,COLORGREEN;

解答:

?牛熊分界线:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),COLOR0000FF;

年线:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top